Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Won't let me unzip .dll file


18 Aug 2010   #1

windows 7
 
 
Won't let me unzip .dll file

First of all, I'm sorry if I'm in the wrong place. I don't mean to be, I just don't know where else to ask this.

Second, my problem is that, when I try to unzip a .dll file, well d3dx9_42.dll, I get a message saying I may need admin privileges. However, after looking through these forums for some time, I have found no solution. I have run cmd as an admin, successfully used the 'net user administrator' idea, it isn't doing anything, and tried to take ownership of the .dll.(Couldn't do that, something about an invalid argument/option.) I also tried uninstalling and re-installing the program that needs the file to run, and that didn't work either. If there is anything I have missed, or am missing, help would be appreciated.

PS-I am running Windows 7, but I'm not sure if its 32 0r 64 bit and am currently scanning the system in the cmd prompt.

My System SpecsSystem Spec
.

18 Aug 2010   #2

Win 7 Ultimate (64-bit), Win 8.1.1 (64-bit)
 
 

DLL files do contain a library of functions but they can't be unzipped because they aren't an archive of compressed files.
My System SpecsSystem Spec
18 Aug 2010   #3
Arc

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium 64 Bit SP 1
 
 

Welcome aboard . You may try the method one Take Ownership of file - Vista Forums . But actually why do you want to unzip it ? Is it possible to fulfill your need without such an unzipping ?

You may have an access to that dll through Resource Hacker or Restorator 2007 .
My System SpecsSystem Spec
.


19 Aug 2010   #4

windows 7
 
 

I don't think it is possible to get what I want without unzipping because the site I downloaded the dll on says it is compressed and it has to be unzipped. But, if I don't have to unzip it in the first place, that might be causing the problem? Oh, and I did try the first method of taking ownership. Neither way worked.

PS, I just got the game working by downloading the newest Direct X update. Didn't even know it was out of date, or that it could be updated, but fortunately, the problem is fixed. Thank you both for giving me the advice you did. I half expected to be ignored, and was very glad not to be. If I ever have a problem again, I'll have to remember this place.
My System SpecsSystem Spec
20 Aug 2010   #5

Win 7 Ultimate (64-bit), Win 8.1.1 (64-bit)
 
 

What extension does the file have? If it has an extension of .zip then it needs to be unzipped, if .dll then it doesn't need to be unzipped.
My System SpecsSystem Spec
20 Aug 2010   #6

Windows 7 Professional x64
 
 

d3dx9_42.dll appears to belong to DirectX.
My System SpecsSystem Spec
Reply

 Won't let me unzip .dll file




Thread Tools



Similar help and support threads for2: Won't let me unzip .dll file
Thread Forum
Solved imbedded win7 zip/unzip program General Discussion
Solved Can't unzip a .zip driver file Software
Solved Win 7 HP Native Zip/Unzip Program General Discussion
64 bit command line unzip utility Software
Free unzip utilities? Software
Unzip rar Files without Password Software
Unzip EXE file problems General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:43 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33