Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet Problem?


23 Aug 2010   #1

Windows 7 Home Premium 32bit
 
 
Internet Problem?

When i am surfing the web on internet explorer there are a lot of times when my pages dont load or load VERY slow. In the tab it will say "Connecting..." with the blue loading circle.

Also when i checked my internet speed some sites could not verify my upload speed while others were saying it 0.07Mbps.

And i have comcast high speed internet off my laptop running on a router

Can anyone tell me why is this happening?

Thanks


My System SpecsSystem Spec
.

23 Aug 2010   #2

Win7 x64 Ultimate SP1
 
 

Have you run Speedtest?
What speeds dose your carrier you should have?

Ken
My System SpecsSystem Spec
23 Aug 2010   #3

 

Could be so many things. But sometimes, and I have had this problem with Comcast in the past, they throttle your connection. IDK Why, but it happened to me when I first signed up them. I had a 6meg pipe, and I was downloading at like 23k a second.

I called them (in a huff) and told them to return all my money I had paid during set up, because I wasn't going to pay $$$ for a 6MB pipe while I'm only downloading at 23k p/s. The next day, everything was fine, and I was zooming happily across the highway.

Of course, it could be any number of reason's why. You'd need to provide some more background about your problem. When did it start? What changes did you make to your PC before this problem appeared? Any other symptoms show up on your PC at the same time this one did? And what have you already done to try to resolve it?
My System SpecsSystem Spec
.


23 Aug 2010   #4

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
 
 

Sometimes a lower speed can be the fault of the ISP.
You can power down/power up your router.
Are you connected to your router through Ethernet or wi-fi?
If it's wireless, make sure the router and nic are both set up for g or n.
My System SpecsSystem Spec
23 Aug 2010   #5

Windows 7 Home Premium 32bit
 
 

Well it just started about last week or so, and the only change i made was installing adobe reader on my computer, whcich i uninstalled today.

And i have my laptop connected via wifi not by ethernet. I dont think i should have a problem there because its been like that for more than 2 years
My System SpecsSystem Spec
23 Aug 2010   #6

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
 
 

- Can you verify your router is still set for g/n instead of b?
- check your router firmware and flash if needed
- restore computer to date prior to slow down.
- upgrade you nic driver
- try pinging with ip address and alpha address. same? if not, dns problem
My System SpecsSystem Spec
23 Aug 2010   #7

 

This could be off the wall, and I just mention because you said
Quote:
there are a lot of times when my pages dont load or load VERY slow
But are you by any chance using proxies as well? Any software that might change your proxy settings?
My System SpecsSystem Spec
Reply

 Internet Problem?




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 10:05 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33