Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Not sure what this process does

04 Oct 2010   #1
vicvic

windows 7 Home premium 32 bit
 
 
Not sure what this process does

Hi

Not sure what a process does but it is spiking my cpu so that it runs at 100% for about 30mins.Where i am getting random freezes and my computer starts over heating. It started doing this last week.

It is the System Idle Process - the threads behind it are ntkmpa.exe!KiDispatchInterrupt+Ox650 ( from process explorer)


I am aware that system idle process is meant to run from a little googling. When i am not doing anything. At the time i am running Eveonline, excel, word firefox and other stuff. So the machine isn't idle.

i have run virus and malwarbtyes scans on my computer and they have found nothing.

Any ideas what i need to do to sort out this problem

cheers


My System SpecsSystem Spec
.

04 Oct 2010   #2
arkhi

Windows 2000 5.0 Build 2195
 
 

Quote:



System Idle Process - You cannot end this process from Task Manager.
  • This process is a single thread running on each processor, which has the sole task of accounting for processor time when the system isn't processing other threads. In Task Manager, expect this process to account for the majority of processor time.
Default Processes in Windows 2000

Why you're having problems should be a result of some other culprit.
My System SpecsSystem Spec
04 Oct 2010   #3
vicvic

windows 7 Home premium 32 bit
 
 

How do i work out what is causing the problem.
My System SpecsSystem Spec
.


04 Oct 2010   #4
arkhi

Windows 2000 5.0 Build 2195
 
 

Hmm.. Can you post an HJT log maybe?
My System SpecsSystem Spec
05 Oct 2010   #5
vicvic

windows 7 Home premium 32 bit
 
 

arkhi thanks here a log - Not sure if you wanted a log at the time of the problem. Here is a log of when my computer has just been turned on. If you need another log let me know. thanks in advance

Logfile of Trend Micro HijackThis v2.0.4
Scan saved at 2:56:22 AM, on 6/10/2010
Platform: Windows 7 (WinNT 6.00.3504)
MSIE: Internet Explorer v8.00 (8.00.7600.16385)
Boot mode: Normal

Running processes:
C:\Windows\system32\Dwm.exe
C:\Windows\Explorer.EXE
C:\Windows\system32\taskhost.exe
C:\Program Files\Intel\Intel Matrix Storage Manager\IAAnotif.exe
C:\Program Files\Hewlett-Packard\HP Quick Launch Buttons\QLBCTRL.exe
C:\Program Files\Alwil Software\Avast5\AvastUI.exe
C:\Program Files\IDT\WDM\sttray.exe
C:\Program Files\Synaptics\SynTP\SynTPEnh.exe
C:\Program Files\ATI Technologies\ATI.ACE\Core-Static\MOM.exe
C:\Program Files\Microsoft Office\Office14\ONENOTEM.EXE
C:\Program Files\ATI Technologies\ATI.ACE\Core-Static\CCC.exe
C:\Program Files\Mozilla Firefox\firefox.exe
C:\Program Files\Microsoft Office\Office14\EXCEL.EXE
C:\Program Files\Microsoft Office\Office14\OUTLOOK.EXE
C:\Windows\system32\SearchProtocolHost.exe
C:\Users\Vic\Downloads\HijackThis.exe

R1 - HKCU\Software\Microsoft\Internet Explorer\Main,Search Page = Bing
R0 - HKCU\Software\Microsoft\Internet Explorer\Main,Start Page = DAEMON-Search.com :: STARTPAGE
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Page_URL = MSN.com
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Default_Search_URL = Bing
R1 - HKLM\Software\Microsoft\Internet Explorer\Main,Search Page = Bing
R0 - HKLM\Software\Microsoft\Internet Explorer\Main,Start Page = MSN.com
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,SearchAssistant =
R0 - HKLM\Software\Microsoft\Internet Explorer\Search,CustomizeSearch =
R1 - HKCU\Software\Microsoft\Windows\CurrentVersion\Internet Settings,ProxyOverride = *.local
O2 - BHO: AcroIEHelperStub - {18DF081C-E8AD-4283-A596-FA578C2EBDC3} - C:\Program Files\Common Files\Adobe\Acrobat\ActiveX\AcroIEHelperShim.dll
O2 - BHO: Groove GFS Browser Helper - {72853161-30C5-4D22-B7F9-0BBC1D38A37E} - C:\PROGRA~1\MICROS~2\Office14\GROOVEEX.DLL
O2 - BHO: URLRedirectionBHO - {B4F3A835-0E21-4959-BA22-42B3008E02FF} - C:\PROGRA~1\MICROS~2\Office14\URLREDIR.DLL
O2 - BHO: Java(tm) Plug-In 2 SSV Helper - {DBC80044-A445-435b-BC74-9C25C1C588A9} - C:\Program Files\Java\jre6\bin\jp2ssv.dll
O4 - HKLM\..\Run: [IAAnotif] C:\Program Files\Intel\Intel Matrix Storage Manager\iaanotif.exe
O4 - HKLM\..\Run: [QlbCtrl.exe] C:\Program Files\Hewlett-Packard\HP Quick Launch Buttons\QlbCtrl.exe /Start
O4 - HKLM\..\Run: [avast5] "C:\Program Files\Alwil Software\Avast5\avastUI.exe" /nogui
O4 - HKLM\..\Run: [SysTrayApp] C:\Program Files\IDT\WDM\sttray.exe
O4 - HKLM\..\Run: [SynTPEnh] %ProgramFiles%\Synaptics\SynTP\SynTPEnh.exe
O4 - HKLM\..\Run: [StartCCC] "C:\Program Files\ATI Technologies\ATI.ACE\Core-Static\CLIStart.exe" MSRun
O4 - Startup: OneNote 2010 Screen Clipper and Launcher.lnk = C:\Program Files\Microsoft Office\Office14\ONENOTEM.EXE
O4 - Global Startup: AutorunsDisabled
O8 - Extra context menu item: E&xport to Microsoft Excel - res://C:\PROGRA~1\MICROS~2\Office14\EXCEL.EXE/3000
O8 - Extra context menu item: Se&nd to OneNote - res://C:\PROGRA~1\MICROS~2\Office14\ONBttnIE.dll/105
O9 - Extra button: Send to OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\Program Files\Microsoft Office\Office14\ONBttnIE.dll
O9 - Extra 'Tools' menuitem: Se&nd to OneNote - {2670000A-7350-4f3c-8081-5663EE0C6C49} - C:\Program Files\Microsoft Office\Office14\ONBttnIE.dll
O9 - Extra button: OneNote Lin&ked Notes - {789FE86F-6FC4-46A1-9849-EDE0DB0C95CA} - C:\Program Files\Microsoft Office\Office14\ONBttnIELinkedNotes.dll
O9 - Extra 'Tools' menuitem: OneNote Lin&ked Notes - {789FE86F-6FC4-46A1-9849-EDE0DB0C95CA} - C:\Program Files\Microsoft Office\Office14\ONBttnIELinkedNotes.dll
O18 - Filter hijack: text/xml - {807573E5-5146-11D5-A672-00B0D022E945} - C:\Program Files\Common Files\Microsoft Shared\OFFICE14\MSOXMLMF.DLL
O20 - Winlogon Notify: AutorunsDisabled - Invalid registry found
O23 - Service: Andrea ST Filters Service (AESTFilters) - Andrea Electronics Corporation - C:\Windows\System32\DriverStore\FileRepository\stwrt.inf_x86_neutral_9691412ff1876250\aestsrv.exe
O23 - Service: AMD External Events Utility - AMD - C:\Windows\system32\atiesrxx.exe
O23 - Service: avast! Antivirus - AVAST Software - C:\Program Files\Alwil Software\Avast5\AvastSvc.exe
O23 - Service: avast! Mail Scanner - AVAST Software - C:\Program Files\Alwil Software\Avast5\AvastSvc.exe
O23 - Service: avast! Web Scanner - AVAST Software - C:\Program Files\Alwil Software\Avast5\AvastSvc.exe
O23 - Service: Bonjour Service - Apple Inc. - C:\Program Files\Bonjour\mDNSResponder.exe
O23 - Service: Com4QLBEx - Hewlett-Packard Development Company, L.P. - C:\Program Files\Hewlett-Packard\HP Quick Launch Buttons\Com4QLBEx.exe
O23 - Service: FLEXnet Licensing Service - Macrovision Europe Ltd. - C:\Program Files\Common Files\Macrovision Shared\FLEXnet Publisher\FNPLicensingService.exe
O23 - Service: hpqwmiex - Hewlett-Packard Development Company, L.P. - C:\Program Files\Hewlett-Packard\Shared\hpqwmiex.exe
O23 - Service: HP Service (hpsrv) - Hewlett-Packard Company - C:\Windows\system32\Hpservice.exe
O23 - Service: Intel(R) Matrix Storage Event Monitor (IAANTMON) - Intel Corporation - C:\Program Files\Intel\Intel Matrix Storage Manager\IAANTMon.exe
O23 - Service: Audio Service (STacSV) - IDT, Inc. - C:\Windows\System32\DriverStore\FileRepository\stwrt.inf_x86_neutral_9691412ff1876250\STacSV.exe
O23 - Service: TeamViewer 5 (TeamViewer5) - TeamViewer GmbH - C:\Program Files\TeamViewer\Version5\TeamViewer_Service.exe

--
My System SpecsSystem Spec
05 Oct 2010   #6
pbcopter

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64
 
 

The system idle process runs to enable the system process scheduler to behave the same way even if no real processes are running. It generally shows how much of the CPU is not being used. It should not cause heating since it is using very little CPU time.

See this article.
System Idle Process - Wikipedia, the free encyclopedia
My System SpecsSystem Spec
05 Oct 2010   #7
DeaconFrost

Windows 7 Ultimate x64 SP1
 
 

Anytime you aren't sure of a process or what it does, just google the process name. You'll find many links and sites that go into great detail.
My System SpecsSystem Spec
05 Oct 2010   #8
Jacee
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

Looks like a driver problem with Nvidia
My System SpecsSystem Spec
05 Oct 2010   #9
arkhi

Windows 2000 5.0 Build 2195
 
 

Thing is, based on his log, he's using ATI. Based on his writen system specs, it's an Mobile HD 4530. He said that System Idle Process runs at 100%, which "probably" means that all CPU load have been released in order for it to be 100% idle, which could probably explain the "hanging".

Having a similar experience with video drivers issues before that had almost this same effect, I'd have to ask this- Have you tried updating your video drivers by any chance?

Also, as far as the log goes, everything seems to be clean of any culprit objects. However, this line is hinting of something erroneuos
Code:
 
O20 - Winlogon Notify: AutorunsDisabled - Invalid registry found
My System SpecsSystem Spec
05 Oct 2010   #10
vicvic

windows 7 Home premium 32 bit
 
 

First thanks for your help guys.

Just a little more information.

Quote:
O20 - Winlogon Notify: AutorunsDisabled - Invalid registry found
I have a regedit to stop auto runs of dvd and usb on my system. Long story virus issue last year. This regedit has never caused a problem.

Quote:
Looks like a driver problem with Nvidia
I found a Nivida driver on my machine on Sunday. My video card is ATI.

On Sunday i had process explorer running so i could see what was causing the problem.

Tree behind the process is

Quote:
ntkmpa.exe!KiDispatchInterrupt+Ox650
which is a Nivida Gforce driver which after googling does cause this problem.

Quote:
Have you tried updating your video drivers by any chance?
Yes i used 1st windows update to update my driver on Sunday. I have been having this issue since Tues last week. After finding the Nivida driver i rolled back the driver and went to ATI website to download the latest driver. This didn't hold either of my computer or external monitor on there correct refresh rates. I have learnt from experience. NEVER use the Catalyst to change things as it just causes a big mess- system restore won't work either after changes.

I rolled back this driver and went to HP website and downloaded there video driver.

Since then it is still going into overdrive but not to the point of before. Where my cpu would run at 100% for 10 mins )

One last thing i have a system image from 2 weeks ago. Could this be a quick fix to the problem.
My System SpecsSystem Spec
Reply

 Not sure what this process does




Thread Tools





Similar help and support threads
Thread Forum
"Error opening process" message in Process Explorer
Hi Everyone I recently did a System Restore on a Windows 7 Pro 64 bit system to correct a strange problem I was having with IE. It seems to have solved the problem, but now Process Explorer is displaying the messages in the screen shot below, and I'm not sure why. The computer is functioning...
Software
open explorer, starts new process, close it, process remains active
Hi, I've got a quicklaunch shortcut to: %windir%\explorer.exe shell:::{323CA680-C24D-4099-B94D-446DD2D7249E} That takes me straight to my explorer favourites. What I notice is that when I launch that, I get a new explorer.exe thread appear in the task manager. When I close it though, that...
General Discussion
Windows 7 + Process Explorer + Patch: [Opening error process]
Hi fooks, I hope you all can read this, i'm from Belgium so my Englsich is not as good as it might be. I have bought last year a little notebook with Windows 7 Home Premium on it. On this machine i am the Administrator, and there are no other people on that, or guestaccounts made. On...
Installation & Setup
IE9 process/tab
I searched the web but i couldn't find a conclusive answer. Is IE9 running each tab on a separate process, just like Chrome does?
Browsers & Mail
Could someone tell me what this process is?
atieclxx.exe is running on my computer now. I was checking the internet, they said it was a virus. I cannot find it. I ran a 100% full scan with Norton 360 and it found nothing. It may be just part of the ati files I am sure I have on my computer. Any help would be appreciated.
System Security
connection by the system process and killed process
I have a few apps running, incl. Firefox, Outlook. I took down their PID and then exit those programs. I run the following command: netstat -a -o -b -p tcp It will list many connections like below TCP 192.168.83.2:57471 xx.xx.xx.xx:http ESTABLISHED 4184 TCP ...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:58.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App