Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: contents of C\windows switched with contents of c\program files

01 Nov 2010   #1
Shawn N

Windows 7 Ultimat 32bit
 
 
contents of C\windows switched with contents of c\program files

I am not a 100% on how I managed this but here were my last steps:
- changed the host file in c\windows\system32\drivers\etc
- rebooted computer
- received system errors, so I ran a HDD defragmenter
- I then tried to access a file in c\program files but could not find it, but it mysteriously felt like I was in the c\windows directory. So I looked in c\windows and found the file I was previously looking for in c\program files.

The other problem is that any file or program that is rooted in those folders gives me an error message reading "location is unavailable" whenever I try to access it.

Needless to say, My computer is JACKED and I would appreciate and help on this.

If this is at all confusing just ask and i will try to explain it better

Thanks

Shawn


My System SpecsSystem Spec
.
01 Nov 2010   #2
James Colbert

 
 

Try doing a System Restore predating the issue.

James
My System SpecsSystem Spec
01 Nov 2010   #3
Orbital Shark

 
 

Hi Shawn, welcome to the forums

Try a System Restore to a time/date when you knew everything was working ok and see if that helps.


OS
My System SpecsSystem Spec
.

01 Nov 2010   #4
Orbital Shark

 
 

Quote   Quote: Originally Posted by James Colbert View Post
Try doing a System Restore predating the issue.

James
Great minds think alike
My System SpecsSystem Spec
01 Nov 2010   #5
Shawn N

Windows 7 Ultimat 32bit
 
 

Thanks, but i already thought of that and to my surprise, I have no restore points
My System SpecsSystem Spec
01 Nov 2010   #6
Orbital Shark

 
 

1 option is to try Repair Install

Or, Start -> All Programs -> Accessories -> [right-click]Command Prompt (run as administrator). Once CMD opens type sfc /scannow to run the system file integrity checker. Any modified/changed system files will be restored.


OS
My System SpecsSystem Spec
01 Nov 2010   #7
Shawn N

Windows 7 Ultimat 32bit
 
 

Well i ran the file integrity checker and that didn't work.

I somehow misplaced my windows 7 install disk. Is there any way I can do a repair install without it?
My System SpecsSystem Spec
01 Nov 2010   #8
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by Shawn N View Post
I am not a 100% on how I managed this but here were my last steps:
- changed the host file in c\windows\system32\drivers\etc
- rebooted computer
- received system errors, so I ran a HDD defragmenter
- I then tried to access a file in c\program files but could not find it, but it mysteriously felt like I was in the c\windows directory. So I looked in c\windows and found the file I was previously looking for in c\program files.

The other problem is that any file or program that is rooted in those folders gives me an error message reading "location is unavailable" whenever I try to access it.

Needless to say, My computer is JACKED and I would appreciate and help on this.

If this is at all confusing just ask and i will try to explain it better

Thanks

Shawn

Restore from backup before problem, do a repair install from the win 7 dvd, or re-install.
My System SpecsSystem Spec
01 Nov 2010   #9
mborner

Windows 7 Pro/32 Academic. Build 7600
 
 

Question 1: How, and why, did you change your host file?
Question 2: Have you tried changing it back to see if it fixes things?

If you were trying to fix a Google redirect issue by deleting malicious hosts from C:\Windows\system32\drivers\etc, it's very effective. I've done it in the past and it works great as long as you leave "local host 127.0.0.1 alone. Clearing out malicious redirect hosts never affected my PC in any way. Or, did you modify it some other way?
My System SpecsSystem Spec
01 Nov 2010   #10
James Colbert

 
 

Quote   Quote: Originally Posted by Orbital Shark View Post
Quote   Quote: Originally Posted by James Colbert View Post
Try doing a System Restore predating the issue.

James
Great minds think alike
You honor me.
My System SpecsSystem Spec
Reply

 contents of C\windows switched with contents of c\program files




Thread Tools




Similar help and support threads
Thread Forum
Just switched to Windows 7, contents of External Drive are read only?
I just switched from Windows XP to Windows 7, I backed up all my files to an external HDD and now I've transferred them all back, but I've noticed the folder they were in says it's read only... or rather, it's not ticked, it has a blue square on read only. According to Security I have access to...
General Discussion
Windows 7 and Searching File Contents
Hey guys, I'm having an issue with searching file contents. We have a folder set up for emails to be placed for archiving. The folder is shared, and located in a server 2003 machine. From my windows 7 machine, searching "reed" generates no results, but searching "Reed" will correctly find the...
General Discussion
windows explorer shows different contents
I've seen a lot of threads about Libraries, but can't find one that addresses (in a way I can understand) my problem. I can navigate to a given folder, say "My Pictures" either through my user name or through "Documents/My Pictures" The two methods show different content for the folder. This is...
General Discussion
Viewing Contents of Temporary Internet Files folder
Hello, I would like to be able to view the various temporary internet file folders like I used to with my previous version of Windows. Can anyone tell me how I can do this. I have tried using: C:> Users\My Directory\AppData\local\Micrososft. According to my antivirus scan tool, the temporary...
General Discussion
7229 slow to show folder contents with avi files
Strange problem here, first time I have observed this in any Windows 7 build: when I click on a folder with movies in it, it takes about 1+ seconds to show the contents. Anyone else experienced this same problem with build 7229? Not something I experienced with previous builds... :shock:
Music, Pictures & Video
Consuming the Contents of Windows 7 Libraries
More...
News


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:45.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App