Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Losing Access to Control Panel

05 Jun 2009   #1

Windows 7 -64
 
 
Losing Access to Control Panel

I had an issue in the Beta vertsion where any user who was not the "administrator account" lost access to control panel or any enhanced rights application, such as mail setup. The issue still happens on a clean install with no connection to the internet. It is still happening on build 7100.
if I create a brand new standard user then things work fine for a few minutes but then they break. The symptoms are if I click on control panel, there is no error, no prompt for the admin password but control panel never launches.

any ideas anyone?

My System SpecsSystem Spec
.

05 Jun 2009   #2

Win 8 Release candidate 8400
 
 

DS
Welcome to SF. there ar a bunch of friendly, smart folks here so dont hesitate to ask
Was it a Clean install, not upgrade? When std user tries to goto cpanel start>cpanel what happens? does it not let you go there, display a uac prohibition, or give you a dialog box/ error?

ken
My System SpecsSystem Spec
05 Jun 2009   #3

Windows 7 -64
 
 

It was a clean install of both the Beta and the RC. I formatted the C drive between each one. You get no error's it just basically ignore's the request to open control panel.
I experimented a little this time:
1. I enabled the genuine admin account, and that login NEVER has the issue.
2. A standard user gets the problem the problem soon after creation.
3. A created user with admin rights also gets the problem soon after creation.
4. Once a user has the issue, I can't seem to recover from it.

I run an i7-920 with 6gb ram and 2 hard disks and it's 64bit.
My System SpecsSystem Spec
.


05 Jun 2009   #4

Windows 7 -64
 
 

Just as a note, I am using control panel as an example; If I try to go to the network and sharing centre from the icon in the system tray, I get the same problem. I intrepret it as anything that would require enhanced rights to launch.
My System SpecsSystem Spec
05 Jun 2009   #5

 
 

Hi David, welcome to the forums.

Did you get the RC from Microsoft? It sounds like the install has either missed files or corruption has occurred.
My System SpecsSystem Spec
05 Jun 2009   #6

Windows 7 -64
 
 

Yes; I did download direct from the Microsoft site both times; I held out for the official releases, and avoided the bittorrents. I downloaded the ISO files. I have a feeling that a service is shutting something down on me, because it works briefly then gives up on me.

BTW- Thanks everyone for your prompt attention on this one, this forum rocks.
My System SpecsSystem Spec
05 Jun 2009   #7

 

Quote:
I have a feeling that a service is shutting something down on me, because it works briefly then gives up on me.
sounds about right by this from MS on Windows 7

Quote:
std user account:
A standard user account lets a person use most of the capabilities of the computer, but permission from an administrator is required if you want to make changes that affect other users or the security of the computer.
When you use a standard account, you can use most programs that are installed on the computer, but you can't install or uninstall software and hardware, delete files that are required for the computer to work, or change settings on the computer that affect other users. If you're using a standard account, some programs might require you to provide an administrator password before you can perform certain tasks.
My System SpecsSystem Spec
05 Jun 2009   #8

 
 

If you click the Start orb and type edit group then click on the Edit group policy. Navigate to User Configuration\Administrative Templates\Control Panel
Losing Access to Control Panel-capture.png

What does it say next to 'Prohibit access to the Control Panel' ?


My System SpecsSystem Spec
05 Jun 2009   #9

Windows 7 -64
 
 

results:
1. In my admin account that item is "not configured".
2. I had to elevate my standard account tob admin level to run the edit group item. I tried "run as admin", but it was not an option.
3. I then managed to run the policy app and the item is also set as "not configured".
4. While I had elevated the rights i tried control panel again, and still nothing, i also typed control in the start cmmand box, but that would not run either.
My System SpecsSystem Spec
05 Jun 2009   #10

 
 

have you got access to command prompt? Type CMD in the Start Menu, when it comes up right-click & 'Run as administrator'

When/if it runs type sfc /scannow this will run a system file integrity check to see if any of your system files are corrupt or damaged.
My System SpecsSystem Spec
Reply

 Losing Access to Control Panel




Thread Tools



Similar help and support threads for2: Losing Access to Control Panel
Thread Forum
Can't Access Settings on Control Panel General Discussion
can't access control panel Performance & Maintenance
Cannot access Control Panel General Discussion
control panel access problem General Discussion
can't access SYSTEM in control panel Performance & Maintenance
How do I access control panel in virtual pc? Virtualization
cant access Sys prop or Control panel General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:48 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33