Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Help

26 Nov 2010   #1
NiteTrain817

Windows 7 Home Premium
 
 
Help

For some reason my System Language changed to symbols. This includes safe mode. It if very frustraiting and I cant seem to get anywhere!! Please help


My System SpecsSystem Spec
.
26 Nov 2010   #2
Petey7

Windows 7 Professional SP1 64-bit
 
 

Your best bet is a system restore. I imagine you will have trouble getting to it from within Windows, but you have a couple of other options. If you have a Windows 7 disc, you can get to system restore by clicking repair computer after booting from the disc and selecting your language. You can also use the recovery options at bootup. Follow the link below and go to method two for more information on how to do that.

System Restore
My System SpecsSystem Spec
27 Nov 2010   #3
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

Hello NiteTrain817, welcome to Seven Forums!



Have a look at this link to see if this method makes it any easier to get to system restore, be sure to choose a date before the issue started; and be sure to post back with any further questions you may have and to keep us informed.
My System SpecsSystem Spec
.

Reply

 Help




Thread Tools Search this Thread
Search this Thread:

Advanced Search



Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:28.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App