Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: missing drives at boot

28 Nov 2010   #1

missing drives at boot

Hi,i have a quad boot setup(all on seperate drives),just recently my drive selection at boot up is missing two of my drives,when i select either one of the two options i recieve an error message (0xc000000e),but if i put in my win 7 install disc & reboot & ignore the "press any key to continue"my machine then gives me my full 4 boot choices.Ive uninstalled virtual pc 2007 & my new dvd burner as they were the only new installs ive done before this error occured,tried startup repair from win 7 disc & system restore no luck,any help would be appereciated,thanks.

My System SpecsSystem Spec
29 Nov 2010   #2

Microsoft Community Contributor Award Recipient


Hello gnormf and welcome to the Forum. First thing I'd try is a system restore.

System Restore

If that doesn't help you might have a corrupt or damaged master boot record (MBR). This Microsoft article might help:

How to use the Bootrec.exe tool in the Windows Recovery Environment to troubleshoot and repair startup issues in Windows
My System SpecsSystem Spec
29 Nov 2010   #3


Do all four OS's boot correctly if you have the Win7 DVD in the drive?

If so, this means that Win7 needs the DVD to boot itself, and that the boot-critical files for your multi-boot are likely on Win7 partition or its 100mb SysReserved boot partition.

This should be solved by booting the Win7 DVD, selecting Repair My Computer on the second screen, accept any offered Repair. If it doesn't start, boot back into Repair, click through to Recovery Tools list to run Startup Repair up to 3 separate times with reboots until Win7 starts. Startup Repair - Run 3 Separate Times

You may then need to add back one or more of the other OS's to Multi-Boot using EasyBCD 2.0. Welcome to EasyBCD 2.0! — The NeoSmart Files

If there are any further problems, please post back a screenshot of your full Disk Management drive map and listings, and the EasyBCD listings, using Snipping Tool in Start Menu. If you have the 100mb SysReserved partition, it needs to be marked Active. If not, Win7 needs to be marked Active before repair will work correctly: Partition - Mark as Active
My System SpecsSystem Spec

29 Nov 2010   #4

Missing Drives

Thanks Gregrocker,worked a treat,used diskpart like you suggested to marked other partitions inactive then 3 start up repairs & all good to go.Great tut will put that in my tool kit ,many thanks ,Gnormf
My System SpecsSystem Spec
29 Nov 2010   #5


Glad it worked. Once you confirm everything is working just right, save a Win7 backup image so you can reimage to HD or replacement in 15 minutes if Win7 ever becomes irreparable. Backup Complete Computer - Create an Image Backup
My System SpecsSystem Spec
01 Dec 2010   #6


My System SpecsSystem Spec

 missing drives at boot

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Bootmgr.exe missing... mpio.sys missing or corrupted. Unable to boot
I just got a computer for free, a Dell Studio 1555. When I got it, it would try to boot, then come to a screen that said that bootmgr.exe was missing. Sometimes I got a message that said something like mpio.sys was corrupted or missing. I have a Win 7 disk, so I put it in and tried to repair the...
General Discussion
Missing boot menu and missing data partition
Hi there, I'm still very happy with my XP Pro, but I thought I'd set up a dual boot with Win7 ultima 64 and check it out. So I popped in another hdd that was sitting idly in a drawer and installed 7 on it. I fully expected that Win7 would be able to see there's an XP installation and create a...
Installation & Setup
Missing CD drives/ PCI Driver?
Well first thing I noticed is that my CD/DVD drives were not showing up in my computer. Checked device manager and saw that two devices are not installed, 1. Mass Storage Controller 2. PCI simple communications controller. I have uninstalled these both and restarted, have have used the trouble...
W7 Tip - Missing external USB drives
Hi all just a little tip which I hope can save some of you a big bother of plugging in and re-plugging usb drives in frustration. Have you ever plugged in a USB drive - seen the installing driver etc and after the message your device is ready for use you can't see it at all in Windows...
Hardware & Devices
64bit clean install: boot mgr is missing, drives
I am trying to clean install Windows 7 64 bit from previous Vista 32 bit OS. I have a previously perfect RAID 1 setup that seems to be recognized as C: and a data drive that is shown in disk managment as below, but does not appear in MyComputer nor is assigned a drive letter. When...
Hardware & Devices
Install Drives Missing
Hello, I'm having an issue installing Windows 7 (7100) 64 bit. (I have also tried 32 bit and 32 bit v7000) #Note, I burned the disk to a TDK-R 4.7gig Dvd using imgBurn at x2 write speed and verify. I also use the disk to install a guest os in vm workstation. So I know the disk is fine. The...
Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:59.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App