Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Screen saver - monitors off - wont work - powercfg

07 Dec 2010   #1

Windows 7 Home Premium 64
 
 
Screen saver - monitors off - wont work - powercfg

The screen saver and power settings will not engage. I set to turn off monitors in 1 minute and even if i leave for a hour they are still on. Same with screen saver.

I came across powercfg and ran

Quote:
powercfg -REQUESTS
and it showed
Quote:
SYSTEM:
[DRIVER] Realtek High Definition Audio (HDAUDIO\FUNC_01&VEN_10EC&DEV_0889&SUBSYS
_14627577&REV_1000\4&16525e8e&0&0201)
An audio stream is currently in use.
Okay, so even though I don't have any audio playing, it seems like the Realtek driver is causing the system to basically reset the timer. I tried to disable it by invoking the powercfg device disable wake argument and i get a permissions issue.

Quote:
powercfg -DEVICEDISABLEWAKE "Realtek High Definition Audio"
You do not have permission to enable or disable device wake.
The issue is that I have ran CMD as administrator and am logged in as an administrator. I am running the latest version of Realtek driver for Windows 7, why would this happen? suggestions on getting this resolved?

My System SpecsSystem Spec
.

09 Dec 2010   #2

Windows 7 Home Premium 64
 
 

uninstalled realtek drivers to just run windows drivers. didnt fix it.

any suggestions?
My System SpecsSystem Spec
09 Dec 2010   #3

Windows 8 Core X64
 
 

What did powercfg -REQUESTS show after you uninstalled the RealTek driver?
My System SpecsSystem Spec
.


10 Dec 2010   #4

Windows 7 Home Premium 64
 
 

Quote   Quote: Originally Posted by Ztruker View Post
What did powercfg -REQUESTS show after you uninstalled the RealTek driver?
it shows:
Quote:
DISPLAY:
None.

SYSTEM:
[DRIVER] High Definition Audio Device (HDAUDIO\FUNC_01&VEN_10EC&DEV_0889&SUBSYS_
14627577&REV_1000\4&16525e8e&0&0201)
An audio stream is currently in use.

AWAYMODE:
None.
My System SpecsSystem Spec
10 Dec 2010   #5

Windows 8.1 Pro RTM x64
 
 

This is what I get with that command. I actually executed the command 3 times, on the second time I had an audio application open.
Code:
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.
C:\Windows\system32>powercfg -REQUESTS
DISPLAY:
None.
SYSTEM:
None.
AWAYMODE:
None.
 
C:\Windows\system32>powercfg -REQUESTS
DISPLAY:
None.
SYSTEM:
[DRIVER] Realtek High Definition Audio (HDAUDIO\FUNC_01&VEN_10EC&DEV_0662&SUBSYS
_10192609&REV_1001\4&30a3114a&0&0001)
An audio stream is currently in use.
AWAYMODE:
None.
 
C:\Windows\system32>powercfg -REQUESTS
DISPLAY:
None.
SYSTEM:
None.
AWAYMODE:
None.
 
C:\Windows\system32>
I suggest that you try reinstalling the latest driver, using this method: Device Manager - Install Driver - Vista Forums

Latest driver: Latest Realtek HD Audio Driver Version
My System SpecsSystem Spec
11 Dec 2010   #6

Windows 7 Home Premium 64
 
 

Quote   Quote: Originally Posted by Dwarf View Post
This is what I get with that command. I actually executed the command 3 times, on the second time I had an audio application open.
Code:
Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation.  All rights reserved.
C:\Windows\system32>powercfg -REQUESTS
DISPLAY:
None.
SYSTEM:
None.
AWAYMODE:
None.
 
C:\Windows\system32>powercfg -REQUESTS
DISPLAY:
None.
SYSTEM:
[DRIVER] Realtek High Definition Audio (HDAUDIO\FUNC_01&VEN_10EC&DEV_0662&SUBSYS
_10192609&REV_1001\4&30a3114a&0&0001)
An audio stream is currently in use.
AWAYMODE:
None.
 
C:\Windows\system32>powercfg -REQUESTS
DISPLAY:
None.
SYSTEM:
None.
AWAYMODE:
None.
 
C:\Windows\system32>
I suggest that you try reinstalling the latest driver, using this method: Device Manager - Install Driver - Vista Forums

Latest driver: Latest Realtek HD Audio Driver Version

I am assuming that your monitors go off and the system goes to sleep properly? I am running the latest drivers and still not working. Would it be caused by something else? Any suggestions?
My System SpecsSystem Spec
07 Apr 2011   #7

Windows 7 Ultimate 32bit
 
 

No solution yet?
My System SpecsSystem Spec
Reply

 Screen saver - monitors off - wont work - powercfg





Thread Tools



Similar help and support threads for2: Screen saver - monitors off - wont work - powercfg
Thread Forum
My screen saver doesn't work! Customization
Photo screen saver won't work. General Discussion
Seven Screen Saver - Dual Monitors Customization
Screen Saver does not work Customization
Window 7 screen saver doesn't work General Discussion
Dual Monitors and Screen Saver? Customization
screen saver over 2 monitors Customization

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:15 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33