Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "open with" command not working correctly


27 Jan 2011   #1

Windows 7 64 bit Home Premium
 
 
"open with" command not working correctly

Hi,

I've been using XP for 6 years and just switched to Windows 7 3 days ago when I got a new computer.

The default image viewing is Windows Photo Viewer, which is fine. I am running Fireworks MX (yes, I know it's old, but I can't afford to buy a newer version), and sometimes I'd like to open images directly with that in order to edit them. So I right click on them and do open with --> Fireworks MX. Fireworks MX correctly appears in the "open with" list, but even when I choose it, it still opens the photo in Windows Photo Viewer.

Does anyone know how to fix this?

I'd post a vid but I don't have the software to do so. I can post screenshots of the process if it would help?

So my workaround so far as been manually opening Fireworks MX and then dragging the photo into it, but obviously I shouldn't have to do that.

I have Windows 7 Home Premium 64 bit if that matters.

Thanks!


My System SpecsSystem Spec
.

03 Feb 2011   #2

Windows 7 64 bit Home Premium
 
 

Any ideas? This is still happening and I'm not sure how to fix it because what else can I do besides do an "open with"? It's like even though I tell it to "open with" Firefox.exe, it decides to use WindowsPhotoViewer.exe instead. That makes no sense to me and I don't understand why it would use a different program other than the one I specifically tell it to use.

I've considered deleting WindowsPhotoViewer and then trying to do "open with" Firefox to see what it does when the program it wants to use doesn't exist anymore (probably give an error message), but I don't want to delete Windows Photo Viewer because I do want to use it in some cases.
My System SpecsSystem Spec
03 Feb 2011   #3

Windows Home Premium 64bit
 
 
"open with" command not working correctly

Hi Ninjasninja. Possible solution. When you right click on a photo to get to the "Open With" option, there is at the bottom of that menu a choice "Choose default program". Click on that option, choose your viewer of choice and place a check mark in the box "Always use this selection etc."
Hope this helps
My System SpecsSystem Spec
.


Reply

 "open with" command not working correctly




Thread Tools



Similar help and support threads for2: "open with" command not working correctly
Thread Forum
Solved Missing "Open With" command with right-click General Discussion
Solved Can't open cmd through "open command window here" General Discussion
Solved No REG Command in "Open elevated command window here" DOS Box General Discussion
"Flie open" window doesn't display correctly General Discussion
Solved Problems about windows 7 "open command window here" shift-right click General Discussion
Adding "Open Command Prompt" Option Customization
To open "Manage" windows explorer stops working BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:16 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33