Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Laptop running windows 7 is too slow

19 Mar 2011   #1

Windows 7 Ultimate x32
 
 

I made a thread about this about a month ago, but I did everything I was told to do and nothing changed.

This laptop is way too slow. The audio is just a big mess from the login screen and onward(really laggy and static-y). I ran some malware stuff and registry repair as suggested, in safe mode and normal mode, but nothing was fixed.
After a few hours, I gave up and dual-booted Ubuntu 10.04 and it worked perfectly. Speed was excellent, audio was too. The only problem is I just use PCs for gaming and chatting, and I can't do much gaming with Ubuntu.

So, any idea what could be the problem here? I even tried windirstats too see if any huge files that weren't supposed to be there were causing this, because I once had a problem on my own computer where I had this huge file that slowed down everything and wouldn't let me delete it until I did so in safe mode and then everything worked perfectly again.

also, at the boot up menu, there are two loaders. one for vista, one for windows 7. windows 7 just starts up 7, while the vista loader goes to some menu thing that looks like it was booted from a disc.

1.it has the options to reset to factory settings and format the C: drive
2.has the option to reset, but keep data

don't know if that helps at all, but yeah...

My System SpecsSystem Spec
.

19 Mar 2011   #2

Windows 7 Ultimate 64bit
 
 

What laptop do you have? Have you update to the latest audio drivers?

I had a simalar problem that i fixed previously that had this problem due to windows not be able to write data properly and trying enough times to cause the hard drive to be put into pio mode.
Can you go into the device manger, right click my computer and choose manage then device manager, right click on your hard drive, mine is under ide channel then ata channal 0, right click, choose advanced settings and it should say there what mode it is in.

BTW i'm not sure if this will be in effect for sata hard drives, but i'm pretty sure the laptop ifixed had a sata drive in it as it was quite new, if it doew say PIO tell me and we'll go from there.
My System SpecsSystem Spec
19 Mar 2011   #3

Windows 7 Ultimate (x64)
 
 

idunno, how many OSs do you have on your laptop? How did you install your Windows 7: was it pre-installed by the laptop manufacturer or you did it yourself? In the latter case, did you upgrade from Vista or made a clean install?
My System SpecsSystem Spec
.


19 Mar 2011   #4
Microsoft MVP

 

If I were you I would clean reinstall Windows 7 as it sounds like you have an old factory preinstall still on there with all of the attendant junk and corruption.

Follow these tips to get a purrfect Windows 7 reinstall after wiping the HD of all code: re-install windows 7
My System SpecsSystem Spec
19 Mar 2011   #5

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by gregrocker View Post
If I were you I would clean reinstall Windows 7 as it sounds like you have an old factory preinstall still on there with all of the attendant junk and corruption.

Follow these tips to get a purrfect Windows 7 reinstall after wiping the HD of all code: re-install windows 7
That would also prob solve the problem, reason i didnt mention it as by the sounds of it you dont have an install disc of windows just a recovery partition or reset thing like you said (to the op btw), is that right?
My System SpecsSystem Spec
19 Mar 2011   #6

WDS 7 Home Pre.x64
 
 

Quote   Quote: Originally Posted by idunno View Post
I made a thread about this about a month ago, but I did everything I was told to do and nothing changed.

This laptop is way too slow. The audio is just a big mess from the login screen and onward(really laggy and static-y). I ran some malware stuff and registry repair as suggested, in safe mode and normal mode, but nothing was fixed.
After a few hours, I gave up and dual-booted Ubuntu 10.04 and it worked perfectly. Speed was excellent, audio was too. The only problem is I just use PCs for gaming and chatting, and I can't do much gaming with Ubuntu.

So, any idea what could be the problem here? I even tried windirstats too see if any huge files that weren't supposed to be there were causing this, because I once had a problem on my own computer where I had this huge file that slowed down everything and wouldn't let me delete it until I did so in safe mode and then everything worked perfectly again.

also, at the boot up menu, there are two loaders. one for vista, one for windows 7. windows 7 just starts up 7, while the vista loader goes to some menu thing that looks like it was booted from a disc.

1.it has the options to reset to factory settings and format the C: drive
2.has the option to reset, but keep data

don't know if that helps at all, but yeah...


Stay with Ubuntu .... If you are happy with it ....
My System SpecsSystem Spec
Reply

 Laptop running windows 7 is too slow




Thread Tools



Similar help and support threads for2: Laptop running windows 7 is too slow
Thread Forum
Solved Laptop running slow on battery Performance & Maintenance
Samsung Laptop Running Slow Performance & Maintenance
laptop running in slow motion Performance & Maintenance
Laptop disk drive running slow Hardware & Devices
Solved Laptop NBA 2k11 running slow when it was fine a few days ago Performance & Maintenance
laptop running slow help Performance & Maintenance
Laptop running hot and slow performance Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:29 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33