Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Explorer Issue

07 Jul 2009   #1
zboot

Windows 7 Ultimate
 
 
Explorer Issue

I've noticed that updates in explorer occur very slowly, on the order of about a minute. Usually I don't wait that long and right click refresh. Still, it can be annoying at times.

I've noticed this with the following:

1. Delete a file or files. Behavior: File is deleted though icon stays up to a minute later. Refreshing the screen fixes problem or moving to another folder then coming back.

2. Rename a folder. Behavior: Folder is renamed though old name does not change unless I refresh or navigate away. If I enter the renamed folder, then hit back, then forward again, explorer attempts to enter a folder with the old name and gives me an error. Only after the ~ minute does the navigation history change to reflect the new folder name.

3. Same with any other operation, moving, cut/paste, copy - there seems to be a significant lag between when the operation occurs and when explorer updates icons and such.


My System SpecsSystem Spec
.
07 Jul 2009   #2
Brink
Microsoft MVP

64-bit Windows 10 Pro
 
 

Hello Zboot, and welcome to Seven Forums.

That is a bit to long. Is your system under a heavy load at the time?

Could you also update your system specs, it may help with what may be happening here and in your future posts.
My System SpecsSystem Spec
07 Jul 2009   #3
electricbluejase

Win7 Ultimate Build 7100 (32Bit)
 
 

i ran into this problem in version 7000, but it was fixed in 7100, although sometimes it comes back, I am sure m$oft can fix it, soon enough.
My System SpecsSystem Spec
.

07 Jul 2009   #4
Antman

 

When I have encountered this problem (3x so far), I removed all of my context menu "add-ons" and the problem resolved. I then added back only the context menu items that I can't live without.

BTW - this is maybe the only thing I miss about XP-32. I had a tower of right-click options with no ill effect.

I remember this - WinRAR in the context menu has been an "issue" in 7x64. Not a problem today, though.
My System SpecsSystem Spec
07 Jul 2009   #5
Antman

 

OK, that was freaky. After posting the above, I toggled over to Explorer to see if I currently had WinRAR in the context menu. My chosen folder lagged on opening. Jeez. Then I noticed that JetAudio was set as a folder context menu item. I opened JetAudio (and noticed by its skin that I have yet to configure it) and removed the folder context menu option.

Et voila! Lag gone.

And yes, WinRAR is cascaded in the context menu.
My System SpecsSystem Spec
07 Jul 2009   #6
Brink
Microsoft MVP

64-bit Windows 10 Pro
 
 

Zboot,

If this had just recently started to do this, them you might also see if a System Restore using a restore point dated before it started may fix it for you.

You can also use the program ShellExView to temporarily disable added Context Menu (under Type column) items as Antman suggested to see if one them had caused this.
My System SpecsSystem Spec
08 Jul 2009   #7
zboot

Windows 7 Ultimate
 
 

I will try the context menu disabling workaround. I've had this issue since I installed RC1 though I did inherit a couple context menu additions from my vista installation.

Edit:

I tried disabling all the context menu entries via ShellExView and after a reboot, still have the same issue.
My System SpecsSystem Spec
08 Jul 2009   #8
Brink
Microsoft MVP

64-bit Windows 10 Pro
 
 

zboot,

You might see if a repair install can fix it without losing anything.
My System SpecsSystem Spec
Reply

 Explorer Issue




Thread Tools





Similar help and support threads
Thread Forum
ftp issue in windows explorer
Hi, Im trying to download ftp site through windows explorer .It shows error .1 month before it worked but recently im facing this issue.PLease find attached ftp issue
Network & Sharing
explorer exe cpu issue
Hi sure you have heard this before so I will let you know what I have tried to so far ccleaner,app that searches for broken shortcuts,and deleting almost everything that I don't need,and the clean boot technique.I am trying to locate the fake explorer.exe but I am confused.When I go to c windows...
General Discussion
Internet explorer 10 issue
Hi guys I made the decision to download IE10. To be honest I cannot make any distinguishable difference to IE9 in terms of speed. I don't like the fact that to switch to 64 bit browsing you need to change enabled protection something or other and reboot. Seems a pain. Anyway the main...
Browsers & Mail
Issue with Internet Explorer.
Forgive me. This issue is on a Vista notebook. It can go on the network, but cannot get on the Internet with Internet Explorer. I installed Google Chrome, and this is working fine. For info, here's what I get, if I would got on the Inet via IE. What can cause this issue ?
Browsers & Mail
Issue with Process Explorer.
Hi. I'm having issue with Process Explorer. Attached is what I get. What could be the reason ?
Software
Explorer and IE 8 issue with Windows 7 - HELP
Hi There, I up-graded my Vista PC to windows 7 on the weekend. So far so good. Next step was to right click the desktop to personalise my PC. This is where the problems start. I keep getting the following window opening "Windows Explorer has stopped working". Ok, so I thought I would check...
BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 17:19.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App