Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Windows explorer Navigation pane graphics corrupted when scrolling

28 Apr 2011   #1

Windows 7 Professional 64-bit
 
 
Windows explorer Navigation pane graphics corrupted when scrolling

Hi everyone,

This is my first post here. I just got a Dell XPS 8300 with Windows Professional 64-bit. So far, most everything seems to be working normally. However, in Windows Explorer (which I use a lot), the left-side Navigation Pane is getting all screwed up visually when I scroll.

As an aside, I would really like to turn off smooth scrolling in Windows Explorer, but can't figure out how to do it. I have "smooth-scroll list boxes" unchecked, but it doesn't seem to help. I can get TweakUI for XP to run in compatibility mode either (someone on another forum was able to use that to disable smooth scrolling). I wonder if the animated smooth scrolling is causing the problem.

Different types of scrolling cause different degrees of the problem, but it happens nearly all the time. Hitting F5 will clean up the screen, but I would rather figure out what's causing the screen repaint problems.

I've attached a screenshot of what's happening.

I've done many searches (on this forum and other places) and not seen much, if any, people talking about this.

Any ideas?

Thanks,

Chris



Attached Thumbnails
Windows explorer Navigation pane graphics corrupted when scrolling-windows-7-corrupt-file-explorer.png  
My System SpecsSystem Spec
29 Apr 2011   #2

Windows 7 Home Premium 64bit
 
 

Smooth scrolling on/off:
Turn off Smooth Scrolling

Quote:
  1. Click the Start button, and then click Control Panel.
  2. In Control Panel, make sure you are in Classic View, with all Control Panel icons showing. If not, click Switch to Classic View in the left pane of Control Panel.
  3. Click Internet Options to open the Internet Options dialog box. Click the Advanced tab and scroll down to the Settings: Browsing heading. Select or clear the Use smooth scrolling check box.
  4. Click OK, and then click the Close button.
My System SpecsSystem Spec
29 Apr 2011   #3

Several, including Windows 7 x64 Ultimate
 
 

Quote   Quote: Originally Posted by fatherom View Post
Hi everyone,

This is my first post here. I just got a Dell XPS 8300 with Windows Professional 64-bit. So far, most everything seems to be working normally. However, in Windows Explorer (which I use a lot), the left-side Navigation Pane is getting all screwed up visually when I scroll.

As an aside, I would really like to turn off smooth scrolling in Windows Explorer, but can't figure out how to do it. I have "smooth-scroll list boxes" unchecked, but it doesn't seem to help. I can get TweakUI for XP to run in compatibility mode either (someone on another forum was able to use that to disable smooth scrolling). I wonder if the animated smooth scrolling is causing the problem.

Different types of scrolling cause different degrees of the problem, but it happens nearly all the time. Hitting F5 will clean up the screen, but I would rather figure out what's causing the screen repaint problems.

I've attached a screenshot of what's happening.

I've done many searches (on this forum and other places) and not seen much, if any, people talking about this.

Any ideas?

Thanks,

Chris
Welcome to the forums.

You might like to try this;

QTTabBar

solves most such Explorer problems, ( and gives very considerable enhancements), because the developer has managed to streamline the Explorer code. Explorer actually starts and runs a lot faster with this add-on. The add-on is integrated into Explorer itself, it is not a separate program as such.

It usually also clears the repainting problems, as it removes Explorer "lag".

Regards....Mike Connor
My System SpecsSystem Spec
.


29 Apr 2011   #4

Windows 7 Professional 64-bit
 
 

This only turns off smooth scrolling in IE, not Windows File Explorer. Thanks though...

Quote   Quote: Originally Posted by Irene View Post
Smooth scrolling on/off:
Turn off Smooth Scrolling

Quote:
  1. Click the Start button, and then click Control Panel.
  2. In Control Panel, make sure you are in Classic View, with all Control Panel icons showing. If not, click Switch to Classic View in the left pane of Control Panel.
  3. Click Internet Options to open the Internet Options dialog box. Click the Advanced tab and scroll down to the Settings: Browsing heading. Select or clear the Use smooth scrolling check box.
  4. Click OK, and then click the Close button.
My System SpecsSystem Spec
29 Apr 2011   #5

Windows 7 Professional 64-bit
 
 

Cool thanks! I'll look into this. Question though: can QTTabBar be used in conjuction with Classic Shell? I installed that last night and am quite happy with it.

Thanks,

Chris

Quote   Quote: Originally Posted by Mike Connor View Post
Welcome to the forums.

You might like to try this;

QTTabBar

solves most such Explorer problems, ( and gives very considerable enhancements), because the developer has managed to streamline the Explorer code. Explorer actually starts and runs a lot faster with this add-on. The add-on is integrated into Explorer itself, it is not a separate program as such.

It usually also clears the repainting problems, as it removes Explorer "lag".

Regards....Mike Connor
My System SpecsSystem Spec
29 Apr 2011   #6

Several, including Windows 7 x64 Ultimate
 
 

Quote   Quote: Originally Posted by fatherom View Post
Cool thanks! I'll look into this. Question though: can QTTabBar be used in conjuction with Classic Shell? I installed that last night and am quite happy with it.

Thanks,

Chris
Yes, a brilliant combination by the way, I use it myself. Some info on that;

Classic Shell Add On Buttons

the search modification shown there using StexBar is no longer required, The new QTTabBar release has solved the problem with slow searching. It is now extremely fast.

Regards....Mike Connor
My System SpecsSystem Spec
29 Apr 2011   #7

Windows 7 Professional 64-bit
 
 

So I "figured out" the graphic corruption issue. In "Folder and Search Options" I checked the "Show All Folders" box. Now my navigation pane includes things like Desktop (as the root node of the tree), Control Panel, Recycle Bin, etc. I actually prefer this anyway, but as a side effect, the navigation pane doesn't get visually messed up when I scroll.

Not sure why it fixes the problem, but it works for me.

So now my NEXT question. The 'network' entry in the navigation pane auto-populates about 5 seconds after the Explorer window launches. This is fine, except if I'm already somewhere else navigating and the network entry is off the bottom of the screen, when it does populate, the scrollable area jumps down to the network entry on it's own. Quite annyoing. Classic shell fixes most of the navigation pane scrolling bugs, except this. Any way to get the network entry to not populate and automatically expand?

Thanks again...

Chris
My System SpecsSystem Spec
29 Apr 2011   #8

Windows 7 Professional 64-bit
 
 

Fantastic! Gonna install it shortly.

Quote   Quote: Originally Posted by Mike Connor View Post
Quote   Quote: Originally Posted by fatherom View Post
Cool thanks! I'll look into this. Question though: can QTTabBar be used in conjuction with Classic Shell? I installed that last night and am quite happy with it.

Thanks,

Chris
Yes, a brilliant combination by the way, I use it myself. Some info on that;

Classic Shell Add On Buttons

Regards....Mike Connor
My System SpecsSystem Spec
29 Apr 2011   #9

Several, including Windows 7 x64 Ultimate
 
 

Quote   Quote: Originally Posted by fatherom View Post
So I "figured out" the graphic corruption issue. In "Folder and Search Options" I checked the "Show All Folders" box. Now my navigation pane includes things like Desktop (as the root node of the tree), Control Panel, Recycle Bin, etc. I actually prefer this anyway, but as a side effect, the navigation pane doesn't get visually messed up when I scroll.

Not sure why it fixes the problem, but it works for me.

So now my NEXT question. The 'network' entry in the navigation pane auto-populates about 5 seconds after the Explorer window launches. This is fine, except if I'm already somewhere else navigating and the network entry is off the bottom of the screen, when it does populate, the scrollable area jumps down to the network entry on it's own. Quite annyoing. Classic shell fixes most of the navigation pane scrolling bugs, except this. Any way to get the network entry to not populate and automatically expand?

Thanks again...

Chris
That works because explorer does not then try to jump around in the navigation pane. This is a bug in explorer. Doesn't happen when using QTTabBar when things are set up properly.

Only way I found to stop the problems with network, was to remove it from the pane;

http://www.door2windows.com/windows-...vigation-pane/

There are also instructions here in the tutorials, which will allow you to remove individual items;

Network - Add or Remove from Navigation Pane

You will almost certainly find that if you use QTTabBar, you don't need the navigation pane any more. Because you can reach any folder you want with a maximum of two mouse clicks, without any scrolling or anything like that.

Here an example;



Left-clicking on the icon in the tab, gives you an immediate cascade of the heirarchy, and you can just move there with the mouse and click on whatever you want. Right-clicking on the icon gives you a cascade of all items above the folder you are using.

There are also other ways to do this. It takes a little while to change your habits when you first start using QTTabBar. But it is a very great deal more comfortable and efficient than anything else I know of or have used.

Regards.....Mike Connor
My System SpecsSystem Spec
29 Apr 2011   #10

Windows 7 Professional 64-bit
 
 

Quote   Quote: Originally Posted by Mike Connor View Post
That works because explorer does not then try to jump around in the navigation pane. This is a bug in explorer. Doesn't happen when using QTTabBar when things are set up properly.
Just curious...I don't fully understand what you mean by this ("explorer does not then try to jump around in the navigation pane"). I don't really see Explorer jumping when "Show All Folders" is off/on, just the graphical corruption of the navigation pane when I scroll.

Quote   Quote: Originally Posted by Mike Connor View Post
Only way I found to stop the problems with network, was to remove it from the pane;
That's unfortunate, but it's what I ended up doing. I would've liked to been able to navigate network shares in the navigation pane, but that population/scroll jump is too annoying.

Gonna play more with QTTabBar...
My System SpecsSystem Spec
Reply

 Windows explorer Navigation pane graphics corrupted when scrolling





Thread Tools



Similar help and support threads for2: Windows explorer Navigation pane graphics corrupted when scrolling
Thread Forum
Remove icons in windows explorer navigation pane Customization
Stopping folder navigation pane auto scrolling down General Discussion
Changing Windows Explorer's Navigation Pane General Discussion
Windows Explorer Navigation Pane Autoscroll General Discussion
Windows explorer navigation pane General Discussion
Cleaning Up The Windows Explorer Navigation Pane Customization
Windows 7 Explorer Navigation pane Question Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:40 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33