Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: apache does not work, port 80 is used by...

05 May 2011   #1
rikkant

Windows 7 Home Premium 32bit
 
 
apache does not work, port 80 is used by...

I recently installed wampserver on my computer (apache, mysql, php). It is apache 2.2.17 version. However i cannot get it to start, and the wamp server icon stays yellow.

I've tried to find some information on other forums. Apparently the problem is that port 80 is used by another program and therefore apache cant use it. But i cannot find out which program (information not available). I don't have skype installed, so that cant be the problem. Any suggestions how to identify and turn of the other program using port 80?

Thanks.


My System SpecsSystem Spec
05 May 2011   #2
z3r010

 

If you type 127.0.0.1 or localhost into your webbrowser does any page display?
My System SpecsSystem Spec
05 May 2011   #3
rikkant

Windows 7 Home Premium 32bit
 
 

Nope, it says webpage cannot be found..
My System SpecsSystem Spec
05 May 2011   #4
SmurofNeves

Seven ultimate 32bit
 
 

Identify it on your router..? Check what port is occupied by what..
My System SpecsSystem Spec
05 May 2011   #5
rikkant

Windows 7 Home Premium 32bit
 
 

uhm.. how?
My System SpecsSystem Spec
05 May 2011   #6
wilywombat

win7
 
 

Port 80 is the port used by your internet browser! You probably need to search more on the WAMP or XAMPP boards for the answer to this one.
My System SpecsSystem Spec
05 May 2011   #7
Capt.Jack Sparrow

Windows 7 Ultimate - 64-bit | Windows 8 Pro - 64-bit
 
 

I'm not sure about the step. I have play with IIS setup not Apache. But Port 80 would be blocked by default in Router. Get into your router and open the Port. Then go to Open Port Check Tool and test for Port 80 to see if it's blocked
My System SpecsSystem Spec
06 May 2011   #8
wilywombat

win7
 
 

@Capt.Jack If port 80 is blocked, how is the OP getting on the internet? Port 80 is used by browsers....
My System SpecsSystem Spec
06 May 2011   #9
Capt.Jack Sparrow

Windows 7 Ultimate - 64-bit | Windows 8 Pro - 64-bit
 
 

Quote   Quote: Originally Posted by wilywombat View Post
@Capt.Jack If port 80 is blocked, how is the OP getting on the internet? Port 80 is used by browsers....
Not sure ... But mine and lot of cases I have seen was blocked in router. The website I mentioned for is what I used to check it. They block it to prevent worm attack. Just Google Port 80 blocked
My System SpecsSystem Spec
06 May 2011   #10
wilywombat

win7
 
 

You could block it but you wouldn't get out on the web..See this for port allocations:- http://en.wikipedia.org/wiki/List_of...P_port_numbers
My System SpecsSystem Spec
Reply

 apache does not work, port 80 is used by...




Thread Tools





Similar help and support threads
Thread Forum
ps/2 port of the case doesn't work properly
Hi guys, I'm going to install Win XP on my computer (I had win 7 but had some problem with installing the HP printer on it and so I decide to install XP because that printer seems to be installed properly on XP). Now When I put the XP CD on the CD driver, it says press a ker to boot from CD and...
Hardware & Devices
USB Port issue some drives work some don't!! Code 10!!
I have an HP Pavilion Dm4t-1000 and all of a sudden my usb ports will recognize some drives but not all of them. I attached a 1GB usb stick, a 16GB stick, and 2 external drives, one in an enclosure from a win 7 machine, and one actual external drive. The usb keys show up and autoplay, the externals...
Hardware & Devices
2TB Hard Drive won't work on Marvell 6GB SATA port
Intel Core i7-960 3.20GHz LGA1366 CPU BX80601960 MB Intel BOX DX58OG PSU Corsair 600W MEM 4G KST KVR1333D3/4GR x3 EVGA GeForce GTX 560 Ti Western Digital 500 GB SATA 6.0 GB-s Internal OEM Drive WD5000AAKX Western Digital 2 TB Caviar Black SATA 6GB/s Internal OEM Drive WD2002FAEX...
Hardware & Devices
Any ideas -Port opened in FW but won't work, telnet
Hi all! Glad to join your community, I found the SevenForums in a Google search on this problem...Looks like a real active group! I have searched Google and also the archives here, but I'm at a loss. Telnet is turned on. I'm trying to open a port to use with UltraVNC Single Click. The...
Network & Sharing
certain usb port don't work with usb reciever
I was wondering anyone else ran into this issue. I got a logitech vx revolution and when i plave the reciever into certain usb port on either my netbook or laptop it doesn't work. But when i place into other usb port on the same machine it works. Is there a reason for this and how do i fix it. ...
Hardware & Devices
UsB port won't work anymore :(
Hey ! Can anyone help me with this ? My usb ports (3) wont work. Nothing is recognize anymore. :cry: When I go in Device Manager, under universal serial bus controller, I have 5 tiny triangle with exclamation points. When I check the specs it says: Windows cannot start this hardware device...
Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 12:36.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App