Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Access Denied Permissions Gone due to XCOPY


14 May 2011   #1

Win7 Pro 64-bit sp1
 
 

I used xcopy in an admin cmd prompt, just as a test to learn how to use it. I asked it to copy a small directory from one HDD to another.

It did but now the entire partition on the destination drive is locked - "Access Denied."

I didn't add anything crazy to the xcopy switches though I did tell it to copy the system files (though like i said I created this directory just as a test - doubt there were any system or hidden files - I can see my hidden files and there were none).

One mistake I've come across in my research on this might be that I didn't check the permissions on the destination drive before I used xcopy.

Now ... - even using Diskpart - even in the Recovery Console Cmd Prompt - the Volume is listed but "access is denied." Safe mode cmd prompt, System Restore - all no help.

Oh btw, I know the files are still there. Right after I ran xcopy I looked inside explorer. The tree on the left was expanded and I was able to click my folders inside the drive, but the top level R:\ drive would not open. Once I rebooted explorer closed the tree and now it won't expand. But I'm 99% sure the files/folders are still there inside R:\.

Also tried takeown /f R:\ /r /d n - same thing, "Access is denied." Also icacls R:\ /restore AclFile - same story.

I can't imagine how I corrupted the permissions to such a deep level but that's where I'm at. ANY HELP at all would be extremely appreciated...

I'd really like to figure this out so I don't make the same mistake again - and maybe the solution will help someone else.

Thanks for any thoughts you can share with me, I appreciate it!

UPDATE: running chkdsk now on R:\ /x /b - not sure if it'll complete but at least CHKDSK runs! It also correctly identified the label for R:\, which is "Caches." First time I've seen the label show up anywhere since running xcopy.

CHKDSK completed, no errors or bad sectors found.

Interesting and frustrating:

I can run ICACLS R:\Handbrake /inheritance:d
"Successfully processed 1 files; Failed processing 0 files

But if I run the same command on the top-level R:\ directory it returns "Access is denied"

got to be an answer!

UPDATE #2: Chkdsk runs fine however when I try to run Defrag it reports "The given volume is currently locked. A format may be in progress, or the disk checking tool is running. (0x89000027)"

UPDATE #3: set the hidden admin account to active and tried the icacls operations, tried simply cd \d R:\ - none of it worked, all still the same "Access is denied."

wow I've been stumped before but not like this...I REALLY hope someone has an idea how to fix it! Thanks!


My System SpecsSystem Spec
.

15 May 2011   #2

Win7 Pro 64-bit sp1
 
 

Well - over a day, 114 views and no response. I had a feeling I'd already exhausted my options before I posted. ICACLS, TAKEOWN, SAFE MODE, WINDOWS RECOVERY ENVIRONMENT, SYSTEM RESTORE... None of them helped at all.

So...I wiped the drive clean and started over. Thankfully it was only Cache and Pre-render files -I used Robocopy and grabbed a few files before I wiped the drive.

I sure wish I knew what went wrong with XCOPY...

***************************

Thanks Anyway Folks...

my advice if you're new to it, avoid XCOPY. I'll never use it again; ROBOCOPY has more options (I think it's even multi-threaded) and the documentation for it is way better too.
My System SpecsSystem Spec
15 May 2011   #3

Windows 7 Ultimate RTM (Technet)
 
 

The better advice is to be sure you're aware of how to use XCopy before doing so. XCopy has been in use for years and its reputation is pretty darn good
My System SpecsSystem Spec
.


17 May 2011   #4

Win7 Pro 64-bit sp1
 
 

Use xcopy if you want but it produced an extremely bizarre result for me and it's not like I started blindly tapping keys into the CLI.

I assume what happened to me is fairly rare by the lack of response. I was hoping yours - well it doesn't matter.

Anyway, don't take it from me. Research both commands and you'll learn why robocopy is much preferred over xcopy.
My System SpecsSystem Spec
19 May 2011   #5

Windows 7 x86/x64, Server 2008r2, Web Server 2008
 
 

Have you tried a bootable OS and tried to access the drive?
My System SpecsSystem Spec
Reply

 Access Denied Permissions Gone due to XCOPY




Thread Tools



Similar help and support threads for2: Access Denied Permissions Gone due to XCOPY
Thread Forum
Permissions are completely messed up; access is constantly denied General Discussion
Solved Folder Permissions - Access Denied Error Network & Sharing
Directory & User Permissions, access denied General Discussion
Access Denied(despite ownership/permissions) General Discussion
Access/Permissions denied messages General Discussion
Solved Hosts: always Access Denied or asking for Admin permissions General Discussion
F-f-frustrated with Permissions & Access Denied!!! Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:34 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33