Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "Retrieving libraries..." error

13 Jun 2011   #1
JPaterson

Windows 7 Home Premium x64
 
 
"Retrieving libraries..." error

Hey all,

New to the forum, found this place through a Google search.

I'm having an issue with libraries in Windows 7 Home Premium x64.

I'm trying to add a pictures folder to the Pictures library, but whenever I right-click the folder to choose "Include in library", instead of bringing up the libraries on my machine, it says "Retrieving libraries..." and it lasts like this, doesn't ever change.

When I click the "Include in library" option on the toolbar, it doesn't do anything, presumably because it can't find the libraries.

Any ideas?

Thanks!


My System SpecsSystem Spec
.
13 Jun 2011   #2
t-4-2

Windows 7 Home Premium 64-bit, SP1
 
 

Quote   Quote: Originally Posted by JPaterson View Post
Hey all,

New to the forum, found this place through a Google search.

I'm having an issue with libraries in Windows 7 Home Premium x64.

I'm trying to add a pictures folder to the Pictures library, but whenever I right-click the folder to choose "Include in library", instead of bringing up the libraries on my machine, it says "Retrieving libraries..." and it lasts like this, doesn't ever change.

When I click the "Include in library" option on the toolbar, it doesn't do anything, presumably because it can't find the libraries.

Any ideas?

Thanks!
You have lost me completely.
I have exactly the same OS version as you do. I do not have " include in library " option no matter where or which I right click. I must have missed something ?

When I want to add a new folder, I'll just simple right click at the Pictures folder under Libraries > New > Folder.
My System SpecsSystem Spec
13 Jun 2011   #3
JPaterson

Windows 7 Home Premium x64
 
 

Screenshot at the following link:

Imageshack - libraries.jpg

I'm choosing a folder that isn't included in the "Pictures" library.
My System SpecsSystem Spec
.

13 Jun 2011   #4
DeaconFrost

Windows 7 Ultimate x64 SP1
 
 

You may be looking in the wrong spot. In Windows Explorer, I have an Include in Library button at the top, with a drop down to chose from existing libraries, or create a new one. You need to click on a folder first, to make the options appear.

Now, for the question, it sounds like some kind of OS corruption. you could try running the system file checker (sfc /SCANNOW) at an elevated command prompt.
My System SpecsSystem Spec
13 Jun 2011   #5
JPaterson

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by DeaconFrost View Post
You may be looking in the wrong spot. In Windows Explorer, I have an Include in Library button at the top, with a drop down to chose from existing libraries, or create a new one. You need to click on a folder first, to make the options appear.

Now, for the question, it sounds like some kind of OS corruption. you could try running the system file checker (sfc /SCANNOW) at an elevated command prompt.
Running now. Will re-post once scan is complete.
My System SpecsSystem Spec
13 Jun 2011   #6
JPaterson

Windows 7 Home Premium x64
 
 

"Windows Resource Protection did not find any integrity violations."

Any other suggestions? Heh
My System SpecsSystem Spec
13 Jun 2011   #7
DeaconFrost

Windows 7 Ultimate x64 SP1
 
 

Not really, unfortunately. I guess you could always try removing the libraries and recreating them.
My System SpecsSystem Spec
13 Jun 2011   #8
boohbah

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

Quote   Quote: Originally Posted by t-4-2 View Post
Quote   Quote: Originally Posted by JPaterson View Post
Hey all,

New to the forum, found this place through a Google search.

I'm having an issue with libraries in Windows 7 Home Premium x64.

I'm trying to add a pictures folder to the Pictures library, but whenever I right-click the folder to choose "Include in library", instead of bringing up the libraries on my machine, it says "Retrieving libraries..." and it lasts like this, doesn't ever change.

When I click the "Include in library" option on the toolbar, it doesn't do anything, presumably because it can't find the libraries.


Any ideas?

Thanks!
You have lost me completely.
I have exactly the same OS version as you do. I do not have " include in library " option no matter where or which I right click. I must have missed something ?

When I want to add a new folder, I'll just simple right click at the Pictures folder under Libraries > New > Folder.
right clicking a folder gives you the "include in library" in the context menu
Name:  2011-06-13_1602.png
Views: 3
Size:  53.0 KB


My System SpecsSystem Spec
Reply

 "Retrieving libraries..." error




Thread Tools




Similar help and support threads
Thread Forum
Libraries not showing up on navigation pane, "restore" not working
Hello, A couple of days ago I notice that the "Libraries" on the navigation panel were gone. (see image 001.jpg) The Libraries folder exists (in the AppData\Roaming\Microsoft\Windows\Libraries) and contains all the folders that should show. Right clicking and choosing "restore default...
General Discussion
Hard Disk can't read in "my computer ", "initialized",I/O device error
I have a big problem here, I have used my hard disk for 9month, Yesterday when I watched movie on the half way, My hard disk suddenly disfuntion, And I thought my laptop problem due to always lagging so I restart my computer. But after that I can't read my hard disk (WD)in my computer. It can...
Hardware & Devices
Attempted Share to Libraries Results in "Folder Not Indexed" Error
Hi all. I am unable to get a shared folder from one user account on the same machine to add to another user account's Libraries due to this "folder not indexed" error. The same thing occurs when trying to add across the network to a different computer for a different user account's Libraries. ...
Network & Sharing
Issues w/ "Documents" in Libraries - New install, Win7 Home Prem. x64
Hi guys - just doing a fresh install of Windows 7 Home Premium x64 on my bro's new system. He had been running WinXP until now, so it is time for an upgrade! I've run into an issue though - under Libraries, and then under Documents, the default My Pictures, My Videos, and My Music folders are...
Installation & Setup
"Whoops! Problems retrieving XML Data!"
Hi there, I don't know where to put this but I just started my computer and just like yesterday I had this pop up which says: ZOMG! Problems retrieving XML Data! What does this mean? :confused: I didn't do anything yet, just started the computer... That's all.
Performance & Maintenance
I hate the "Libraries" bring back "My Computer"
I hate the "Libraries" bring back "My Computer" Am I the only one whom dislikes the windows 7 windows explorer, I have ceased using the original "My" Folders years ago, all of my data is on NAS Servers, is there a replacement program that will allow me to customize file access more like XP My...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:33.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App