Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: thumbnails take too long to load


21 Jun 2011   #1

Win 7 Home Premium 64bit
 
 
thumbnails take too long to load

hi everyone,

I have this issue with thumbnails of photos taking a very long time to load when I open a folder in windows explorer. I mean a really long time, like 5+ minutes, for a folder that contains say 200 pictures. And this happens all the time, regardless of what else may be running, and regardless of what size thumbnails I select. What's weird too is that if I have an external harddrive hookep up through a USB 2 or 3, and open a folder in windows explorer with a similar number of pictures, those thumbnails load normal, fast. So it's only slow when it's reading thumbnails from my internal harddrive. Otherwise I don't believe my internal drive is slow, as everything else like launching programs etc works fine.

Can anyone tell me why this is happening? It's really annoying.
btw, I'm on an Envy 17 laptop, i5, 8 gigs RAM, 640 gig hars drive, Win 7 home premium. But I don't think my system config matters, since as I said, thumbnails load fine when reading from an external drive. Please help! thank you


My System SpecsSystem Spec
.

21 Jun 2011   #2

Microsoft Community Contributor Award Recipient

Windows 7 Ult. x64 Windows 8.1 x64
 
 

Hi Envy,

There are a few things you could try:

1. Is your internal hard disk heavily fragmented?
Heavily fragmented hard disks cause slower access times, although you would notice this with other file types too. Please follow the instructions in this tutorial, and let us know the outcome.

Disk Defragmenter - Open and Use

2. Has disk indexing being turned off?
Disk indexing allows faster search times for files in Explorer (I'm unsure if this could be the issue but please follow it up). Please follow this tutorial and let us know if it helps.

Index - Enable or Disable - Vista Forums

Another thing you can try, is to open up Task Manager, and watch which processes are utilising resources whilst you attempt to open one of those thumbnails. You can get more information on what is going on by usinjg Resource Manager too:

Resource Monitor

Lastly, can you tell us which anti-virus software are you using at the moment? We need to make sure you have at least something installed and running, and that the symptoms you describe are not virus-related.

Regards,
Golden
My System SpecsSystem Spec
21 Jun 2011   #3

Win 7 Home Premium 64bit
 
 

hi,

only 2% fragmented.
Indexing is not disabled.

Resource monitor shows no process hogging the processor. Explorer is at the top, with approx 3-5% CPU usage.
Using Norton Security Suite from Comcast.

Thank you for your suggestions, but they don't seem to be the issue. Again, thumbnails display fine when opening a folder on a USB attached drive. I would really appreciate someone solving this for me, it's very frustrating. thank you,
My System SpecsSystem Spec
.


06 Feb 2012   #4

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Quote   Quote: Originally Posted by Envy17 View Post
hi,

only 2% fragmented.
Indexing is not disabled.

Resource monitor shows no process hogging the processor. Explorer is at the top, with approx 3-5% CPU usage.
Using Norton Security Suite from Comcast.

Thank you for your suggestions, but they don't seem to be the issue. Again, thumbnails display fine when opening a folder on a USB attached drive. I would really appreciate someone solving this for me, it's very frustrating. thank you,
I have a similar problem but with my album art on my music. It either takes a long time to load or doesn't load at all. Have you found a solution?????
My System SpecsSystem Spec
06 Feb 2012   #5

XP / Win7 x64 Pro
 
 

Run "sfc /scannow" from an elevated command prompt to rule out a corrupted dll or system file that is hanging up the thumbnailing process. If it's just happening with the internal drive, I'd run a Disk Check on that drive.

Disk Check

Make sure both options are checked to scan and fix errors and bad sectors.
My System SpecsSystem Spec
02 May 2012   #6

Windows 2007
 
 
Explorer Thumbnails Loading Very Slowly

I had the same problem when trying to view thumbnails in a folder with a large amount of pics and what has worked for me is this. Select any of the thumbnails and then hold down the "Page Down" key until it reaches the bottom. Then hold down the "Page Up" key and let it shoot up to the top. While it's scrolling up the screen you might see some of the thumbnails be blank, as you would when they're not refreshing. Do this repeatedly a few times until you see the thumbnails as they should be and then stop and try and scroll up and down normally.

Good luck!

Tommy Lent
My System SpecsSystem Spec
Reply

 thumbnails take too long to load




Thread Tools



Similar help and support threads for2: thumbnails take too long to load
Thread Forum
Solved Most video thumbnails do not load Music, Pictures & Video
Most video thumbnails do not load Music, Pictures & Video
Thumbnails take forever to load sometimes. Music, Pictures & Video
Bios takes long time to load General Discussion
Album art takes long to load or doesn't load at all in explorer.exe General Discussion
Solved Why? Long load times from each mailbox! Microsoft Office
Why does it take a long time for a video to load? General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:11 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33