Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Print spooler not running /crashing

28 Jun 2011   #1

Windows 7 Home Premium (x64)
 
 
Print spooler not running /crashing

Hello, I am using a Windows 7 Home premium (x64) laptop and a Canon MP560 printer. Anytime I try to print from my laptop to my printer (through a wireless network), an error pops up which reads:

"Windows cannot connect to the printer. The local print spooler service is not running. Please restart the spooler or restart the machine."

Sometimes, the printer disappears from my computer (I don't delete it, it just vanishes) and when I try to add printer I get the message: "Windows can't open add printer. The local print spooler service is not running. Please restart the spooler or restart the machine."

I know it is not a problem with the printer as my husband's laptop is printing fine. Also, if I right click on the printer and try to print a test page from my computer it prints perfectly fine. However, I am unable to print anything from MS Word or the internet.
I have tried:
- System restore, twice.
- Manually starting the print spooler (in Services) but it stops running as soon as I send anything to print.
- Deleting and reinstalling the drivers for the printer.

Here are the event properties if this is helpful:
Faulting application name: spoolsv.exe, version: 6.1.7600.16661, time stamp: 0x4c6f61fe
Faulting module name: CNMN6PPM.DLL, version: 2.6.0.150, time stamp: 0x49d5bfef
Exception code: 0xc0000005
Fault offset: 0x00000000000256b2
Faulting process id: 0x56c
Faulting application start time: 0x01cc35c5dc8c25af
Faulting application path: C:\Windows\System32\spoolsv.exe
Faulting module path: C:\Windows\System32\CNMN6PPM.DLL
Report Id: 1afcd667-a1b9-11e0-aa01-e8113243c17f

I have spent the last few hours looking online for solutions and have tried everything I have found but nothing has worked, so I am hoping someone here might have a solution. Thank you so much in advance for any tips you have!

My System SpecsSystem Spec
.

21 Oct 2011   #2

Windows 7 Home Premium 64bit
 
 
Solved this problem

Tried several fixes and finally just deleted the cnmn6ppm.dll. Well that caused the spoolsv to quit stopping. Next I uninstalled all the Canon print programs and reinstalled them.
That fixed the problem.
I love everything about this Canon MX870. The ink tanks are sold at Amazon for less than $2 each and they work perfectly.
My System SpecsSystem Spec
Reply

 Print spooler not running /crashing





Thread Tools



Similar help and support threads for2: Print spooler not running /crashing
Thread Forum
print spooler does not always start Hardware & Devices
Print Spooler shut down by .spl .shd especially with QB POS 10.0 General Discussion
All Print Drivers Disappeared, Print Spooler Quits (7 Pro, 64-bit) Drivers
Have to stop/start Print Spooler to get documents to print? Hardware & Devices
Print spooler keeps stopping Hardware & Devices
Print Spooler Constantly Crashing BSOD Help and Support
Print Spooler Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:26 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33