Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: 0xc0000142 Errors

05 Aug 2011   #1

Windows 7 Ultimate x64
 
 
0xc0000142 Errors

Hi,

I'm using Windows 7 Ultimate. I've been using it for some time without problems, but this morning I was unable to get on the Internet. Yesterday I'd installed an update for ZoneAlarm which I thought was probably the problem, so I uninstalled in and downloaded and installed PC Tools Firewall Plus instead. no my computer will connect to the Internet OK, but whenever I try to open most programs, I get the following error:

"The application was unable to start correctly (0xc0000142). Click OK to close the application."

The only two exceptions I've found are Microsoft Security Essentials and Internet Explorer which both work fine.

Please can someone tell me what I need to do to stop this error from appearing?

Thanks,
Joe

My System SpecsSystem Spec
.

05 Aug 2011   #2

Windows 7 Ultimate
 
 

My System SpecsSystem Spec
05 Aug 2011   #3

Windows 7 Enterprise x64 SP1
 
 

I'm gonna ask you some questions just to be on the safe side:

Did you make any changes to the Windows\winsxs folder?
Have you recently run any cleaning software on your pc?
Did you disable any services (in Services.msc)?
Did you force a reboot/shutdown or experienced a power loss just before this happened?

Run a chkdsk on your c: drive after which run a command prompt with admin privileges and type sfc /scannow (and Enter).
My System SpecsSystem Spec
.


05 Aug 2011   #4

Windows 7 Ultimate
 
 

i would suggest doing the sfc /scannow first. if it was a format problem windows would of already tried to run a chkdsk. plus odds are you would be getting crc errors.
My System SpecsSystem Spec
06 Aug 2011   #5

Windows 7 Ultimate x64
 
 

ZyanWu - The answer to all your questions is no.

I tried running sfc /scannow and just got the following: "Windows Resource Protection did not find any integrity violations."

I didn't do a checkdisk first, but I did run one last Sunday anyway.
My System SpecsSystem Spec
06 Aug 2011   #6
Microsoft MVP

Windows 7 Ultimate X64 SP1
 
 

Welcome to Seven Forums Joe. Go ahead and run chkdsk /f to find and fix, you'll need to reboot and allow it to run.
Try using a Restore point before the problem occurred.
My System SpecsSystem Spec
06 Aug 2011   #7

Windows 7 Enterprise x64 SP1
 
 

The problem you're facing is (imo) caused by a missing dependency which might have been removed either with your uninstalling of ZA firewall either with one of the problems above. I don't know what was deleted and you're going to have to install a process which will tell you what dependencies the program you're trying to run has.
When that/those have been identified you can then proceed to (re)install them.
That's my side of the story.

If you reinstall ZoneAlarm does the 0xc0000142 Error go away?
Maybe if it does we can treat your inability to connect to the internet. Configuring a firewall to allow internet access is easier than figuring out what might have been deleted.
My System SpecsSystem Spec
07 Aug 2011   #8

Windows 7 Ultimate x64
 
 

Unfortunately I'm unable to reinstall ZoneAlarm because I just get the same error message when I try to open the installation file as I do when I try to open any other program.

I ran a checkdisk and after it finished all the programs that are set to open automatically at startup opened but I got the error when I tried to open a program by double clicking on it.

I ran System Restore (I had a restore point for the 4th and the problem started on the 5th) and when my computer restarted my computer was back to showing the error for my startup programs as well as programs I try to open by double clicking.

I got the following error: "System Restore did not complete successfully. your computer's system files and settings were not changed.

Details: System Restore failed to replace the file (C:\Windows) with its original copy from the restore point.
An unspecified error occurred during System Restore. (0x80071a90)

You can try System Restore again and choose a different restore point. If you continue to see this error, you can try an advanced recovery method. For more information, see What is Recovery?"
My System SpecsSystem Spec
07 Aug 2011   #9

Windows 7 Ultimate
 
 

Quote   Quote: Originally Posted by successgold View Post
Unfortunately I'm unable to reinstall ZoneAlarm because I just get the same error message when I try to open the installation file as I do when I try to open any other program.

I ran a checkdisk and after it finished all the programs that are set to open automatically at startup opened but I got the error when I tried to open a program by double clicking on it.

I ran System Restore (I had a restore point for the 4th and the problem started on the 5th) and when my computer restarted my computer was back to showing the error for my startup programs as well as programs I try to open by double clicking.

I got the following error: "System Restore did not complete successfully. your computer's system files and settings were not changed.

Details: System Restore failed to replace the file (C:\Windows) with its original copy from the restore point.
An unspecified error occurred during System Restore. (0x80071a90)

You can try System Restore again and choose a different restore point. If you continue to see this error, you can try an advanced recovery method. For more information, see What is Recovery?"
run system restore from safe mode. about half the time running it in the normal environment it will fail. the easiest way to get into safe mode is: start, run, type msconfig, go to the boot tab and check safe boot. once in safe mode run the system restore first, reboot, once back in safe mode you can go back to msconfig and uncheck safe boot and restart.
My System SpecsSystem Spec
08 Aug 2011   #10

Windows 7 Ultimate x64
 
 

In the end I just decided to restore from my Acronis TrueImage backup image which I made last Monday which meant I had to backup a lot of files that had changed but I managed to get everything restored and I don't think I've lost anything.

I uninstalled ZoneAlarm which worked fine and then I installed PC Tools Firewall again and the problem came back with the same error whenever I tried to open programs. This time I tried restarting in safe mode and uninstalling PC Tools Firewall and it worked. When I restarted in normal mode everything was fine again so I installed the latest version of ZoneAlarm and everything seems to be working fine now.

Thank you for the help and advice.
My System SpecsSystem Spec
Reply

 0xc0000142 Errors




Thread Tools



Similar help and support threads for2: 0xc0000142 Errors
Thread Forum
Solved Regedit (0xc0000142) error General Discussion
error 0xc0000142 help! BSOD Help and Support
Error '0xc0000142' - Need Help BSOD Help and Support
0xc0000142 in x86 programs BSOD Help and Support
0xc0000142 Problem BSOD Help and Support
Does Anyone Know of a Fix for the 0xc0000142 Problem BSOD Help and Support
0XC0000142 Error BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:03 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33