Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Installing language pack on a multi-boot system fails

29 Aug 2011   #1

Um... Windows Seven, obviously
 
 
Installing language pack on a multi-boot system fails

I have Windows Ultimate x64. It's a fresh (re)install. After retrieving all available updates (including all optional drivers) and rebooting, I tried to install the Japanese Language pack via Windows Update and after maybe around twenty minutes of the software trying to install, Windows Update reports an install failure. The error message is:

Code:
Code 80070643: Windows Update encountered an unknown error.
I Googled the error code, and Microsoft says that the error is caused by a possibly corrupt .NET install. After using their .NET cleaner and reinstalling all the applications, the error persists. I looked further on Google and read a post by someone with the exact same problem as me. It looked like he was able to fix his problem pretty easily, and he explains how he resolved it in his following post, but his explanation is a little over my head. From what I can tell he used bcdboot to tell Windows where the reserved system partition is or something like that. But without explicit instructions I'm kind of in the dark. I'm not good with Windows. I prefer Linux. Basically I need what he did explained in Captain Dummy talk... I think his solution is the solution to my problem as well.

My System SpecsSystem Spec
31 Aug 2011   #2

Um... Windows Seven, obviously
 
 

Hey neat! I fixed it myself by guessing at the guy's instructions!

What he did was issue the following command:
Code:
bcdboot C:\windows /s C:
And marked my system partition as active by using the administrative tools. I thought this would remove my boot loader, but it didn't, I still have GRUB. I think I basically just gave myself write permissions to the system drive, which Windows needed to install the language pack.
My System SpecsSystem Spec
Reply

 Installing language pack on a multi-boot system fails





Thread Tools



Similar help and support threads for2: Installing language pack on a multi-boot system fails
Thread Forum
Solved Unable to change language (pack) nor Repair installing. Installation & Setup
Icons changed after installing MS Office 2010 language pack Microsoft Office
removing win7 64 from multi boot system Installation & Setup
XP dies in multi-boot system BSOD Help and Support
Multi-boot system General Discussion
Unexpected error on multi-boot system Installation & Setup
Windows 7 RTM Language Pack and Local Pack General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:55 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33