Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: PC isn't Showing Image, and restarts 30 seconds after...

31 Aug 2011   #1

Windows 7 64 bit Ultimate
 
 
PC isn't Showing Image, and restarts 30 seconds after...

Hello guys, i need some help with something.
Tdoay i installed a new Case for my PC an a new PSU for my PC, i DID everything as i should, and when i press the power button, i get the fans to work, all the lights and stuff but no image, also the leds on the mouse dont start up, and the lights on the keyboard dont start up either, after 30 seconds the pc turns off, and then turns on again i dont really know what to do now, im really dscared since ive been working to get some money for this parts and now looks liek something is wrong please help me guys

My System SpecsSystem Spec
31 Aug 2011   #2

Win7 Home Premium 64x
 
 

Can you give us some info on the case and PSU that you installed and the motherboard?

I would say one thing is the power to the motherboard can be either 20 pin or 24 pin so make sure that is right.

Also, there is a set of wires that go to the motherboard from the front panel to tell the computer to start/restart/and leds... make sure these all match on the motherboard.
My System SpecsSystem Spec
31 Aug 2011   #3

Windows 7 64 bit Ultimate
 
 

The Case is a Thermaltake Element G and the PSU is a Corsair HX850W NON Modular, the power to the mobo is ok a 24 pin just checked, also i disconnected all the front panel cables to make sure it wasnt an error with them. turned on manually and same error appears
My System SpecsSystem Spec
.


31 Aug 2011   #4

Win7 Home Premium 64x
 
 

how did you take out mobo/components? did you take precautions against ESD?

another thing might be standoffs in the new case? maybe grounding out?

do you have a way to test the new PSU? it might be faulty as well.
My System SpecsSystem Spec
31 Aug 2011   #5

Windows 7 64 bit Ultimate
 
 

yes i did it with a lot of caution. how can i test the new psu?
My System SpecsSystem Spec
31 Aug 2011   #6

WINDOWS 7 Ultimate x64 Full
 
 

Hello Dan, There are some very talented people on this forum that would love to help solve your P.C issuses but you must help us first start by filling in your sys specs.
My System SpecsSystem Spec
31 Aug 2011   #7

Win7 Home Premium 64x
 
 

you should check the docs that came with the PSU for the correct voltages

Then, you can either use one of these: Newegg.com - Rexus PST-3 Digital Power Supply Tester with LCD

or a regular multimeter: Newegg.com - GB Gardner Bender DM6400 8 Function Digital Multimeter

and here is a good tutorial: Power-supply troubleshooting with a multimeter | TechRepublic
My System SpecsSystem Spec
31 Aug 2011   #8

Win7 Home Premium 64x
 
 

another thing to check would be that all the components are seated properly... the RAM could have popped out? but this would still allow post I think....

If the CPU is not seated correctly, then the computer wont POST though I think (I could be wrong, but I will check)

Also do you here any beeps? usually if there are errors during POST, there will be beep codes:

http://en.wikipedia.org/wiki/Power-on_self-test
My System SpecsSystem Spec
01 Sep 2011   #9

Windows 7 64 bit Ultimate
 
 

ok i will try testing all that, about the multimeter, well i dont have one and i live outside of the us so its really hard for me to buy one so ill try witht the pther psu andd alll that stuff, and ill tell you if something worked, i cant get to hear any beps
My System SpecsSystem Spec
01 Sep 2011   #10

Windows 7 64 bit Ultimate
 
 

tried installing thother psu and the same error appeared
My System SpecsSystem Spec
Reply

 PC isn't Showing Image, and restarts 30 seconds after...





Thread Tools



Similar help and support threads for2: PC isn't Showing Image, and restarts 30 seconds after...
Thread Forum
Folder Icons showing image contents General Discussion
Image not showing in folder backgrounds for my windows themes Themes and Styles
System image not showing up Backup and Restore
Computer freezes sudenly every 2-3 seconds and freezes/crashe/restarts Gaming
pdf image not showing General Discussion
BSOD touch screen PC restarts randomly showing BSOD 0x0000007E BSOD Help and Support
Computer restarts a few seconds after shutdown BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:15 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33