Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: External Hard Drive keeps on showing Autoplay prompt

13 Oct 2011   #1
kevindd992002

Windows 7 Ultimate x6
 
 
External Hard Drive keeps on showing Autoplay prompt

I have a fresh install of Win7 x64 Ultimate on my PC and there are times that when I reboot my computer or turn it on from an off state I get the Autoplay prompt for my External HDD. This occurrence is totally random and it doesn't happen sometimes. It just gets annoying that when you boot up you see that prompt and you have to close it every now and then. What could be the problem in this case? I have an Asus P8Z68-V motherboard.

Please help. Thanks.


My System SpecsSystem Spec
.
13 Oct 2011   #2
Brink

64-bit Windows 10 Pro
 
 

Hello Kevin,

If you don't use it, then turning off AutoPlay should sort this for you.

Hope this helps,
Shawn
My System SpecsSystem Spec
13 Oct 2011   #3
speedgamer01

Windows 7 Ultimate 64 bit SP1
 
 

You can check if the plugs are connected ok. Otherwise this is normal in my opinion.
Though you can disable it, open Control panel > Autoplay, now set mixed content or any other fields to 'take no action'.
The message might pop up for a moment afterwards as well, but most times it doesn't as i can remember.
My System SpecsSystem Spec
.

13 Oct 2011   #4
kevindd992002

Windows 7 Ultimate x6
 
 

But i do use Autoplay. I want the Autoplay feature to come up when I plug in USB devices in my PC. I'm just annoyed with this one because it is already connected and why should it still me prompt up that. I would say it is "normal" if it happens every single time I reboot or shutdown and turn back on. But this isn't the case, it is happening randomly. I still want to know what's causing these?

One thing to note though, USB3.0 legacy support, USB legacy support, and EHCI Hand-off are all disabled in my BIOS settings because based on what I'm reading in the Internet, Win7 natively supports all of these. Does that ring a bell in my problem above?
My System SpecsSystem Spec
13 Oct 2011   #5
Brink

64-bit Windows 10 Pro
 
 

Kevin,

From what SG posted above, do you have the external HDD listed under "devices" in AutoPlay (Control Panel) where you could set it to "take no action"?
My System SpecsSystem Spec
13 Oct 2011   #6
kevindd992002

Windows 7 Ultimate x6
 
 

Quote   Quote: Originally Posted by Brink View Post
Kevin,

From what SG posted above, do you have the external HDD listed under "devices" in AutoPlay (Control Panel) where you could set it to "take no action"?
There is no Device listed under "devices" in Autoplay (Control Panel) even though my external HDD is connected and running properly. Is that also normal?
My System SpecsSystem Spec
13 Oct 2011   #7
Brink

64-bit Windows 10 Pro
 
 

Sometimes a external HDD may be displayed, and sometimes not in AutoPlay.
My System SpecsSystem Spec
13 Oct 2011   #8
Windows i7 920

Windows 8 Pro x64
 
 

Also try making sure there's no autoplay configuration file on the HDD itself as this could cause it.
My System SpecsSystem Spec
13 Oct 2011   #9
kevindd992002

Windows 7 Ultimate x6
 
 

What does it mean if the device is not listed under Autoplay? Why is my drive still randomly Autoplaying "just after restart"?

There's no Autoplay config file or whatsoever in every directory present in my external HDD. One thing to note though, I partitioned this drive to be GPT, does that count for something in this situation?
My System SpecsSystem Spec
18 Oct 2011   #10
logicearth

Windows 10 Pro (x64)
 
 

I'm going to take a guest as to why this is happening. The drive turns off, Windows thinks it has disconnected, the drive turns back on, Windows thinks it has reconnected. Either way, I think this problem is hardware related in some way.
My System SpecsSystem Spec
Reply

 External Hard Drive keeps on showing Autoplay prompt




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
External Hard Drive not showing up.
I usually use the hard drive with the desktop, however the other day I plugged it into the laptop, it was running at the time, and was accidentally unplugged, since then it doesn't seem to be recognized in either computer. The laptop will make the noise when I plug in the external drive, and it...
Hardware & Devices
Autoplay from External Hard Drive Question
Hey everyone, Whenever I plug my External Hard Drive in, my Autoplay pops up which is fine. But under General Option where it says Import Photos, it is my Lightroom program. But the problem is that it does not show the correct program (I have Lightroom 5.3 installed and my Autoplay says...
Hardware & Devices
External Hard Drive Not Showing Up
I have a western digital 2tb hard drive and I am unable to access any of the information on it. It is listed in the devices and printers, but it doesn't give me many options to do much, just view it. I know that it works on my hp laptop, but the laptop has since crashed. I purchased a new hp...
Hardware & Devices
Samsung s2 external hard drive not loading showing local disk F drive
I have a Samsung s2 1tb external hard drive. Today when I hooked it up to my laptop it would not load. It will shows local F drive when it usually will say samsung Drive. A pop up box will then appear stating "you need to format drive" I know if I reformat it I will lose all my data which...
Hardware & Devices
External Hard Drive not showing up anywhere
Hi everybody. I have a problem :( My 3TB Western Digital Hard Drive is not showing up on any PC I connect it to. The light on the drive itself is on, but no where on the PC does it register. I am pretty sure the disks aren't spinning either, but that is probably because the computer isn't...
Hardware & Devices
External hard drive not showing up
So I recently purchased and installed a new hard drive in my PS3. To do that I had to reformat my Western Digital 250 GB hard drive to FAT32 format. Ok, so that's all well and good but I then decided to take my PS3, 60 GB HD (the brand escapes me, but it's a big manufacturer of hard drives) and put...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:38.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App