Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Needs elevation (the usual fix doesn't work)


16 Nov 2011   #1

Windows 7 Home Premium 64 bit
 
 
Needs elevation (the usual fix doesn't work)

On a Windows 7 ultimate system (svc pack 1), when I try to open any file in the my documents folder I get an error message that says that this operation "needs elevation".

So I picked one particular file that I couldn't open and I looked at the owner in the security tab. Indeed the owner was not set to me. It was set to "Administrator". Although I'm logged in as an administrator, my login has my name in it, so this was not me. (I don't see any other user accounts however). So anyway I go ahead and change the owner to me. If I cancel and go back in thru properties I see that this worked. (i.e. I am now listed as the owner of this file). However windows still will not allow me to open the file (same error messages). I have the permissions set to "Everyone", and all the permissions are checked. (I do this to allow full file sharing, even with non Windows 7 computers). I've tried playing with various permissions, but everything I see is checked. Why is windows still so insistant that I shouldn't open this file?

By the way, I tried copying the file to another drive. Windows allows that, but again I can't open it. Then I deleted this copy, which windows did without complaint. I'm dumbfounded. Windows thinks it's perfectly acceptable for me to have rights to delete a file that I have no right to even look at.

By the way, I have run Malwarebytes and Superantispyware. Both found and fixed a few problems, but still this needs elevation problem remains.

Thanks in advance for any suggestions you may have.

~Paul

My System SpecsSystem Spec
.

16 Nov 2011   #2

Windows 7 Home Premium 64 bit
 
 

I thought I should add that I just tried changing my "User Account Control" to the lowest notch (never notify). However I still get the dreaded "Needs elevation" warning just the same.

I also verifed that the files in question are still good. I can copy these files to another computer and they open just fine there.

I hope there is a solution short of reloading the operating system, since that will be painful and quite time consuming.

~Paul
My System SpecsSystem Spec
Reply

 Needs elevation (the usual fix doesn't work)




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:18 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33