Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Deleted Library Folder, Got Explorer Problems


26 Nov 2011   #1

Win 7, 64 bit, Home Premium
 
 
Deleted Library Folder, Got Explorer Problems

Hi folks

After trying several registry fixes to either disable, remove, hide libary or remove library pane I finally got so pissed I simply deleted the libary folder in C:\Users\Bruker\AppData\Roaming\Microsoft\Windows. To my great relief I suddenly had no problems saving documents or images in my documents or images, which was suggested in the Save to menu. No Save to library "popping up" all the time, and no library removing my choosen folder every so often so that I had to check every time I saved a document or image that the library had not taken over from my already choosen folder.

However, after I got rid of the library, every time I want to create a new folder, rename a folder, create a new file or rename a file, and some times also move a folder/file I get a error message telling me the folder/file is not found in it's location. The folders or files are where they are supposed to be, but explorer don't seem to "see" them. However, when I click the Retry button (that is retry the folder/file move, rename, creation, etc) things work out.

This "funny" error message and retry process are time consuming, and a bit bothersome, so I wonder if anybody know what to do to correct it? I Guess explorer somehow relates to the deleted library function, instead of looking to itself, but have no idea what to do about it. If nobody know about a solution I'll live with this rather than have the library horror back.

Thanks for any reply, and have fun :-)

Also, thanks to many posters for answers and tweaks, I have learned a lot from those when I have been browsing this forum!

Jacey

My System SpecsSystem Spec
.

27 Nov 2011   #2

Win 7, 64 bit, Home Premium
 
 

Hi

I just found this info on page 6 (reader comments) in this post - [Fix] “Item Not Found” Error Message While Moving Files and Folders in Windows 7 Explorer After Installing Service Pack 1 (SP1) - Tweaking with Vishal

"Using this "Disable Libraries in Windows 7" script resulted in the error "Could not find this item. This is no longer located in ... Verify the item's location and try again." when trying to create new folders. The fix to restore libraries resolved the problem, but restored the libraries. Use with care."

The main post say this is common after installing service pack 1 in Windows 7, which I have not. But, I did use the mentioned reg file and disabled the library. So it seems I was wrong when assuming this error message came about because I deleted the library folder. The author of the post say this error message will go away when using the reg file "Restore Default Settings.reg",but then I will get back the library too, which I absolutely do not want to.

It seems to me, and I'm no expert in these matters, that windows explorer somehow points or references to the deleted library folder, since it always say in the error message that the file or folder in question can no longer be found in the location C:\Users\AppData\Roaming\Microsoft\Windows. When I f.ex create, rename or move a file or folder in a folder located in partition D, it still refers to the C:\Users\ etc location, even though the file or folder never have been located in C:\Users\ etc.

My documents folder and all other documents or image folders are located on another partitions than C:\, but explorer keeps referencing the files and folders to C:\Users\AppData\Roaming\Microsoft\Windows library folders. So, how do I tell explorer to refer to the true file and folder locations, avoiding the C:\Users\ etc reference?

Thans for any help :-)

Jacey
My System SpecsSystem Spec
27 Nov 2011   #3
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

Looks like you axed everything in sight. No wonder the thing goes on the blink. Here is a thread where the matter is being discussed in more detail - maybe it helps.
My System SpecsSystem Spec
.


27 Nov 2011   #4

Win 7, 64 bit, Home Premium
 
 

Hi whs

Thank you for your suggestion. In the thread I found nothing I could use, but perhaps I would if the user garza had told us what dll files he deleted. In this post from the thread - Start Menu User Folder Buttons - Open to Users Instead of Libraries I see you experts in here seem to know about the problem. But, to my understanding I don't need to have my start menu folders open to users, but rather my main folders like my documents and my images, etc to point to themselves, where they are actually located. Or rather, to have explorer point to the files and folders where they actually are instead of where they are supposed to be according to windows.

If I f.ex create a file or folder in D:\My Documents I would like explorer to refer to the file or folder being created in D:\My Documents instead of checking in C:\User etc and then give me a error message telling me the file/folder I am creating is not found there. Also, I wonder why explorer finds the files/folders when I click Retry. My explorer have Alzheimer's?

Have fun :-)

Jacey
My System SpecsSystem Spec
27 Nov 2011   #5
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

I really do not know where your problem is. I have my default folders on C: and other user folders on F:. And they are clearly identifyable as such (see pic).

When you store to the library, it always goes to the default folder which is clearly defined in the library properties. And you can designate any folder as default.

As to your current problem - it is hard to say what is happening. You changed too much to be able to tell.


Attached Images
 
My System SpecsSystem Spec
Reply

 Deleted Library Folder, Got Explorer Problems




Thread Tools



Similar help and support threads for2: Deleted Library Folder, Got Explorer Problems
Thread Forum
Accidentally deleted a folder I created in my "my videos" folder Music, Pictures & Video
I am so mad please help me Windows Media Deleted- Broken Library General Discussion
Solved Deleted files from Picture Library. Can they be recovered? Backup and Restore
I deleted the desktop folder in my personal folder General Discussion
HELP! Pic folder set up in the library Music, Pictures & Video
Folder Deleted General Discussion
Deleted Items Folder: Where Are The Deleted Messages Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:48 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33