Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Solved: Windows Explorer would not display correct volume labels

14 Dec 2011   #1

64-bit Windows 7 Home Premium
 
 
Solved: Windows Explorer would not display correct volume labels

I had a problem with Windows Explorer not displaying the correct volume labels of external or thumb drives when these were renamed. The volume labels were, however, correctly displayed in command prompt and Disk Management.

In my case, it had to do with the autorun.inf folder created by a USB security program I installed.

Of course, I could always force Explorer to display the correct volume label by specifying it in the autorun.inf file, but the USB security program always removed the autorun.inf file to create its own customized autorun.inf folder. I discovered by trial-and-error (even experimenting with clean and safe boots) that the customized folder was the only one causing the Explorer to not display the correct volume label.

My solution was to uninstall the USB security program because (1) I found out during my search for a solution that Windows 7 does not acknowledge autorun.inf anymore, so there's really no need to have a resident USB malware-blocking program and (2) this SMALL bug (?!) had been a BIG pain in the fill-in-the-blank for quite sometime.

Now, for the protection of the individual thumb drives (to be inserted in systems other than my own), I use a USB protection program that does not need to be installed in my system, such as Bitdefender's USB Immunizer. The program "immunizes" (or "vaccinates") my thumb drives by creating its own customized autorun.inf folder on them, too, but because there's no resident blocking program in my system to interfere, the correct volume labels are now displayed by Explorer.

I am posting this for reference to those users who have the same problem as mine.

My System SpecsSystem Spec
.

Reply

 Solved: Windows Explorer would not display correct volume labels





Thread Tools



Similar help and support threads for2: Solved: Windows Explorer would not display correct volume labels
Thread Forum
Solved Unable to hide menu bar in Windows Explorer (problem solved) Customization
Solved SOLVED: Run XP Mode Explorer from Windows 7 Virtualization
Clock Won't Display Correct GMT/UTC ? General Discussion
has the windows 7 explorer folder refresh bug been solved? General Discussion
nVidia display and Win 7 crash solved Graphic Cards
Volume labels not showing in explorer Installation & Setup
hard drives labels not showing in explorer Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:44 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33