Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cannot fix Missing BootMngr error


16 Dec 2011   #1

Win 7 Premium 64 bit
 
 
Cannot fix Missing BootMngr error

I have a new laptop (refurbished) that came with Windows 7. When I initially started the machine it went through the install process, and finished with burning 4 recovery disks. All good at this stage.

I then installed Linux as a dual boot and again all was well. Both OS's booted fine.

I then (stupidly) resized the C:\ partition and on next boot got the "BootMngr" missing error.

I decided to use the 4 discs expecting a menu to repair or recover -instead it went straight into a recovery install procedure. So the first thing was it warned me that the entire disk would be repartitioned resulting in loss of data etc. No problems I had already cleared what I needed.

It seemed to install OK, but when I tried to boot, I just got a black screen and blinking cursor.

I reinstalled Linux and tried to reboot. This time the windows OS had been found, and I chose Windows, this was when I got the BootMngr missing error.

I searched the net and found a number of fixes involving using an installation CD (which a friend loaned me) using this I was able to get to the"repair computer" part and went into the command line to copy the bootmngr file to the correct place. c:\ from the disc. But it couldn't find it. I then realised that the file was on the D:\ disc and I successfully copied it to the C:\ but same error came again.

I have tried changing to the Boot directory in D:\ and using bootrec/fixboot and bootrec/rebuild bcd but all to no avail.

Anyone know how to fix this so that I can get into my windows system again?

Is there a way to make a Windows"Live" CD so that I can see the system without mounting the partitions?

My System SpecsSystem Spec
.

16 Dec 2011   #2

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

To Remove Linux take look at this post:
Error 0xc0000225 on boot
My System SpecsSystem Spec
16 Dec 2011   #3

Win 7 Premium 64 bit
 
 

You misunderstood my post. I have no intention of removing Linux, I just want Windows to be available to boot. I find it quite amazing that the 4 "recovery" discs do not place the bootmngr in the MBR which is where it should be placed.

The question was how do I reset the bootmngr file to the correct place ie ion the MBR.
My System SpecsSystem Spec
.


16 Dec 2011   #4
Microsoft MVP

 

Run Factory Recovery from its partition at boot which is the most stable method. Use the disks as backup only.

Please fill in your System specs in the bottom left corner of post so we can help you better since you don't even mention your make/model.

The best method to add Linux is here: Dual boot Ubuntu-Win7. This keeps GRUB off the Windows 7 partition which can be corrupted easily by it.
My System SpecsSystem Spec
17 Dec 2011   #5

Win 7 Premium 64 bit
 
 

Maybe I should have not mentioned the dual boot as this seems to be confusing things.

Even when I completely got rid of everything, made one blank partition and then used the recovery discs, the bootmngr was still placed in the wrong place. Copying it from D: to C: made no difference.

The issue is- after using the 4 discs I am left with an unbootable system.

How can I
Quote:
Run Factory Recovery from its partition at boot which is the most stable method
when I can't even boot -- I don't understand,please elaborate.

Can I get a disc that will allow me to boot and then carry out whatever changes I need to in order to get the Win 7 bootmngr to work correctly?
My System SpecsSystem Spec
17 Dec 2011   #6

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Quote:
Maybe I should have not mentioned the dual boot as this seems to be confusing things.
The dual boot is the problem.

All Linux code must be deleted using the CLEAN ALL command.As you have had linux on the HD you need do a Clean all & full format.

Type in command line
DISKPART
LIST DISK
SELECT DISK # (win HD)
CLEAN ALL
CREATE PARTITION PRIMARY
SELECT PARTITION 1
ACTIVE
FORMAT fs=NTFS
ASSIGN
EXIT
EXIT
SSD / HDD : Optimize for Windows Reinstallation

Than Run Factory Recovery from Recovery DVD's.
My System SpecsSystem Spec
17 Dec 2011   #7
Microsoft MVP

 

Yes, you need to clean the boot sector using Diskpart Clean or Clean All Command. Clean All takes about an hour per 320 gb.
My System SpecsSystem Spec
17 Dec 2011   #8

Win 7 Premium 64 bit
 
 

OK now that is clear, it sounds reasonable. I will let you know what happens. Thanks

UPDATE

So here am a full 12 hours of loading reloading and cleaning and sweeping and nada. This is the story. I followed the instructions completely with the exception of doing a "clean" before the "Clean all" command (apparantly that clears the MBR as well) 2.5 hrs it takes to write all the little zero's to my 600 gig disc. Then I went through the install process using the created ASUS image recovery discs that I burned on initial install. All went well.I rebooted -- black screen flashing cursor.

Using my Linux live CD I was able to examine the file and partition structure, yup, there is the 21.49 gig Recovery partition, the NTFS Win C: partition and the NTFS Win D: partition complete with files galore. But no Bootmngr in the correct place.

2nd try - went through the entire process again but this time used the single Windows 7 install DVD that my mate lent me. All went well It booted -- yahoo -- until it got to the product key window.

Carefully copying the key on the bottom of my laptop, I clicked enter and it told me that it did not fit the windows SKU. and there it stayed.

I tried the whole process again and this time after entering the key and getting the same answer I turned the machine over and photographed the key to make sure my eyes were not seeing things. When I turned it back over it had advanced to a new window? go figure. So when it finally loaded up, I looked for my programs and found that I only had a base install- none of my preloaded programs. Thats no good at all.

So back I go the drawing board. It seems that the ASUS discs will recover the image, and reload all the factory settings, but puts the bootmngr on the D rather than the C drive (or apparently the MBR)

Contrary to all these issues, I load up the single DVD OpenSuse 12.1 Linux disc and in 20 minutes have a fully functional system including on the boot menu an entry saying "Windows 7" (Seems Linux can find the windows system OK)

Clicking that entry results in "Bootmngr missing press cntr-alt-del"

I hate having a computer beat me, but in this instance it seems that neither the ASUS recovery discs nor the Windows 7 DVD can effectively recover a damaged windows 7 system.

I remain hopeful that someone could suggest something that might work -- like the correct way to copy the bootmngr of windows onto the C: drive and have the system see it.

Too hard? I wait and see. Is there anyone up to the challenge. (By the way I have lost count of the number of threads on the net started over the last 3 yrs on this exact problem, and still MS does not fix the issue!)
My System SpecsSystem Spec
05 Jan 2012   #9

Win 7 Premium 64 bit
 
 

Well there you go -- two weeks and not one suggestion. Not a wonder more and more people are switching over to Linux. So now I will leave as is, and maybe later have another look, just for fun's sake.
My System SpecsSystem Spec
05 Jan 2012   #10
Microsoft MVP

 

If you clean reinstall Windows 7 with the disks, why would you expect your programs to still be there?

What you need - and I'm sorry it was not mentioned earlier but we were under the impression you wanted to run Factory Recovery - is to run Startup Repair repeatedly from the System Recovery Options.

A problem can be that if GRUB is on the HD it may corrupt Windows 7 beyond repair until GRUB is wiped completely. This is the point Theog was trying to make.

If Startup Repair can't get any traction after several attempts, make sure Windows 7 or it's 100mb System Reserved partition (preferred) are marked Active, then run Startup Repair - Run 3 Separate Times to repair/rewrite the System boot files to the boot partiton or Windows 7 partition itself. If one fails, try the other.

You can use free Partition Wizard bootable CD to Modify>Set to Active, then click on the Disk number to highlight it, from Disk tab select Rebuild MBR which can preclude the need to run the Repairs.
My System SpecsSystem Spec
Reply

 Cannot fix Missing BootMngr error




Thread Tools



Similar help and support threads for2: Cannot fix Missing BootMngr error
Thread Forum
Solved comctl32.dll missing error General Discussion
gdiplus.dll missing error - tried everything and won't go away Software
"Bootmgr is missing" error upon startup, caused by human error General Discussion
HDDRECOVERY missing error Hardware & Devices
bootmgr is missing error BSOD Help and Support
Missing link error Gadgets
cd/dvd drivers missing error Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:51 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33