Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Why does Windows 7 freeze when I try to switch to AHCI mode?

01 Jan 2012   #1
crovou718

Windows XP Ultimate x64
 
 
Why does Windows 7 freeze when I try to switch to AHCI mode?

I changed the appropriate setting in the registry. (msachi > start: 0) Then I changed the setting in my motherboard and Windows froze upon starting up, and my system rebooted.

The thing is, I changed it to AHCI before. It worked fine! I then switched back to IDE while trying to fix a problem with eSATA detection (turned out to be a faulty cord), Now I can't switch back! Sigh. I really would like my eSATA to be plug and play.

Thanks.


My System SpecsSystem Spec
.
01 Jan 2012   #2
gregrocker

 

Did you follow these steps? AHCI : Enable in Windows 7 / Vista

You may need to do a clean reinstall in AHCI mode following these steps to get it perfect: Reinstalling Windows 7

Then capture an image so you don't have to reinstall ever again.
My System SpecsSystem Spec
01 Jan 2012   #3
crovou718

Windows XP Ultimate x64
 
 

yeah those are the steps I followed. As I said in my first post, I got it working fine this time the first time I switched to AHCI mode. Then I switched to IDE while addressing a hard-drive issue. Now in AHCI mode, Win 7 freezes when booting up
My System SpecsSystem Spec
.

01 Jan 2012   #4
gregrocker

 

These SATA modes can be fussy and shouldn't be counted upon to switch back and forth.

What I would do is capture an image in IDE mode labeled IDE, then clean reinstall in AHCI and after setup capture an image labeled AHCI. Then use the images if you need to change modes going forward.
My System SpecsSystem Spec
01 Jan 2012   #5
crovou718

Windows XP Ultimate x64
 
 

Okay. I'll do that if I decide that ACHI is worth having to reinstall all my programs and shit again. Thanks!
My System SpecsSystem Spec
Reply

 Why does Windows 7 freeze when I try to switch to AHCI mode?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
AHCI Mode After Windows 7 Installation MBR 3 MBR1 Error
Hi, I've just installed an SSD drive (Samsung EVO 840) and set it up with Win 7 by cloning the previous drive. I'd like to switch from IDE to ACHI mode and I followed the instructions at the foot of this post prior to switching the "On Chip SATA type" in the BIOS from IDE to ACHI and have had...
Installation & Setup
AHCI-mode on Marvell 9128 controller in Windows 7 Ultimate x64
I am having trouble installing Win 7 Ultimate x64 on my new Intel 510 SSD drive connected to the Marvell 9128 controller (on my Asus board) in AHCI mode. Mind you, Windows installed fine on the 510 when Marvell was in IDE mode. I am usually able to get to the HDD selection-screen, and here I...
Drivers
Questions About Enabling AHCI Mode After Windows Seven Install
I have a Samsung 840 Pro SSD (256 GB) and I installed windows seven on it, but not in AHCI Mode. I was going to change that now using this method: GUIDE - Enabling AHCI mode AFTER Windows 7 Installation - Guru3D.com Forums It says that it works for all Intel SSDs, I assume this would work with...
Hardware & Devices
Can I switch my boot disk from ahci mode to raid mode?
I Installed windows on a ssd drive running in ahci mode. I then switched the sata setting in the bios from ahci to raid in order to add 2 other hdds as a raid 0. Now the pc won't boot anymore getting no boot device error. I know about the registry fix to get an IDE sata drive to boot in ahci mode,...
Hardware & Devices
BSOD when installing Windows 7 in AHCI mode
Hi guys, I'll try to explain my problem in as few words as possible. First thing, my build: Board: Gigabyte GA-P55A-UD4 CPU: Core i7 870 @ 2,93 Ghz Graphic: Sapphire AMD Radeon 8670 Mushkin 2x2Gb Red Culvert Kit @ 1600Mhz CAS 6-7-7-18 Seagate 320 GB SATA II HDD + WD Caviar Black 1TB SATA...
Installation & Setup


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:25.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App