Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: I somehow broke my windows search feature, help needed.


12 Aug 2009   #1

Windows 7
 
 
I somehow broke my windows search feature, help needed.

Ok, so I went into "turn windows features on or off" and I decided to disable windows search. Now that I want to re-enable it, it won't let me. Every time I try to enable it again and hit ok it does it's little thing and then asks me to restart, so of course I restart. However when I start up it starts saying "configuring windows features" or whatever, and then fails and goes into reverting changes. I can't get windows search to come back on for nothing, any help would be appreciated.

My System SpecsSystem Spec
.

12 Aug 2009   #2

Windows 7 Ultimate x64 build 7600
 
 

how long was it turned off? Did you do anything special during that time?

Have you tried in safe mode?

If that doesn't work, you might want to use system restore...

Also, if you have exact error message, could help too,

and that message does it happen before logging in?

in that case, you can probably forget the safe mode advice
My System SpecsSystem Spec
12 Aug 2009   #3

 
 

Quote   Quote: Originally Posted by Khaotik55 View Post
Ok, so I went into "turn windows features on or off" and I decided to disable windows search. Now that I want to re-enable it, it won't let me. Every time I try to enable it again and hit ok it does it's little thing and then asks me to restart, so of course I restart. However when I start up it starts saying "configuring windows features" or whatever, and then fails and goes into reverting changes. I can't get windows search to come back on for nothing, any help would be appreciated.
Try that again, but with Windows disc in your drive.
My System SpecsSystem Spec
.


12 Aug 2009   #4

Windows 7 Ultimate x64 build 7600
 
 

turning features back on is not supposed to require having install disc, and if it needed it, it would just ask for it, I don't think there is a parameter such as "if fail, try to install from drive without telling user about it, else cancel and rollback"
My System SpecsSystem Spec
12 Aug 2009   #5

Windows 7
 
 

I've tried it in safe mode, and there's no real error message, just failed configuring features or whatever before logging in. Also, I didn't burn windows 7 onto a disc, I ran it from desktop and let it install. No disc needed. (I still don't understand how it does that, probably copied needed files somewhere temporarily.) Needless to say, I can't use a disc, and my motherboard only has 1 IDE port, and I use a small storage harddrive on that, and I'm in no mood to go into my PC and change it out for a DVD drive, lmao I need to upgrade my drives to sata.
My System SpecsSystem Spec
12 Aug 2009   #6

 
 

Quote   Quote: Originally Posted by hdfrango View Post
turning features back on is not supposed to require having install disc, and if it needed it, it would just ask for it, I don't think there is a parameter such as "if fail, try to install from drive without telling user about it, else cancel and rollback"
I disabled one feature in vista (i can't remember what feature) and menaged to enable it this way i mentioned.
It is worth to give it a shot...
My System SpecsSystem Spec
12 Aug 2009   #7

Windows 7 Ultimate x64 build 7600
 
 

in that case, have you tried a system restore?

if you want, I can disable/enable that feature here and see how it goes, just in case it would be a bug or something.

I am new to windows 7, only a few days, still learning things, but far from a beginner with computers, just to let you know .
My System SpecsSystem Spec
12 Aug 2009   #8

Windows 7
 
 

I don't think I have any restore points that go back that far, I don't think I even have that enabled, usually I keep my PC tidy and error free so it's not needed. This happened about a month ago anyways, so it's been a while.
My System SpecsSystem Spec
12 Aug 2009   #9

Windows 7 Ultimate x64 build 7600
 
 

ok, just in case I disabled/rebooted, enabled/rebooted, and it worked fine, so it seems to be something on your side (unless we would be unlucky enough that this was a bug in the build you run)

So it's been a full month...

May be along the way you installed things or changed some default settings that make reinstalling that feature a hassle for windows. Could be a number of things.

About safe mode,have you tried in safe mode when you reboot and it tries to reinstall the feature, and not when you're choosing the feature you want back prior to reboot?

Sometimes, failure could be due to corrupted files or something, you might want to try to run chkdsk.

What "major" software (including security ones) do you have installed?

edit:

also, if you tweaked windows 7 in any way, using registry hacks or some program that does it for you, you might want to try to revert whatever was done.

Have you disabled any other features?
My System SpecsSystem Spec
12 Aug 2009   #10

Windows 7
 
 

Avast antivirus, a couple games. Nothing weird besides that. I have disabled search indexing.
My System SpecsSystem Spec
Reply

 I somehow broke my windows search feature, help needed.




Thread Tools



Similar help and support threads for2: I somehow broke my windows search feature, help needed.
Thread Forum
Outlook Search feature failing Microsoft Office
Advanced Search Help needed... Anyway to search multiple pages? General Discussion
search feature General Discussion
Search feature in Windows 7 = No Search! General Discussion
Lost the Windows search feature, even in services in comp management General Discussion
Solved Windows 7 Search Feature Suggestion General Discussion
MAJOR HELP NEEDED ! sound card driver broke RAID cont.. Drivers

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:47 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33