Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: SSVagent.exe error; cannot open programs or print


07 Jan 2012   #1

Windows 7 ; I believe it's 32 bit but not completely sure; when I type winver into search I get erro
 
 
SSVagent.exe error; cannot open programs or print

I've been getting a pop-up box that asks me to select which program I want to run and the only option I get is iexplorer.exe. When I click on that it takes me to the same box again. At the top of the box it says "SSVagent.exe" I googled that and it seems to be some type of malware?? I ran a full scan using my Kaspersky Security software and nothing was found. I also cannot print to my network printer from the 2 laptops that are connected to it or from the main desktop. I tried using system restore but although it goes back to a previous day, the problem still exists. The only way I can run any program is if I right click and choose "Run as administrator." Then if I'm on internet explorer, for example, after I clicked run as administrator, every time I want to change websites or screens, I get that pop-up box asking me to choose a program. Once I close that box out then the webpage loads. Can anyone help me? I'm surprised that Kaspersky didn't pick anything up. Thanks for all your help in advance. Oh, I also do not remember downloading or adding any software just prior to this happening.


My System SpecsSystem Spec
.

07 Jan 2012   #2

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

run command prompt as administrator. then type
notepad
and press enter of course. Does it open?

Same problem in safe mode?
Same problem when you logon under another account?
My System SpecsSystem Spec
07 Jan 2012   #3

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

How did you run system restore? You told you couldn't run any exe file, and system restore is just an exe file
My System SpecsSystem Spec
.


07 Jan 2012   #4

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Hi JEM183, Welcome to the forums, Download the free version of Mbytes anti malware Malwarebytes : Malwarebytes Anti-Malware PRO removes malware including viruses, spyware, worms and trojans, plus it protects your computer let that scan your system ,Have you tried system restore from "safe Mode" also It would be a good idea to run the system file checker SFC /SCANNOW Command - System File Checker , When doing the system restore try going back a little further than 1 day
My System SpecsSystem Spec
07 Jan 2012   #5

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

it coulde be this, but very unlikely
It seems to be a bug in the Sun Java installation file.
This is one possible solution on the Sun Bug forum, from someone named Lee. Open Internet Explorer and...
Tools -> Manage Add-ons -> Enable or Disable Add-ons
Click on SSVHelper Class
Select Disable under Settings.
Hope it works!

doesn't help? reenable it back
My System SpecsSystem Spec
07 Jan 2012   #6

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

put this text in a file and call file reset.reg

Code:
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\exefile\shell\open\command]
@="\"%1\" %*"
[HKEY_CLASSES_ROOT\exefile\shell\open\command]
@="\"%1\" %*"
Afterwards doubleclick on that file and merge with registry. Now doubleclick exe files works?
My System SpecsSystem Spec
08 Jan 2012   #7

Windows 7 ; I believe it's 32 bit but not completely sure; when I type winver into search I get erro
 
 

I downloaded and ran the Malware Removal software that you suggested and it seems to have removed whatever bad files were on the computer. There were actually 5 files and they were all HK...... I'm still not able to print however. When I go to Devices and Printers, my network printer now has a green check next to it, which it didn't before, but on the top under devices, next to my computer name it still has the warning sign. (Yellow triangle with exclamation point in it). I am not able to print from my laptop or my desktop which is also connected to the network printer. Thanks for all your help so far.
My System SpecsSystem Spec
08 Jan 2012   #8

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Quote   Quote: Originally Posted by JEM183 View Post
I downloaded and ran the Malware Removal software that you suggested and it seems to have removed whatever bad files were on the computer. There were actually 5 files and they were all HK...... I'm still not able to print however. When I go to Devices and Printers, my network printer now has a green check next to it, which it didn't before, but on the top under devices, next to my computer name it still has the warning sign. (Yellow triangle with exclamation point in it). I am not able to print from my laptop or my desktop which is also connected to the network printer. Thanks for all your help so far.
Hi JEM183, Thats good that you have removed the virii, The green checkmark means that it is the default printer, now on to the yellow exclaimation mark , Right click on the device and select "update driver" and windows will find the best available driver for you If you have any more probs please post back
My System SpecsSystem Spec
08 Jan 2012   #9

Windows 7 ; I believe it's 32 bit but not completely sure; when I type winver into search I get erro
 
 

Pebbly, I tried doing what you said, but when I right clicked on my laptop under the "Device" heading, it did not give me the option to update drivers. I also went onto the desktop computer to see if I can print from there and I couldn't print from there either. When I ran the troubleshooter, it said it could not ping the print ??? (sorry I forgot what it said after the print, it might have been print driver, print setup). Ugh, computers are so frustrating when they don't work. LOL!
My System SpecsSystem Spec
08 Jan 2012   #10

win 7 ultimate32bit, Win8.1pro wmc 32bit
 
 

Quote   Quote: Originally Posted by JEM183 View Post
Pebbly, I tried doing what you said, but when I right clicked on my laptop under the "Device" heading, it did not give me the option to update drivers. I also went onto the desktop computer to see if I can print from there and I couldn't print from there either. When I ran the troubleshooter, it said it could not ping the print ??? (sorry I forgot what it said after the print, it might have been print driver, print setup). Ugh, computers are so frustrating when they don't work. LOL!
JEM183, When you right clicked on the device heading ,you should have right clicked on the sub device with the exclaimation mark on it, Is that what you did ?
My System SpecsSystem Spec
Reply

 SSVagent.exe error; cannot open programs or print




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:48 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33