Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: BOOTMGR is missing on reboot

07 Jan 2012   #1

Windows 7 Ultimate x64
 
 
BOOTMGR is missing on reboot

Hello Sevenforums!

Here are my specs:
Radeon HD 6950
AMD 695 OC to 3.95Ghz
8GB of ram
1 Terabyte hard drive

I'm having a pretty bad issue today! I decided it was time to loose my old XP installation for extra space. So, I removed my XP installation with a tool which I believe was called partition magic (Installed on the computer that is not booting don't remember the exact name). After removing the installation, I expanded my windows 7 installation to be confronted with "BOOTMGR is missing" on restart. So, after all of this, I decided to attempt a system repair. I put in my installation disc and pressed repair system but oddly, I can't press next to continue with the repair. I'm given "This version of System Recovery Options is not compatible with the version of windows you are trying to repair. Try using a recovery disc that is compatible with this version of windows." I'm not sure what to do from here. I've looked around, googled and I found a similar issue but nothing has helped so far. Thanks for reading hopefully we can get this solved without wiping my Hard drive!

Is it possible that I could insert bootmgr into my windows installation from a usb or something?

Matt


My System SpecsSystem Spec
.

07 Jan 2012   #2
Microsoft MVP

 

You'll need to mark the Windows 7 partition Active first before running Startup Repair - Run 3 Separate Times
to write the system boot files to the Active partition.

Try using free Partition Wizard bootable CD to rightlclick Windows 7 partition, select Modify>Set to Active, OK.

Then click on the Disk number to highlight it, from Disk tab select Rebuild MBR, Apply both steps. This may preclude the need to run the Repairs from Windows 7 DVD or System Repair Disk.

Is this factory preinstalled Windows 7? If not where did you get it and how is it activated?
My System SpecsSystem Spec
07 Jan 2012   #3
whs
Microsoft MVP

Vista, Windows7, Mint Mate, Zorin, Windows 8
 
 

When you deleted XP, the bootmgr went out the door with it. In a dual boot installation the common bootmgr always stays with the older system.

If you follow Greg's advice, you will get it fixed. The reason it did not work before was because you had no active partition (that went out the door with XP too). And make sure you run the repair 3 times.
My System SpecsSystem Spec
.


07 Jan 2012   #4

Windows 7 Ultimate x64
 
 

Thanks for the help!

I created the disc and attempted to make the partition 'active' yet, I was only given a 'inactive' option. I'm guessing because it is already active? However, I did rebuild MBR and that seemed to work.

I re-inserted my installation disc and I still can't press next in the system repair menu without being greeted with the "this version of system recovery options..." message. However, a few minutes ago I received a message telling me there was something wrong after the system recovery options searched for the partitions and I was asked to restart my computer so it could fix them. I restarted and the issue is still here. The message is still the same as before. Any ideas?

Thanks once again,
Matt
My System SpecsSystem Spec
07 Jan 2012   #5
Microsoft MVP

 

Matt -

If you're booted into Partition Wizard CD you should be able to see if Windows 7 partition is in fact marked Active as it will be labeled same. Can you post back a camera snap of the PW drive map with listings, or type them out?

Once PW is marked Active choose Rebuild MBR to see if it will start. If not you'll need to get Windows 7 DVD or Repair CD to boot if System Recovery Options are no longer on the F8 Advanced Boot Options menu.

I would have already linked to you a fresh ISO of your licensed version if you had answered my question about where you got Windows 7 and how it is activated.
My System SpecsSystem Spec
07 Jan 2012   #6

Windows 7 Ultimate x64
 
 

Sorry I was in a bit of a rush I'm using a OEM copy. I bought it from ncix along with my computer parts. I installed it myself.

Code:
Disk 1               Capacity         Used           Unused     File system         Type              Status
*:              7.88 MB           0 B            7.88 MB     unallocated           Logical           None
*:             931.50 GB     274.92 GB       656.59 GB           NTFS               Primary         Active
Computer is still not booting after the MBR Rebuild. Still cannot get past the next button on the System recovery options page.
My System SpecsSystem Spec
07 Jan 2012   #7

Windows 7 Professional x64 Linux Mint 16
 
 

The only time I`ve ever gotten that message was when I accidently dropped in a 32 bit repair disc on a 64 bit system ( and vice versa ). And are you using it to attempt a startup REPAIR or a restore ? Exactly ?
My System SpecsSystem Spec
07 Jan 2012   #8

Windows 7 Ultimate x64
 
 

Repair not restore. I don't know how that could have happened unless I downloaded the wrong iso... My computer doesn't have an optical drive yet so I had to make a boot usb to get into the repair my computer section.
My System SpecsSystem Spec
08 Jan 2012   #9

Windows 7 Professional x64 Linux Mint 16
 
 

But you said you dropped in your installation DISC.
My System SpecsSystem Spec
08 Jan 2012   #10

Windows 7 Ultimate x64
 
 

Mhm I have another computer. I plugged my harddrive into it at first and tried with the actual disk but the computer is quite old and It was just as effective to use a USB key. So, I switched to my other computer and I have the same results.
I guess I should have mentioned this earlier!

Sorry!
My System SpecsSystem Spec
Reply

 BOOTMGR is missing on reboot




Thread Tools



Similar help and support threads for2: BOOTMGR is missing on reboot
Thread Forum
Bootmgr.exe missing... mpio.sys missing or corrupted. Unable to boot General Discussion
Bootmgr is missing General Discussion
Solved BOOTMGR is Missing - Only Sometimes! Installation & Setup
Solved Missing BOOTMGR General Discussion
Solved BootMGR is missing General Discussion
bootmgr missing error, became bootmgr MISSING. General Discussion
Bootmgr missing Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:42 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33