Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: MSInfo32 no showing 32 bit modules when run on a 64 bit version of Win

10 Jan 2012   #1
JustRay

Windows 7 Professional 64 bit
 
 
MSInfo32 no showing 32 bit modules when run on a 64 bit version of Win

Hello folks,
I run a number of 32 bit applications on my Windows 7 box.
(I have two of them. A 32 bit version and a 64 bit version).

When I run MSInfo32 on my 64 bit Windows 7 box, it does not show any of the 32 bit models that are indeed loaded into memory.

But they all show up on my 32 bit version of Windows 7.

Is there a setting or something that I have to enable in order to "see" all of the loaded modules ?

Any help would be greatly appreciated.

Thanks so much for any responses.


My System SpecsSystem Spec
.
10 Jan 2012   #2
pbcopter

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64
 
 

Are the 32 bit applications just missing from the loaded modules?
There are no special settings and the only way to tell the difference is to look at the path.
32 bit applications will show a path to Program Files (x86), while 64 bit applications will show program Files.
My System SpecsSystem Spec
10 Jan 2012   #3
JustRay

Windows 7 Professional 64 bit
 
 

Thanks for the reply.

When running MSInfo32.exe on a 64 bit Windows 7 box .....

There ARE 32 bit "tasks" listed in the expanded "Running Tasks" section.
Along with, 64 bit tasks.
A GOOD thing.

But there aren't any 32 bit modules listed in the expanded "Loaded Modules" section.
ONLY 64 bit modules.

Kind of disappointing, if it turns out to be "just the way it is".

My System SpecsSystem Spec
.

10 Jan 2012   #4
pbcopter

Windows 7 Ultimate x64 SP1, Windows 8.1 Pro x64, Windows 10 Pro x64
 
 

I see both 32 and 64 bit in the expanded Loaded modules.

For example, if you run Internet explorer and Internet explorer (64 bit), they both show in the list with the appropriate paths.
My System SpecsSystem Spec
11 Jan 2012   #5
JustRay

Windows 7 Professional 64 bit
 
 

And thank you for the reply.

I also see the IE, .exe objects in the loaded modules section.

Do you se any 32 bit .ocx or .dll objects ?

I don't see a single one on a 64 bit Windows 7 box.
Yet I see them all on a 32 bit version of windos 7.

Is that consistant with what you are seeing ?
I mean, no 32 bit .ocx or .dll objects ?
My System SpecsSystem Spec
Reply

 MSInfo32 no showing 32 bit modules when run on a 64 bit version of Win




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Why is Adobe flash checker page still showing older version.
Someone here left me this pages link to check if i had the latest flash player and to my surprise this page still shows the older version . Any reasons why? Thanks
Browsers & Mail
Windows Version not showing
Hi A recent error has caused my pc to not show the windows version as you can see on the picture (sorry it's in danish). I was wondering if any of you guys knows how to fix this and get the information back without restoring from a backup? thanks :)
General Discussion
Google Chrome 21 (Last Version) Thumbnail Is Not Showing
http://imageshack.us/a/img842/3918/84199809.png Any Comment For Help Me. ? I Restart & Delete Data Many Time But It Still Not Showing
Browsers & Mail
windows 7 ultimate showing different version
I have downloaded windows 7 ultimate x64 iso file. X17-59465.iso but after installed, it is showing windows professional which is weird. Why? Anyone knows why? or how to solve it? Thanks
Installation & Setup
System Showing Wierd SP1 Version
I have loaded SP1 on 2 of my laptops. One of them is simply statting Service Pack 1 under my Properties. The other is showing a Service Pack 1 v721. What is this all about?
Windows Updates & Activation
WEI still showing RC in the Retail Version!!!
Hello guys.. Im using the final RTM version.today i opened the winsat formal file to see some values and i was surprised to see "RC" in the rtm version.Any idea??
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 20:33.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App