Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Headset + Sound Card giving me "rain" and background noises.


05 Feb 2012   #1

Windows7
 
 
Headset + Sound Card giving me "rain" and background noises.

Hello. Recently i've bought a Roccat Kave headset along with a Creative SB X-fi Titanium Sound card ( PCI-E bulk version ) . It was all fine when suddenly the quality dropped. Today, I can still hear but the quality is nowhere near from what it used to be. I keep getting static sounds . I have not made any changes to the computer. I have installed the drives from the sound card as for the headset it wasn't needed ( I'm on windows 7 ). Sometimes when on youtube, I can stop hearing people talking and I only get static noise untill music or whatever it was playing before comes.

Any tips on how I could fix this? Could this also mean my headset speakers are damaged in any way? ( It's just cuz I'm a bass-lover and ever since I got it to work, I've put it all the way to the max.

EDIT: It is not from my headset as I've tried using the headset connected to the motherboard sound connections and it works just fine.

My System SpecsSystem Spec
.

Reply

 Headset + Sound Card giving me "rain" and background noises.




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:49 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33