Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Base filtering engine won't start

07 Mar 2012   #1
oldspook

Windows 7 Ultimate
 
 
Base filtering engine won't start

A few days ago my computer was infected with the trojan HEUR:Backdoor.Win64.Generic (consrv.dll). Kaspersky caught it and removed it but not before it disabled my windows security service, "base filtering engine". I restored the service in the register but it won't start even though it is set to automatic. I think it won't start because the file bfe.dll was corrupted by the virus. I have another copy of the file obtained from a working computer with the same operating system but I cannot replace it because "I don't have permission".

Does anyone know how to replace this protected file or how to get BFE to start?


My System SpecsSystem Spec
.

07 Mar 2012   #2
Ztruker

Windows 8 Core X64
 
 

Enable the hidden Administrator account.

Open a Elevated Command Prompt
Enter net user administrator /active:yes

Boot to Safe mode and login as Administrator. Replace bfe.dll

Reboot normally.

If you want to disable the Admin account:

Open a Elevated Command Prompt
Enter net user administrator /active:no
My System SpecsSystem Spec
07 Mar 2012   #3
oldspook

Windows 7 Ultimate
 
 

OK, I got the file replaced but it didn't help. I still cannot start the service base filtering engine. Several other security services that are dependent on it also won't start.

Any ideas how to get it started? When I try to start it I get this error message:
"Windows could not start the Base Filtering Engine service on Local Computer.
Error 1083: The executable program that this service is configured to run in does not implement the service.
My System SpecsSystem Spec
.


07 Mar 2012   #4
Ztruker

Windows 8 Core X64
 
 

Open an Elevated Command Prompt and run sfc /scannow. That should replace any missing or damaged files. Takes awhile so be patient.
My System SpecsSystem Spec
07 Mar 2012   #5
oldspook

Windows 7 Ultimate
 
 

Already did that, found nothing.
My System SpecsSystem Spec
Reply

 Base filtering engine won't start




Thread Tools





Similar help and support threads
Thread Forum
Base Filtering Engine could not be started. Error 5: Acess is denied
Every time I start the service from Services, I always get this error: Windows could not start the Base Filtering Engine service on Local computer. Error 5: Access is denied. I tried this code: Reg Query "HKLM\SYSTEM\CurrentControlSet\Services\BFE"> 0 & notepad 0 and this is the outcome: ...
Windows Updates & Activation
BFE(Base filtering Engine) Error 5 Access Denied + Windows Firewall
Hi, I have tried starting BFE and Windows Firewall, but cant get anything to work. I came across this thread:http://www.sevenforums.com/windows-updates-activation/269245-base-filtering-engine-could-not-started-system-error-5-has-occured.html Everything is the same up until the commands :...
General Discussion
Base Filtering Engine could not be started. System Error 5 has occured
When I try and start the BFE through command prompt, it comes up with this error: ***** Microsoft Windows Copyright (c) 2009 Microsoft Corporation. All rights reserved. C:\Windows\system32>NET START BFE The Base Filtering Engine service is starting. The Base Filtering Engine service...
Windows Updates & Activation
How to turn on Base Filtering Engine
Hey I need to turn on the "Base Filtering Engine" on my laptop, as well as "IPsec Policy Agent" and "IKE and AuthIP IPsec Keyring Modules" I opened cmd and ran services.msc to turn them on but BFE is missing completely. The other 2 are both there but when I click start they give a message...
System Security
Windows 7 64-bit - Base filtering engine won't start
I've researched this topic for like 4 hours. I've tried re-adding the appropriate reg files. I've tried fixing permissions in the registry. I've tried all the cmd line commands. I have no idea how to get this service to run. Because of this the firewall doesn't work. And also i can't open any ports...
General Discussion
base filtering engine BFE deleted
HI all, My BFE service Base Filtering Engine has been deleted by a nasty installer or whatever... how can i manually reinstall the BFE service without a full reinstall ? i don't have any system restore point available (never need this sh##ty feature in the past) win7 x64 BFE service does...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:32.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App