Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: "Interactive Services Detection" message pop up every 5 minutes

14 Apr 2012   #1

Windows 7 Ultimate 32 bit
"Interactive Services Detection" message pop up every 5 minutes

Hi everyone

Well i have a small issue here. After a long research over the internet, i see that the only way to fix this, is to format disk or reinstall Windows. Well my computer is for company and i have many programs that will need to be reinstalled after a format or windows reinstallation, and this is a big problem. I recently tried to update "Nokia Multimedia Common Components". It suddenly stopped and said that it couldn't remove the old software, because Nokia Suit needed it. I click on "OK". Since then i have a pop up message, telling me that "A running service is trying to show me a message". Well the message is that it can't be installed. My problem is that i can't install other software because the current installation is running, looks like there is no way to stop this installation, delete this file, finish installation or just in some way put this program to background so i could install other programs or stop the annoying message.

If anyone can help me, i would really appreciate this.

Attached Images
My System SpecsSystem Spec
14 Apr 2012   #2

Windows 10 Pro X64

Have you tried uninstalling it? If that works then you can reinstall it.

If it won't let you, open msconfig and disable anything Nokia related in the Startup and Services tabs. For services, check the Hide all Microsoft services box first.

Reboot then uninstall it.
My System SpecsSystem Spec
15 Apr 2012   #3

Windows 7 Ultimate 32 bit

Hi Ztruker

Thank you for your reply. Well, I actually tried this out, but you see, my PC says that this program is not even installed on System. When I try to uninstall “from uninstall a program” it says: “Another program is being installed. Please wait until the other program finish the installation”. But the program which is being installed is actually the one that I want to remove completely from my PC. When I log on in Safe Mode, the annoying massage is not appearing, but in “Uninstall a Program” says that the “Nokia Multimedia Common Components” is not properly installed so I can’t uninstall it.

By the way, thank you for your help!!!
My System SpecsSystem Spec

15 Apr 2012   #4

Windows 7 Ultimate 32 bit

Hi guys,

I figured out how to fix this problem.

1) Shutdown your PC
2) Start it again and click the F8 button multiple times, until the menu for Safe Mode etc. comes out.
3) Choose the first selection “Repair your Computer”
4) When the System recovery option appears choose “System Image Recovery”
5) If you see button “Load Driver” or “Advance” click on it
6) If you clicked on “Advance” then it will ask you if you want to load from internet or you computer
7) Choose the computer
8) In any way, you now should be able to see a window which shows your computer
9) Click on “Computer” on the left
10) Then go to Local Disk C\Windows\System 32 and search for the file MsiExec.exe
11) Now move this file to your desktop. MAKE SURE that this file is missing from the System 32 Folder
12) ATTENTION: when you click on “Load Driver” or “Advance” in step 5 and 6, the computer will probably navigate you to System 32 of Recovery Partition. There you will not be able to find the file that you need. So follow exactly the step 9 and 10.
13) That’s it. You are ready. Click everywhere “Cancel” and restart your PC.

This worked 100% for me. I don’t have annoying messages about interactive programs and I am able to install other software again.
Name:  windows-7-f8.jpg
Views: 76
Size:  32.0 KB

Name:  repair16.jpg
Views: 65
Size:  24.7 KB

My System SpecsSystem Spec
16 Apr 2012   #5

Windows 10 Pro X64

When you rebooted, was msiexec.exe put back in the system32 folder? From what I've read it's needed to process msi (Microsoft Installer) files.
My System SpecsSystem Spec
18 Apr 2012   #6

Windows 7 Ultimate 32 bit

Actually, it is not there anymore. I did the mistake, and removed it from my system. But if you move it on your desktop and after the reboot, you transfer it back to System 32 Folder, i am not sure if the problem will continue. In any way i can now install new softwares without getting Error 1500. If you can upload the msiexec.exe somewere and send me the link, i would really appreciate it.

My System SpecsSystem Spec
18 Apr 2012   #7

Windows 10 Pro X64

If you open a Command Prompt and change to teh \Windows directory, do a

dir msiexec.exe /s

It will show you other locations the files already exists. On my WIn 7 Pro X64 system, I find it in these places:
Directory of C:\Windows\System32
11/20/2010 06:25 AM 128,000 msiexec.exe

Directory of C:\Windows\SysWOW64
11/20/2010 05:17 AM 73,216 msiexec.exe

Directory of C:\Windows\winsxs\amd64_microsoft-windows-installer-executable_31bf3856ad364e35_6.1.7600.16385_none_a57666739fcae94c
07/13/2009 09:39 PM 127,488 msiexec.exe

Directory of C:\Windows\winsxs\amd64_microsoft-windows-installer-executable_31bf3856ad364e35_6.1.7601.17514_none_a7a77a3b9cb96ce6
11/20/2010 06:25 AM 128,000 msiexec.exe

Directory of C:\Windows\winsxs\x86_microsoft-windows-installer-executable_31bf3856ad364e35_6.1.7600.16385_none_4957caefe76d7816
07/13/2009 09:14 PM 73,216 msiexec.exe

Directory of C:\Windows\winsxs\x86_microsoft-windows-installer-executable_31bf3856ad364e35_6.1.7601.17514_none_4b88deb7e45bfbb0
11/20/2010 05:17 AM 73,216 msiexec.exe
My System SpecsSystem Spec
20 Apr 2012   #8

Windows 7 Ultimate 32 bit

You are right. Looks like there are no problems. I recently updated Deamon Tools Light 4. And i had no problems. That means, you can follow those step above. In any case, If you modify your PC, always keep backups, they are really useful.
My System SpecsSystem Spec
20 Apr 2012   #9

XP / Win7 x64 Pro

You could have done a System Restore to a time previous to this issue as well.
My System SpecsSystem Spec
21 Apr 2012   #10

Windows 7 Ultimate 32 bit

You are also right, but you see, there weren’t any system restore points, so I couldn’t restore it.
My System SpecsSystem Spec

 "Interactive Services Detection" message pop up every 5 minutes

Thread Tools

Similar help and support threads
Thread Forum
Can't install printer : "Active directory domain services is curren.."
Have just reinstalled Windows 7 32 bit over Windows 7 64 bit and my computer doesn't now recognise the same printer that it recognised under the 64 bit OS. Could someone please help me with this?
Hardware & Devices
Interactive Services Detection- program not compatible after update.
Yeah so I updated windows the other day and I come home to find this warning, keeps popping up. I hope I am not about to get the BSOD again. Anyone know what I need to do to fix this issue?
Windows Updates & Activation
Setup is starting services "loop" No Repair or installation Disk
Hi Everybody, I'm really in need of some help or advice with my laptop Specs below: Acer Aspire 5742 Intel i5-480M 6GB DDR3 Intel Graphics It started when I needed to take the computer back to factory default with a fresh install. It was going back to Acer to have the charger point...
Installation & Setup
resuming Windows ... Setup is starting services..."stuck" Aspire5742
I was trying to save some files in restoring windows 7; now i can't boot my computer; 1st screen : windows resuming., then setup is starting services.... , "stuck" ; acer aspire 5742 Windows 7 64bit Home Premium; What can i do? now; F8;F2; F12; Ctr+Alt+Del; nothing runs all night ; have a recovery...
Installation & Setup
interactive services detection for ntvdm.exe
hi this morning I updated my drivers. now I get this message: interactive services detection for ntvdm.exe I searched through Microsoft answers and it recommended that I can stop it from services window,so I did that and now the message doesn't pop up(should I stop it?is gonna make problems...
eMachines E727 laptop Stuck on "Setup is starting services".
Hi, My computer is stuck on "Setup is starting services" during a recovery and has been like that for a day now. I tried to restore days ago and I turned it off during this same screen and it came up with an Install Windows error "The computer restarted unexpectedly or encountered an unexpected...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 08:50.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App