Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Screen Saver to password logon screen failing

23 Apr 2012   #1

Windows 7 64-bit
 
 
Screen Saver to password logon screen failing

I have set up my Win 7 Pro 64-bit screen saver to bring up the password logon screen upon activation of the mouse/keyboard/whatever.

Late last week, whenever I moved the mouse or clicked the keyboard, the screensaver would go directly to the desktop, bypassing the logon screen. I went to the screensaver utility and unchecked and rechecked the 'On resume, display the logon screen' box, selecting 'Apply and OK' each time.

This would work for maybe two or three times and then go back to returning to the desktop.

I've run MalwareBytes, IOBit, and Norton and all come up virus/rootkit free.

Any ideas?

My System SpecsSystem Spec
.

23 Apr 2012   #2

Windows 7 Ultimate x64
 
 

There are a few seconds of "grace" time, meaning when the screensaver launches you have a few seconds to "wake it" and go back to your desktop without locking it.

I guess I can assume you're not talking about that, right?
My System SpecsSystem Spec
23 Apr 2012   #3

Windows 7 64-bit
 
 

No, I can catch it fast enough if I want to return to the desktop.

This happens after some time has passed with the screensaver running. In the past (pre-service pack 1 days) I could re-boot the PC and take care of the problem that way. Now, for the last few weeks, this problem won't go away.

It's funny that it'll work two or three times after I re-do the screen saver configuration, and then stop working. It's almost like there's malware running that is playing with me, letting me start correctly and then removing the password protection. But I don't show any malware/rootkit infection.

Anyway, it's a mystery to me. Also, I don't know where to look deep in the Administration Security configuration to see if a DWORD is on or off. Maybe someone could point me in that direction.

Thanks for all you help so far!
My System SpecsSystem Spec
.


24 Apr 2012   #4

Winbdows 7 ultimate x64 | Ubuntu 12.04 x64 LTS
 
 

My System SpecsSystem Spec
24 Apr 2012   #5

Windows 7 64-bit
 
 

The first time I tried running SFC /SCANNOW I found that the Windows Module Installer was disabled. SFC ran after I made the module 'Automatic'. I will try the screen saver password after SFC runs.

Something like this happened last year when Windows Update could not install new updates. I checked through the Services and found that the Installer was disabled.

What could disable the Module Installer anyhow?
My System SpecsSystem Spec
24 Apr 2012   #6

Winbdows 7 ultimate x64 | Ubuntu 12.04 x64 LTS
 
 

Quote   Quote: Originally Posted by rzn6jw View Post
The first time I tried running SFC /SCANNOW I found that the Windows Module Installer was disabled. SFC ran after I made the module 'Automatic'. I will try the screen saver password after SFC runs.

Something like this happened last year when Windows Update could not install new updates. I checked through the Services and found that the Installer was disabled.

What could disable the Module Installer anyhow?
Anything. May be some malware, or cold be some setting related to windows updates as it is responsible for managing the installation/removal of updates.

Does it happen with every screensavers? Are you using default screensavers or custom installed?
My System SpecsSystem Spec
24 Apr 2012   #7

Windows 7 64-bit
 
 

No custom screensavers. Have used Mystify forever. Like I said, this happened once with Update, but Update has run every time since - no errors.

Screensaver to password screen seems to be working fine now. Will keep an eye on WMI if something like this happens again.

Thanks for all your help!!
My System SpecsSystem Spec
24 Apr 2012   #8

Winbdows 7 ultimate x64 | Ubuntu 12.04 x64 LTS
 
 

For the Windows Module Installer service, double click it and navigate to Recovery tab and make sure the first two drop-down lists say "Restart the service".
Since you seem to like using mystify screensaver, this may interest you- Mystify Screen Saver - Change Settings
My System SpecsSystem Spec
Reply

 Screen Saver to password logon screen failing




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:12 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33