Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Mouse issue

06 May 2012   #1

windows 7 home premium 64
 
 
Mouse issue

I am currently having issues with my mouse or explorer. I can use keyboard shortcuts just fine. When I click on a window it seem to put it in the background, I am unable to click on the task bar. The windows act like the are in the background unable use with the mouse. I can alt+tab and use with the keyboard just fine. The mouse works in games and most of the time in firefox, (it cannot select item in drop boxes). I can not move the icons around on the desktop most of the time. The mouse will also not work on the login tiles right at start up.

I can ctrl+alt+del and hit escape and it will work for a while then the windows will freeze again. All programs work fine but the mouse will not work correctly in the desktop environment. I have checked my memory, ran check disk, removed all nonessential programs from start up through msconfig. I've uninstalled USB host controlers and reinstalled them and uninstalled the mouse drivers. I have used multiple usb ports for the mouse. I have also used sfc /scannow with no success.

I'm completely out of ideas... Any help would be greatly appreciated.

My System SpecsSystem Spec
.

06 May 2012   #2

Windows 7 Home Premium 64bit (O.E.M)
 
 

It would help us if we knew the manufacturer of the mouse. So, if you could tell me who the mouse is made by, I would be grateful and then I can help you better.

Stephen
My System SpecsSystem Spec
06 May 2012   #3

windows 7 home premium 64
 
 

Logitech M-U0007
My System SpecsSystem Spec
.


06 May 2012   #4

Windows 7 Home Premium 64bit (O.E.M)
 
 

Would you mind sending me a PM or VM tomorrow to remind me to reply? I'm not in the mood to help people at the mo as I'm not feeling well.

Thanks
Stephen
My System SpecsSystem Spec
06 May 2012   #5

windows 7 home premium 64
 
 

will do
My System SpecsSystem Spec
07 May 2012   #6

Windows 7 Home Premium 64bit (O.E.M)
 
 

Now I'm feeling slightly better and am in a good mood, let's run through some basic troubleshooting steps.

First, have you tried changing the mouses battery. I don't mean to sound like a smarty-pants but it could be as simple as that.

Secondly, try updating the Logitech setpoint software to the latest version or install it if have never installed it in the first place.

Finally, do you have a system restore point to go back to before this started?

Hope this helps
Stephen
My System SpecsSystem Spec
07 May 2012   #7

windows 7 home premium 64
 
 
yes yes and yes

When I uninstalled the driver I installed an updated version of setpoint. It's a corded mouse (so no batteries ) . Windows failed to restore from a previous point. It's just odd when I hit ctrl+alt+del and esc back into the windows environment I get most functionality back for a minute or so. The mouse also works flawlessly in games. I think it has to do with Windows. The mouse also works on my laptop just fine..
My System SpecsSystem Spec
07 May 2012   #8

Windows 7 Home Premium 64bit (O.E.M)
 
 

Hmmmmm. Very odd. Do you have another mouse you can try in that computer? If that works, it's the mouses fault. If it doesn't work, something's up with windows. Reading your original post I can see you have tried all the other things that I can really think of.

However, if another mouse doesn't work, I have an idea. It's fairly drastic but as the issue you are having is quite bad you might be interested. This is the idea. If you are not comfortable with doing a Repair Install I'll speak to some other members of the forum and see if they have any answers.

Sorry I can't be of more help. I'll post back if I have any more ideas.
Stephen
My System SpecsSystem Spec
07 May 2012   #9

windows 7 home premium 64
 
 

for some odd reason it seems to be working. I didn't do anything else.... Just an odd anomaly I guess. I would still like to know what it caused, somethings are left to be unknown I suppose .
My System SpecsSystem Spec
07 May 2012   #10

Windows 7 Home Premium 64bit (O.E.M)
 
 

Well that's good. Post back if it starts again. Glad it stopped though.

Stephen
My System SpecsSystem Spec
Reply

 Mouse issue





Thread Tools



Similar help and support threads for2: Mouse issue
Thread Forum
Far Cry mouse issue Gaming
Mouse scrolling issue. Hardware & Devices
Mouse lag issue. Hardware & Devices
Mouse Lag Issue General Discussion
Mouse issue Hardware & Devices
Oh No!! Mouse issue! Hardware & Devices
Mouse issue Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:20 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33