Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: WIN7 x64 - Uses all available RAM, runs slowly

01 Jun 2012   #1
Viking5275

WIN 7 Ultimate X64
 
 
WIN7 x64 - Uses all available RAM, runs slowly

Hi all, pardon the newbie question. If this has been answered already please point me that way? I did do a search but found nothing to help.

My system is a home built, Core I7, 8GB RAM, Radeon 560 TI with 2GB VRAM. Recently upgraded from 4GB RAM.

I was having this same issue with 4GB of RAM. After the computer has been on a bit (hour or two) the memory usage will approach 90% and upwards and things will start to run slowly. I close all active programs, kill all non-essential background programs (dropbox, steam, printer software etc). I look in my processes and no way does it all add up to nearly 8GB of memory.

So my question is, how do I get my computer to run faster? I know WIN 7 uses memory differently than XP did, and I don't care if it wants to use all the RAM, as long as it will run quickly. The problem is, it runs slowly.

I have WIN 7 x64 ultimate, I have ESET security suite and show no viruses. Problem goes away after I reboot, but returns over time.

If I can provide more info please let me know.


My System SpecsSystem Spec
.
01 Jun 2012   #2
logicearth

Windows 10 Pro (x64)
 
 

One of your applications has a memory leak. I vote security software...but it could be anything.
My System SpecsSystem Spec
02 Jun 2012   #3
Viking5275

WIN 7 Ultimate X64
 
 

How can I determine which one it is (other than trial and error)? Nothing really shows up as "large" in task manager. Firefox is by far the largest, but when I close it out it doesn't really fix the issue and it is rarely over 300mb in size.
My System SpecsSystem Spec
.

02 Jun 2012   #4
logicearth

Windows 10 Pro (x64)
 
 

Memory leaks do no show up in task manager or any such tool. Going based upon who as the highest memory usage won't tell you anything. It must be trial and error.
My System SpecsSystem Spec
02 Jun 2012   #5
Viking5275

WIN 7 Ultimate X64
 
 

Is there any way to reclaim the memory other than rebooting?
My System SpecsSystem Spec
02 Jun 2012   #6
Zepher

Windows 7 Ultimate 64bit
 
 

On the task manager screen that show the processes , there hold be a button on the bottom left that says "show processes from all users" and it should show you a lot more processes.
My System SpecsSystem Spec
03 Jun 2012   #7
OCD

Windows 7 Professional 32bit
 
 

Check your Memory IO Operations. They are available in Task Manager view options. Also check your CPU usage. It sounds like a buggy application. If your application uses .NET framework, update to the latest .NET service pack.
My System SpecsSystem Spec
Reply

 WIN7 x64 - Uses all available RAM, runs slowly




Thread Tools




Similar help and support threads
Thread Forum
age of Empire 2 EN LJ 65 laptop runs slowly
Hi, age of empire 2 runs very slowly on my EN LJ 65 laptop. It starts in the menu and it takes a long time to switch hotkeys. When im playing it runs rather smoothly in the beginning but when more units is on the map the game responds very slowly. None of my friends have the same issue so it...
Gaming
Windows 7 x64 installs and runs slowly
I am trying to upgrade my wife's computer to Windows 7 x64 from Windows Vista x32. It has run great for the past 3 years using Vista 32bit. The system shows it should run x64 bit no problems. I've already run the Windows 7 Upgrade adviser that also says I should have no problems. However...
Installation & Setup
replaced rj45 lan input with a new lan card but runs very slowly
My motherboard is an Asus M3A78-EM and I have been using the system with the built in lan rated at 10/100/1000 mbps. The socket seems to be going bad so I tried replacing it with another internal card. They only had two to choose from at Office Depot were rated at 10/100/ mbps. and the other which...
Network & Sharing
Win7 boot too slowly
I am running Windows 7 and it takes me a lot of time to boot. I think this was caused by Cacheman. I installed it to speedup my old laptop, after it disable Aero, I uninstalled. After that, when booting, my laptop is taken about 5 minutes at Starting Windows sceen. When pass that sceen, my system...
Performance & Maintenance
Virus? Computer runs extremely slowly!
Hi, I hope this is the right place to post. If not, I apologise, let me know and I'll move it to where it should be. Thanks! Basically, I'm having major problems with my computer of late, and the troubles all started a few weeks ago when I got a virus. I don't know much about getting rid of...
System Security
Why runs slowly when i have 2GB RAM and P4 2.8 Ghz ?
Hello everybody I have problem with Windows 7 on PC computer. IT runs slowly even i turn on clasic view and turned off all effects... My PC is: Pentium 4 2.8 Ghz RAM 2GB Motheroard - AsRock Video - Nvidia GeForce 7600 - 512Mb WIndows installed on Sata HDD 40GB, in system there is more two HDD...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:16.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App