Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Installer - can't install ANY msi package


18 Jan 2009   #11

Windows 7 64bit beta
 
 

Hi - no I don't have cccleaner installed - not sure what's caused it. Just got my setup right so really don't want to do a clean install!
Anyone sorted it without an install yet?

My System SpecsSystem Spec
.

18 Jan 2009   #12

Windows 7 x64 Home Premium
 
 

Keith, what do you mean Ccleaner did it for you? Did you ran its reg cleaner or removed ccleaner that solved the prob? I have Ccleaner as well thats why I am asking.
My System SpecsSystem Spec
18 Jan 2009   #13

Windows 7 Beta
 
 

im also experiencing this problem right now

whenever i try to install an MSI package it always says that it has stopped working

MS Flight Simulator X Update SP1 - Stopped Working
Windows Update - Stopped Working
And just popped right now - User Profile - Stopped Working

Did'nt Installed CCleaner or other software you were talking before.

Seriously, this is really getting into my nerve, hope someone could finally find a solution

[shhh....Users calling to Microsoft ... Users calling to Microsoft... shhh ...over..]
My System SpecsSystem Spec
.


18 Jan 2009   #14

W 7
 
 

I have the same problem and i tried a lot of workarounds...
Try this:
Click Start/Run and type:

net start MSIServer

It works for me yesterday, but the problem reappears today.
I don't want to reinstall windows 7, but seems to be the only solution for this (at least for now)
My System SpecsSystem Spec
18 Jan 2009   #15

Windows 7
 
 

I'm having the problem trying to install several programs now:
- Google Earth
- Lego Digital Designer
- Textpad
- SaveAsPDFandXPS
- LiveUpload to Facebook
- Picasa Web Publisher for Windows Live Photo Gallery

It seems to have just started in the past couple of days. Truly annoying.
My System SpecsSystem Spec
18 Jan 2009   #16

windows 7
 
 

Hey guys, I had the same problem also and had to reinstall windows 7 to solve. What happened is I was trying to install fallout 3, the installer started to try to install windows live and i think some other .net stuff and it crashed. After that I couldnt get the installer to work at all, I downloaded the games for windows-live 2.0 because I couldnt even start fallout 3 without it and the installer would stop working. Id try windows update and explorer crashed with the same error.

So I reinstalled a fresh copy of windows7 and the first thing i did was install windowslive2.0 and it installed fine after that I installed fallout3 and everything went smooth. I have a feeling something in the fallout 3 installer corupted some files or something. I know it tries to install .net maybe that was the problem.
My System SpecsSystem Spec
18 Jan 2009   #17

Windows 7
 
 

Just tried the fix mentioned above...
"net start MSIServer"

C:\>net start MSIServer
System error 5 has occurred.
Access is denied.
My System SpecsSystem Spec
18 Jan 2009   #18

W 7
 
 

Other workarounds
Windows Installer Service could not be access

I still haven't found a real fix for this anyway.
My System SpecsSystem Spec
18 Jan 2009   #19

Windows 7
 
 

Exploring what others said in this thread, I may have isolated my own cause of this problem.

A program that installed the .NET Framework 3.5 SP1 when it wasn't necessary. Restore Pointing before that instant seems to have 'solved' the problem, and since we lack any other way to repair a framework corruption in Windows 7, I guess that's all we have .

It's an idea at least .
My System SpecsSystem Spec
18 Jan 2009   #20

Windows 7 Beta
 
 

Hey all! Came to the forums from a google search, because I've been experiencing the same problem in this thread.

Seems installing Picassa hosed something with the Windows 7 Installer, so I did a System Restore back to the point before I installed Picassa, and I can install MSIs fine now. I'm assuming certain installers for apps mess with the .NET or Windows Installer somehow.
My System SpecsSystem Spec
Reply

 Windows Installer - can't install ANY msi package




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:32 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33