Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Problem with scheduled programs at startup that need admin rights

17 Jun 2012   #1

Windows 7 Enterprise 32bit
 
 
Problem with scheduled programs at startup that need admin rights

Hello all!

When I start Windows, programs that need administrator rights don't start as they did before. Before I describe the problem I'm having I would like to state that I searched and found similar problems all over the web, but not any solutions that worked for me. Now let's get on with the problem.

The situation is as follows: programs that need admin rights and which I set to run at log on (like PeerBlock and TopWinPrio) don't start automatically anymore. I don't get a UAC message, I get nothing, they just don't launch.

A few days ago everything worked fine. Since then I've run CCleaner and Gamebooster 3.5b. I did clean the registry with CCleaner but used the backup of the registry CCleaner made after I noticed this behavior (so I think the registry clean with CCleaner could not be the issue). I've also used the 'normal clean' function of CCleaner, maybe this caused the problems?

I think the problems have something to do with messed up admin rights on my account. The programs startup fine when I disable UAC, but I'd rather not do that. Also, when I log onto the administrator account, the programs startup fine.

I can start the programs manually after I'm logged in, but I'd rather have them startup automatically.

I've tried the following to solve it:
- sfc / scannow command - did not solve it
- check if my account has admin rights - as far as I can see this is the case
- look for restore points - this is stupid, I know, but it seems I have deleted them with either Tuneup or CCleaner

So, if anyone knows anything that may be of help, please post.

Thanks in advance!

My System SpecsSystem Spec
.

17 Jun 2012   #2
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Hello Nick, and welcome to Seven Forums.

By default, you cannot run a elevated (Run as administrator) program that requires UAC permission at startup using the normal Windows 7 startup programs.

As a workaround to be able to do this, you can use the tutorial below to create an elevated task shortcut.
Elevated Program Shortcut without UAC Prompt - Create
Afterwards, use the shortcut created above with the tutorial below at step 23 in the tutorial above. When finished, the task created in the tutorial below will run the elevated task shortcut created in the tutorial above at startup.
Task - Create to Run a Program at Startup and Log On
Hope this helps,
Shawn
My System SpecsSystem Spec
17 Jun 2012   #3

Windows 7 Enterprise 32bit
 
 

Thanks Brink, I think I saw this before but I will take a look. The thing is however, a few days ago these programs ran just fine. I did not take any special steps to get them at work, I just checked the 'start with windows' in the software itself and it worked without any prompts or other problems.

Edit: I tried your solution for TopWinPrio and it does not work for me. When I open task scheduler, I get alot of errors, I will post them later if needed, because I haven't got much time now. The shortcut I created at the first tutorial you posted did not work: the command prompt window showed up shortly but TopWinPrio was not started. When I log onto the administrator account, TopWinPrio also does not start anymore.
I may have to fix my task scheduler, but if it's possible I prefer the situation from before this problem. So anymore suggestions are welcome.
My System SpecsSystem Spec
.


18 Jun 2012   #4

Windows 7 Enterprise 32bit
 
 
Task Scheduler errors

I don't know if the task scheduler is causing the problems or not, but I might as well fix the task scheduler. Here is my report on it:

A unelevated start of taskschd.msc leads to the task scheduler doing nothing. When I look at it in Windows Task Manager the status is 'Running'. If I end the task in Windows Task Manager, I get the message that the task scheduler has crashed. Immediately after that I get a message that Microsoft Management Console has stopped working. I can't start taskschd.msc after this message anymore, not even when I run it as admin.

If I start taskschd.msc as administrator initially, I get some errors. These are the errors I get (in the order they appear):

- "The selected task "{0}" no longer exists. To see the current tasks, click Refresh."

- "Task Scheduler service is not available. Task Scheduler will attempt to reconnect to it."

- {0} error again

- Task Scheduler service error again

- "Task AD RMS Rights Policy Template Management (Manual): The task image is corrupt or has been tampered with."

- {0} error again

If I then click on "Task Scheduler Library" I get the following errors:

- {0} error

- Task Scheduler service error

- {0} error again

- Task Scheduler service error again

After that I can see the scheduled tasks and edit them.


Does anyone know how I can fix these errors with the Task Scheduler?
My System SpecsSystem Spec
18 Jun 2012   #5
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Nickys,

Double check to make sure that the Task Scheduler service is set to be Started, and Automatic. Next, run a sfc /scannow command to see if it may be able find and fix any corrupted system files that may be responsible.

If you still get these error afterwards, then see if using the tutorial below to help troubleshoot may be able to reveal a cause.

Troubleshoot Application Conflicts by Performing a Clean Startup
My System SpecsSystem Spec
22 Jul 2012   #6

Windows 7 Enterprise 32bit
 
 

Sorry for not replying for so long, I was busy with exams and on vacation. I now have plenty of time to solve the problem however.

I tried Brink's latest suggestion: I already had the Task Scheduler service set to be Started and Automatic, so that was not the problem.
The sfc /scannow command said Windows Resource Protection didn't find any integrity violations, so this is also not the problem.

The Task Scheduler still launched with errors after checking those two things, so I tried Brink's tutorial (thanks for those tutorials btw Brink, they're really user friendly).

The Clean Startup in step one did not solve it, Task Scheduler still gives errors when started. Therefore, I followed step three of the tutorial to restore the settings.

I have taken a look at the Related Tutorials, like Brink's tutorial suggested, but I couldn't find anything that would help me.
Any more ideas how to solve these problems?
My System SpecsSystem Spec
22 Jul 2012   #7
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Do you have these same issues in your other administrator account?

If not, then you might create you a replacement administrator account for your current one that you are having these issues in to see if it works ok in the new one. If so, then you could copy what (ex: shortcuts, documents, etc...) you want from the old account to the new one, and delete the old one if you like.
My System SpecsSystem Spec
18 Aug 2012   #8

Windows 7 Enterprise 32bit
 
 

Again, sorry for long time no posting, but I'm really busy these months.

I logged in on the administrator account and still have some troubles. The applications that need admin rights to start launch at startup, so that's great. I get the same errors in the task scheduler as I described before however.

The easy solution seems to do what Brink said: create a new administrator account and copy everything over. My programs will probably launch fine then.
I would like to know however if there is an easy way to make my task scheduler work normally again.
My System SpecsSystem Spec
18 Aug 2012   #9
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Nickys,

Did it work properly using the new administrator account instead?
My System SpecsSystem Spec
18 Aug 2012   #10

Windows 7 Enterprise 32bit
 
 

I don't know, because I have some trouble creating a new administrator account. I've followed this tutorial to create a new user account.

When I want to log in on the new account I get the following error:
'There are currently no logon servers available to service the logon request.'

I think this is caused by the fact that in the logon screen, it says 'Log on to: name of my university' (note: I bought my computer via the university).
When I type 'my current user name'\'user name of new account' I can log in. I think this is because I now logon locally, and not on a domain. If I do that, the account behaves the same way as my current account: the programs do not launch at startup and task scheduler gives errors.

So I'm not sure what to do now. Somehow I need to make another local account on my computer that's not dependent on my current account, but I don't know if that's possible.
My System SpecsSystem Spec
Reply

 Problem with scheduled programs at startup that need admin rights





Thread Tools



Similar help and support threads for2: Problem with scheduled programs at startup that need admin rights
Thread Forum
Allow certains programs without Admin rights? Software
auto run admin rights Core Temp program at startup Vista/Windows 7 Software
admin user lost some admin rights BSOD Help and Support
e/u has local admin rights but he still gets need admin rights message Network & Sharing
Admin rights? General Discussion
admin rights.. Performance & Maintenance
Admin Rights General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:59 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33