Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 64-bit - Base filtering engine won't start

01 Jul 2012   #1

64
 
 
Windows 7 64-bit - Base filtering engine won't start

I've researched this topic for like 4 hours. I've tried re-adding the appropriate reg files. I've tried fixing permissions in the registry. I've tried all the cmd line commands. I have no idea how to get this service to run. Because of this the firewall doesn't work. And also i can't open any ports on my router I'm thinking.

I've used ccleaner to fix the errors in my registry, as well as sfc /scannow. I was getting some error when trying to use the Windows 7 installation disc to repair windows so I couldn't do that.

I'm also not infected with zero acess rootkit becaue these aren't found on my computer.

Quote:
if you find a folder called system64
C:/WINDOWS/SYSTEM64(not the sysWOW64)

and a file called consrv.dll
C:/WINDOWS/SYSTEM32/CONSRV.DLL
You're infected by zero access rootkit.It is recommended to contact malware removal forums to remove it first and try the fix




I've tried this too but to no avail -->

Quote:
Download both the registry files

bfe.reg

firewall.reg

Launch and import them to registry

Restart your PC

Now,open RUN and type

regedit and click ok

go to

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\BFE

Right click on it-permissions

Click on ADD and type

Everyone and click ok

Now Click on Everyone

Below you have permission for users

Select full control and click ok

Now,open RUN and type

services.msc and click ok

start base filtering engine service and then windows firewall service

For further assistance contact me here, I will be checking this thread every few hours, this worked for me and it should work for you too.


My System SpecsSystem Spec
.

01 Jul 2012   #2

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by exzacklyright View Post
I've researched this topic for like 4 hours. I've tried re-adding the appropriate reg files. I've tried fixing permissions in the registry. I've tried all the cmd line commands. I have no idea how to get this service to run. Because of this the firewall doesn't work. And also i can't open any ports on my router I'm thinking.

I've used ccleaner to fix the errors in my registry, as well as sfc /scannow. I was getting some error when trying to use the Windows 7 installation disc to repair windows so I couldn't do that.

I'm also not infected with zero acess rootkit becaue these aren't found on my computer.

Quote:
if you find a folder called system64
C:/WINDOWS/SYSTEM64(not the sysWOW64)

and a file called consrv.dll
C:/WINDOWS/SYSTEM32/CONSRV.DLL
You're infected by zero access rootkit.It is recommended to contact malware removal forums to remove it first and try the fix




I've tried this too but to no avail -->

Quote:
Download both the registry files

bfe.reg

firewall.reg

Launch and import them to registry

Restart your PC

Now,open RUN and type

regedit and click ok

go to

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\BFE

Right click on it-permissions

Click on ADD and type

Everyone and click ok

Now Click on Everyone

Below you have permission for users

Select full control and click ok

Now,open RUN and type

services.msc and click ok

start base filtering engine service and then windows firewall service

For further assistance contact me here, I will be checking this thread every few hours, this worked for me and it should work for you too.
Visit the following site and read the section "Resolution".

http://support.microsoft.com/kb/2530126

For malware removal I suggest "MBAM" which can be downloaded from;

http://download.cnet.com/Malwarebytes-Anti-Malware/3000-8022_4-10804572.html?part=dl-10804572&subj=dl&tag=button

HTH
My System SpecsSystem Spec
01 Jul 2012   #3

64
 
 

So using these:

Quote:
sc config MpsSvc start= auto
sc config KeyIso start= auto
sc config BFE start= auto
sc config FwcAgent start= auto
net stop MpsSvc
net start MpsSvc
net stop KeyIso
net start KeyIso
net start Wlansvc
net start dot3svc
net start EapHostnet
net stop BFE
net start BFE
net start PolicyAgent
net start MpsSvc
net start IKEEXT
net start DcaSvcnet
net stop FwcAgent
net start FwcAgent
in a repair.bat file might of done the trick because now bfe is started!! I'm getting this though when trying to start the diagnostic policy service.





When I click use recommended settings on the firewall though it crashes.


I've tried this too and it didn't work -->



ALso tried re-installing the network devices/ Ethernet controller as shown in this thread but no luck.

http://social.technet.microsoft.com/...d-371af19b3af5
My System SpecsSystem Spec
.


04 Jul 2012   #4

64
 
 

Any idea if these services would cause it so I can't see my computer from my phone? And also why I'm unable to open this port?

I want to be able to start the diagnostic policy service and window firewall service.
My System SpecsSystem Spec
Reply

 Windows 7 64-bit - Base filtering engine won't start




Thread Tools



Similar help and support threads for2: Windows 7 64-bit - Base filtering engine won't start
Thread Forum
Base Filtering Engine could not be started. System Error 5 has occured Windows Updates & Activation
Solved How to turn on Base Filtering Engine System Security
could not start Windows Base Filtering Engine service (BFE) . General Discussion
Base Filtering Engine stops internet access Network & Sharing
Base filtering engine won't start General Discussion
base filtering engine BFE deleted Performance & Maintenance
Solved Base Filtering Engine - Odd problem Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:34 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33