Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 64-bit - Base filtering engine won't start

01 Jul 2012   #1
exzacklyright

64
 
 
Windows 7 64-bit - Base filtering engine won't start

I've researched this topic for like 4 hours. I've tried re-adding the appropriate reg files. I've tried fixing permissions in the registry. I've tried all the cmd line commands. I have no idea how to get this service to run. Because of this the firewall doesn't work. And also i can't open any ports on my router I'm thinking.

I've used ccleaner to fix the errors in my registry, as well as sfc /scannow. I was getting some error when trying to use the win7 installation disc to repair windows so I couldn't do that.

I'm also not infected with zero acess rootkit becaue these aren't found on my computer.

Quote:
if you find a folder called system64
C:/WINDOWS/SYSTEM64(not the sysWOW64)

and a file called consrv.dll
C:/WINDOWS/SYSTEM32/CONSRV.DLL
You're infected by zero access rootkit.It is recommended to contact malware removal forums to remove it first and try the fix




I've tried this too but to no avail -->

Quote:
Download both the registry files

bfe.reg

firewall.reg

Launch and import them to registry

Restart your PC

Now,open RUN and type

regedit and click ok

go to

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\BFE

Right click on it-permissions

Click on ADD and type

Everyone and click ok

Now Click on Everyone

Below you have permission for users

Select full control and click ok

Now,open RUN and type

services.msc and click ok

start base filtering engine service and then windows firewall service

For further assistance contact me here, I will be checking this thread every few hours, this worked for me and it should work for you too.



My System SpecsSystem Spec
.
01 Jul 2012   #2
Sir George

Windows 7 Professional x64
 
 

Quote   Quote: Originally Posted by exzacklyright View Post
I've researched this topic for like 4 hours. I've tried re-adding the appropriate reg files. I've tried fixing permissions in the registry. I've tried all the cmd line commands. I have no idea how to get this service to run. Because of this the firewall doesn't work. And also i can't open any ports on my router I'm thinking.

I've used ccleaner to fix the errors in my registry, as well as sfc /scannow. I was getting some error when trying to use the win7 installation disc to repair windows so I couldn't do that.

I'm also not infected with zero acess rootkit becaue these aren't found on my computer.

Quote:
if you find a folder called system64
C:/WINDOWS/SYSTEM64(not the sysWOW64)

and a file called consrv.dll
C:/WINDOWS/SYSTEM32/CONSRV.DLL
You're infected by zero access rootkit.It is recommended to contact malware removal forums to remove it first and try the fix




I've tried this too but to no avail -->

Quote:
Download both the registry files

bfe.reg

firewall.reg

Launch and import them to registry

Restart your PC

Now,open RUN and type

regedit and click ok

go to

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\BFE

Right click on it-permissions

Click on ADD and type

Everyone and click ok

Now Click on Everyone

Below you have permission for users

Select full control and click ok

Now,open RUN and type

services.msc and click ok

start base filtering engine service and then windows firewall service

For further assistance contact me here, I will be checking this thread every few hours, this worked for me and it should work for you too.
Visit the following site and read the section "Resolution".

http://support.microsoft.com/kb/2530126

For malware removal I suggest "MBAM" which can be downloaded from;

http://download.cnet.com/Malwarebytes-Anti-Malware/3000-8022_4-10804572.html?part=dl-10804572&subj=dl&tag=button

HTH
My System SpecsSystem Spec
01 Jul 2012   #3
exzacklyright

64
 
 

So using these:

Quote:
sc config MpsSvc start= auto
sc config KeyIso start= auto
sc config BFE start= auto
sc config FwcAgent start= auto
net stop MpsSvc
net start MpsSvc
net stop KeyIso
net start KeyIso
net start Wlansvc
net start dot3svc
net start EapHostnet
net stop BFE
net start BFE
net start PolicyAgent
net start MpsSvc
net start IKEEXT
net start DcaSvcnet
net stop FwcAgent
net start FwcAgent
in a repair.bat file might of done the trick because now bfe is started!! I'm getting this though when trying to start the diagnostic policy service.





When I click use recommended settings on the firewall though it crashes.


I've tried this too and it didn't work -->



ALso tried re-installing the network devices/ Ethernet controller as shown in this thread but no luck.

http://social.technet.microsoft.com/...d-371af19b3af5
My System SpecsSystem Spec
.

04 Jul 2012   #4
exzacklyright

64
 
 

Any idea if these services would cause it so I can't see my computer from my phone? And also why I'm unable to open this port?

I want to be able to start the diagnostic policy service and window firewall service.
My System SpecsSystem Spec
Reply

 Windows 7 64-bit - Base filtering engine won't start




Thread Tools




Similar help and support threads
Thread Forum
Base Filtering Engine could not be started. System Error 5 has occured
When I try and start the BFE through command prompt, it comes up with this error: ***** Microsoft Windows Copyright (c) 2009 Microsoft Corporation. All rights reserved. C:\Windows\system32>NET START BFE The Base Filtering Engine service is starting. The Base Filtering Engine service...
Windows Updates & Activation
How to turn on Base Filtering Engine
Hey I need to turn on the "Base Filtering Engine" on my laptop, as well as "IPsec Policy Agent" and "IKE and AuthIP IPsec Keyring Modules" I opened cmd and ran services.msc to turn them on but BFE is missing completely. The other 2 are both there but when I click start they give a message...
System Security
Base Filtering Engine could not be started. Error 5: Acess is denied
Every time I start the service from Services, I always get this error: Windows could not start the Base Filtering Engine service on Local computer. Error 5: Access is denied. I tried this code: Reg Query "HKLM\SYSTEM\CurrentControlSet\Services\BFE"> 0 & notepad 0 and this is the outcome: ...
Windows Updates & Activation
BFE(Base filtering Engine) Error 5 Access Denied + Windows Firewall
Hi, I have tried starting BFE and Windows Firewall, but cant get anything to work. I came across this thread:http://www.sevenforums.com/windows-updates-activation/269245-base-filtering-engine-could-not-started-system-error-5-has-occured.html Everything is the same up until the commands :...
General Discussion
Base filtering engine won't start
A few days ago my computer was infected with the trojan HEUR:Backdoor.Win64.Generic (consrv.dll). Kaspersky caught it and removed it but not before it disabled my windows security service, "base filtering engine". I restored the service in the register but it won't start even though it is set to...
General Discussion
base filtering engine BFE deleted
HI all, My BFE service Base Filtering Engine has been deleted by a nasty installer or whatever... how can i manually reinstall the BFE service without a full reinstall ? i don't have any system restore point available (never need this sh##ty feature in the past) win7 x64 BFE service does...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:04.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App