Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Killing in Regedit : Legacy key; MBAMPROTECT (NOT)


06 Jul 2012   #21

Home Premium 64 bit
 
 

I hope what follows will make the mud a little clearer

Quote   Quote: Originally Posted by DavidW7ncus View Post
Quote   Quote: Originally Posted by rundwald View Post
Edit: Have tried to install pro version from my retail CD and got MBAM_ERROR_LOAD_DATABASE (0,5)
Do you get this error trying to install the program, or did the program install and you get this error trying to update the virus definitions ?
I thought I had covered that!. Error was in middle of installation from CD (yesterday)

If you are installing from a CD, it may have an old version of the program.
The current version is 1.61.
If you have MBAM installed look on the "About" tab for the version.
It was an old version as per posts incl one made yesterday, where see my comment about leaving update until after installation was complete

From Post #1, I'm not sure what you did, or what old SF thread you found for this.
it was from post #2 Need Help Deleting Legacy Registry keys W7 64 bit
Did you manually edit the registry?
Yes after Revo had advanced uninstalled and I believed something was amiss

Do you have a restore point and/or backup image from before you first tried to update to the Pro version?
Several generated when I was cleaning out several try before you buy programs. However only one that refers to v1.61 being uninstalled if sys res used.


My System SpecsSystem Spec
.

06 Jul 2012   #22

Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by DavidW7ncus View Post
Quote   Quote: Originally Posted by rundwald View Post
@ everyone. Can it be confirmed that the statuses shown in the attachments are correct? As yet no one has remarked on the attachments
I'm guessing you are asking about the Permissions you have in Post #1.

In a system i am looking at permissions are different than yours for LEGACY_MBAMPROTECTOR.

My LEGACY_MBAMPROTECTOR permissions:
EVERYONE has "Read"
OWNER RIGHTS has "Special Permissions" (only)
SYSTEM has "Full Control" and "Read"
Since yesterday (and noted just now) mine look same as yours.
My System SpecsSystem Spec
06 Jul 2012   #23

Home Premium 64 bit
 
 

Quote   Quote: Originally Posted by DavidW7ncus View Post
What i think caused this issue is Ver 1.45 was installed on top of Ver 1.61
Questions i asked in Post #13 haven't been answered, and based on what is in the OP Post #1 it's not clear to me what was done to try and fix this.

DO NOT use Version 1.45

Download the latest MBAM Version (1.61) from
Where can I download the latest version of Malwarebytes? : Malwarebytes Support
You can use your Key and ID from your purchased Pro version to register the downloaded version.

Without clear answers to all questions asked it's difficult to give good advice.

What you can try:
If you have MBAM installed, uninstall it
Reboot
Run mbam_clean.exe
Reboot
Try installing the downloaded version (1.61) - Do not accept the Trial offer
If 1.61 installs OK, register your Key and ID
Make sure you can update the Virus definitions
If you do get any errors, specify exactly where you get the errors ( during uninstall, during install, running mbam_clean, updating DB, ... )
I shall uninstall and follow advice and just keep the reg details relating to CD. The CD will be useful for a small table mat.

Thanks everyone for your help to an mid septuagenarian.
My System SpecsSystem Spec
.


06 Jul 2012   #24

Win 7 Pro x64 SP1, Win 7 Ult x86 SP1
 
 

I Looked at the old thread Need Help Deleting Legacy Registry keys W7 64 bit
you originally followed to try and fix LEGACY permissions in the registry.

The info in that thread is above my skill level, so i can't give you any advice what to do to change/fix permissions.
It does help explain what you tried and why...and that's good to know.

Hopefully installing Ver 1.61 will fix your issue.
If you still have problems deleting the LEGACY registry keys, someone more skilled than me will need to help you.
Brink, Dwarf, and Bill2 posted in the old thread and probably can help with this.

Also, as you have the MBAM Pro version, you should be entitled to (free) Malwarebytes Support.
I believe they would be able to help straighten this out.

I also suggest learning and using Backup Imaging for your OS and programs.
It's the best way to backout/recover from problems like this...

YUP, your retail CD is at best a drink coaster
My System SpecsSystem Spec
06 Jul 2012   #25

Home Premium 64 bit
 
 

As an aside only
mbam_clean.exe still leaves Legacy_Mbamprotect unscathed
My System SpecsSystem Spec
Reply

 Killing in Regedit : Legacy key; MBAMPROTECT (NOT)




Thread Tools



Similar help and support threads for2: Killing in Regedit : Legacy key; MBAMPROTECT (NOT)
Thread Forum
OpenGL classified as legacy? Chillout Room
TRON - Legacy Chillout Room
How do I run legacy programs? Software
Firewire drivers: the 'Legacy' one isn't there? Drivers
USB Legacy Mode General Discussion
Configure Legacy devices to run on Win 7 News
New ATI Legacy Driver - Catalyst 9.3.1 Graphic Cards

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:17 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33