Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7, multiple UAC problems

14 Jul 2012   #1
ABM

Windows 7 Ultimate x64 SP1
 
 
Windows 7, multiple UAC problems

Hi,
I've been facing some problems with UAC for over a year. I tried solving it myself initially but failed. So I ignored the problem for a year as it didn't bother me too much, but need to get it solved now as it has come in the way of my work.

I'm using Windows 7 Ultimate x64 SP1 on a Dell Precision T3500 Workstation.

Everything was working great until one day I noticed something had changed when I right clicked on any shortcut icon: Name:  Run as admin user.jpg
Views: 14
Size:  69.7 KB
The shield icon next to the "Run as administrator" option was missing and there was a new option there called "runasuser".

When I click on either option, I get this message:
-error.jpg

I tried doing a system restore but it failed and on restart I got a similar message. System restore never worked after that. Also have trouble installing some applications and running some programs like team viewer or time trackers.
Name:  Timetracker problem message.jpg
Views: 12
Size:  72.3 KB

I'm also unable to change UAC settings here:-uac-settings.jpg
I can move the slider but nothing happens when I click the OK button. And the slider is back to where it was when I close and open the window again. But I was able to get around this using the program TweakUAC.

The resource monitor button in the task manager does nothing when clicked:
-resource-monitor.jpg

When I right click on a shortcut and clicked on Advanced properties, the options are always disabled. Even when I am on an Administrator user account.
-run-admin-disabled.jpg

These are the problems I noticed and appear to persist whether I am on a Standard user account or Administrator account. I believe they are all linked? I tried searching everywhere but was unable to get much info on this problem. It will really be great if somebody can let me know what's going on and what I should do.

Thanks in advance!




My System SpecsSystem Spec
.
14 Jul 2012   #2
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

Yes I think they are all related. But of course not 100% sure.
Can you open Elevated Command Prompt
Or is opening an adminstrator command prompt impossible? If impossible is th built-in admin account enabled. Log on as user called "administrator" and open a command pormpt normally.

Is that working?
My System SpecsSystem Spec
14 Jul 2012   #3
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

When in elevated command prompt:

sfc/scannow

post results
My System SpecsSystem Spec
.

14 Jul 2012   #4
ABM

Windows 7 Ultimate x64 SP1
 
 

Thanks for the quick reply Kaktussoft. It was impossible to open an elevated command prompt as a Standard user like you had guessed. I got the same error message. So I logged on to the user called "Administrator" and could run the command normally.
Results:
Name:  Scan results.jpg
Views: 20
Size:  48.8 KB


My System SpecsSystem Spec
14 Jul 2012   #5
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

User "administrator" has admin rights by default. No UAC prompt will be shown. Everything works fine here (check things that don't work previously)?

Do you see a UAC-prompt to confirm (under own account) or just the error message?
Same problem for all accounts? New created accounts? Create them when logged on as user Administrator
My System SpecsSystem Spec
14 Jul 2012   #6
ABM

Windows 7 Ultimate x64 SP1
 
 

I checked the other things that didn't work previously. but they are not working in the administrator user account too.

I didn't see UAC-prompt to confirm but just the error message. Also created new accounts and had the same problem. I will log on to administrator and create a new account and let you know what happens.
My System SpecsSystem Spec
14 Jul 2012   #7
ABM

Windows 7 Ultimate x64 SP1
 
 

I created a new user account while I was on administrator account, but it has the same problems too.
My System SpecsSystem Spec
14 Jul 2012   #8
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

In administor account open regedit goto key HKEY_CLASSES_ROOT\exefile ane export it. Do you see this? Especially focus on the bolded text

Windows Registry Editor Version 5.00
[HKEY_CLASSES_ROOT\exefile]
@="Application"
"EditFlags"=hex:38,07,00,00
"FriendlyTypeName"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,\
00,6f,00,6f,00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,\
32,00,5c,00,73,00,68,00,65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,\
00,2c,00,2d,00,31,00,30,00,31,00,35,00,36,00,00,00
[HKEY_CLASSES_ROOT\exefile\DefaultIcon]
@="%1"
[HKEY_CLASSES_ROOT\exefile\shell]
[HKEY_CLASSES_ROOT\exefile\shell\open]
"EditFlags"=hex:00,00,00,00
[HKEY_CLASSES_ROOT\exefile\shell\open\command]
@="\"%1\" %*"
"IsolatedCommand"="\"%1\" %*"
[HKEY_CLASSES_ROOT\exefile\shell\runas]
"HasLUAShield"=""
[HKEY_CLASSES_ROOT\exefile\shell\runas\command]
@="\"%1\" %*"
"IsolatedCommand"="\"%1\" %*"
[HKEY_CLASSES_ROOT\exefile\shell\runasuser]
@="@shell32.dll,-50944"
"Extended"=""
"SuppressionPolicyEx"="{F211AA05-D4DF-4370-A2A0-9F19C09756A7}"
[HKEY_CLASSES_ROOT\exefile\shell\runasuser\command]
"DelegateExecute"="{ea72d00e-4960-42fa-ba92-7792a7944c1d}"
[HKEY_CLASSES_ROOT\exefile\shellex]
[HKEY_CLASSES_ROOT\exefile\shellex\ContextMenuHandlers]
@="Compatibility"
[HKEY_CLASSES_ROOT\exefile\shellex\ContextMenuHandlers\Compatibility]
@="{1d27f844-3a1f-4410-85ac-14651078412d}"
[HKEY_CLASSES_ROOT\exefile\shellex\DropHandler]
@="{86C86720-42A0-1069-A2E8-08002B30309D}"
[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers]
[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\ShimLayer Property Page]
@="{513D916F-2A8E-4F51-AEAB-0CBC76FB1AF8}"
[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\{B41DB860-64E4-11D2-9906-E49FADC173CA}]
@=""
[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\{B41DB860-8EE4-11D2-9906-E49FADC173CA}]
@=""
My System SpecsSystem Spec
14 Jul 2012   #9
Kaktussoft

Microsoft Community Contributor Award Recipient

Microsoft Windows 7 Home Premium 64-bits 7601 Multiprocessor Free Service Pack 1
 
 

rightclick on exe file (so not the shorcut!) gives you also on option "runasuser" exactly that text?
My System SpecsSystem Spec
14 Jul 2012   #10
ABM

Windows 7 Ultimate x64 SP1
 
 

I did as you said and this is what I got -

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\exefile]
@="Application"
"EditFlags"=hex:38,07,00,00
"FriendlyTypeName"=hex(2):40,00,25,00,53,00,79,00,73,00,74,00,65,00,6d,00,52,\
00,6f,00,6f,00,74,00,25,00,5c,00,53,00,79,00,73,00,74,00,65,00,6d,00,33,00,\
32,00,5c,00,73,00,68,00,65,00,6c,00,6c,00,33,00,32,00,2e,00,64,00,6c,00,6c,\
00,2c,00,2d,00,31,00,30,00,31,00,35,00,36,00,00,00

[HKEY_CLASSES_ROOT\exefile\DefaultIcon]
@="%1"

[HKEY_CLASSES_ROOT\exefile\shell]

[HKEY_CLASSES_ROOT\exefile\shell\Open]

[HKEY_CLASSES_ROOT\exefile\shell\Open\Command]
@="\"%1\" %*"

[HKEY_CLASSES_ROOT\exefile\shell\runas]

[HKEY_CLASSES_ROOT\exefile\shell\runas\command]

[HKEY_CLASSES_ROOT\exefile\shell\runasuser]

[HKEY_CLASSES_ROOT\exefile\shell\runasuser\command]

[HKEY_CLASSES_ROOT\exefile\shellex]

[HKEY_CLASSES_ROOT\exefile\shellex\ContextMenuHandlers]
@="Compatibility"

[HKEY_CLASSES_ROOT\exefile\shellex\ContextMenuHandlers\CmdLineExt]
@="{9869EFB4-18E9-11D3-A837-00104B9E30B5}"

[HKEY_CLASSES_ROOT\exefile\shellex\ContextMenuHandlers\Compatibility]
@="{1d27f844-3a1f-4410-85ac-14651078412d}"

[HKEY_CLASSES_ROOT\exefile\shellex\DropHandler]
@="{86C86720-42A0-1069-A2E8-08002B30309D}"

[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers]

[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\ShimLayer Property Page]
@="{513D916F-2A8E-4F51-AEAB-0CBC76FB1AF8}"

[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\{B41DB860-64E4-11D2-9906-E49FADC173CA}]
@=""

[HKEY_CLASSES_ROOT\exefile\shellex\PropertySheetHandlers\{B41DB860-8EE4-11D2-9906-E49FADC173CA}]
@=""
My System SpecsSystem Spec
Reply

 Windows 7, multiple UAC problems




Thread Tools




Similar help and support threads
Thread Forum
Windows 7 multiple problems
Hello recently I experienced a problem in my Win7 version that may be related to Comodo antivirus or not. I have this machine for over 2 years without problems and always with Comodo antivirus. 2 days ago I updated the AMD drivers and Comodo antivirus version and after restart I noticed huge...
General Discussion
Windows 7 Ultimate x64, Multiple Problems
Hi guys, ill try to explain in detail.. Built Awesome PC in September 2011, installed windows 7 ultimate x64, everything was working fine up until december 2011, i turned pc on, walked away to do something. i come back to the computer and its trying to repair? in the end i tried the OE disc and...
General Discussion
Multiple problems with Windows 7 x64 on new laptop
I really hope someone can help me. I have read 100's of posts about the issues I am having, but can't seem to find a solution. I have a brand new laptop that seemed to be working fine, until it did some automatic updates from microsoft (I am guessing this is what caused the problems). 1st...
General Discussion
Windows 7 x86, help Multiple problems
Hi all, i have discovered something about my Windows 7 OS. I am using x64 on a toshiba satelliteLd305 model with 3GB ram. It came originally with Vista though. Im having a problem with the machine in that every sooo often it freezes up and i have to select the option to restart WINDOWS...
BSOD Help and Support
Multiple problems with windows 7
This may be a long message but I am disillusioned about Microsoft generally and win7 in particular. I have had every MS OS since win 3.1 and expect, that each version would be better....in every way than its predecessor....but alas! I run vista ultimate and bought Windows 7 a few days ago. This...
General Discussion
Multiple windows 7 Problems
I do not know if this is in the right section but its my first time here :D okay to the point. i have two problems with my windows 7 64bit desktop the first is after 2 minutes of turning on it says no network access (my computer is wireless) and when i go to shut down it just displays the shutting...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:46.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App