Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Icons for .mht, .htm, & .html Won't Appear in Explorer Window


07 Aug 2012   #1

Windows 7 Home Premium x64 v6.1.7600
 
 
Icons for .mht, .htm, & .html Won't Appear in Explorer Window

Hi Fellows,

I've had this problem in several installs of Windows 7 x64, including this current fresh one. It usually happens about a month after a fresh install.

Here are some facts about the problem:

1. The only icons affected are .mht, .htm., & .html.
2. File extensions are fine - no issues.
3. .mht = Internet Explorer ... both htm & html are associated with Firefox.
4. In Firefox, when using "Save Page As", in the Explorer window that opens, the icons are always there! This has been true in each install of Windows 7, though after a year or two they will sometimes not appear in this case as well. Then, they'll suddenly reappear.
5. Rebuilding the icon cache didn't fix it.
6. Changing the file association temporarily didn't work. When changing htm & html to IE, the icon appears. But changing mht to Firefox doesn't cause an icon to appear, not does the correct IE icon appear when I change the association back to IE. Changing htm & html back to Firefox doesn't work, either.
7. No custom icons, file extensions, etc. are involved.
8. Other icons in the same Explorer window .. DO appear, without fail.

Would appreciate any help for this annoying problem. Below is a screenshot.

Thanks is advance.
~~~




Attached Thumbnails
Icons for .mht, .htm, & .html Won't Appear in Explorer Window-explorer.jpg  
My System SpecsSystem Spec
.

09 Aug 2012   #2

Windows 7 Home Premium x64 v6.1.7600
 
 

No ideas at all?
~~~
My System SpecsSystem Spec
09 May 2013   #3

Windows 7 Ultimate x64
 
 

I know this is an old thread, but it has the most detailed description of this problem, which I have been experiencing for quite a while now.

I finally decided to try and fix it this morning. I am able to get HTM/HTML icons (I use Firefox) to show up properly (had to delete a registry key), but MHT files are still blank.

I've tried every "solution" I could find on the web to no avail.

If anything, I'd really like to know what the problem is. Could it be something to do with "web" files being shared between different browsers?
My System SpecsSystem Spec
.


Reply

 Icons for .mht, .htm, & .html Won't Appear in Explorer Window




Thread Tools



Similar help and support threads for2: Icons for .mht, .htm, & .html Won't Appear in Explorer Window
Thread Forum
Internet Explorer HTML <form> tag bug Browsers & Mail
HTML Depricated in Internet Explorer 10 vs. previous versions Browsers & Mail
make window explorer transparent like gadget window. Themes and Styles
HTML icons (IE8,Firefox) display as blanks Browsers & Mail
blank html icons Software
What is the meaning of each of the window explorer file icons General Discussion
Microsoft Internet Explorer HTML Layout Engine Uninitia Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:56 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33