Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Command prompt - open problem


25 Aug 2012   #1

Windows 7 Proffesional x32
 
 
Command prompt - open problem

I have installed Windows 7 Pro x32 and I'm in corporate lan (domain), but I have admin rights. After a while I can't open command prompt, but cmd.exe and conhost.exe can be found in Task Manager. What have I tried until now without luck:

- remove policy keys
- upgrade Windows 7
- run as Administrator

But, I can open it using SHIFT + right-click and Run as different user and typing different user account.

As I'm programmer I tried to create console application. After i ran it i can see my desktop background through it. I mean console background is transparent.

DebugView shows this after opening cmd:

[4048] CFRContextMenu: Contruct
[4048]
[4048] Initialize
[4048]
[4048] START : CFRContextMenu::Init : .\Src\FRContextMenu.cpp (94).
[4048] InitFiles Count : 1
[4048]
[4048] F:\Windows\System32\cmd.exe has unsupported format
[4048]
[4048] FAILED : CFRContextMenu::Init.
[4048] Initialize ---- FAILED
[4048]
[4048] CFRContextMenu: Destruct
[4048]

I'm not sure what else I can do except to format and install windows 7 again.

Thanks in advance.


My System SpecsSystem Spec
.

25 Aug 2012   #2

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

Welcome
I really have no suggestions other than to off this tutorial to you Elevated Command Prompt Shortcut
My System SpecsSystem Spec
25 Aug 2012   #3

Windows 7 Proffesional x32
 
 

Thanks but no luck. Same happens. Window doesn't show up and processes are visible under task manager.
My System SpecsSystem Spec
.


25 Aug 2012   #4

Win 7 Pro x64 SP1, Win 7 Ult x86 SP1
 
 

If i understand correctly, it sounds like the process is running under a different account than the account you are logged into.
Can you log in with the account the process is running under and see the window?

I tested "a test case" on a home PC and get the error below.
I think you are running into the same issue...

Name:  NoWinSP01.PNG
Views: 5
Size:  22.0 KB

another programmer


My System SpecsSystem Spec
26 Aug 2012   #5

Windows 7 Proffesional x32
 
 

As I can see it's running under my account. And yes when i say bring window to front it shows that message. When i log with any other account (admin, power user, etc) it shows cmd without problem.
My System SpecsSystem Spec
Reply

 Command prompt - open problem




Thread Tools



Similar help and support threads for2: Command prompt - open problem
Thread Forum
Command Prompt Shutdown problem Network & Sharing
Command Prompt Won't Open Software
Windows 7 weird command prompt problem General Discussion
Command Prompt problem General Discussion
Command prompt won't open General Discussion
Command prompt won't open! General Discussion
How to open Elevated Command Prompt? Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:17 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33