Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Autoplay not working

30 Aug 2012   #1
TonyL

windows 7 home premium 64 bit
 
 
Autoplay not working

When I put an audio disk in my disk drive the autoplay does not open the disk. I have open autoplay and selected Itune to open the disk, selected autoplay check box and saved. Then I rebooted the system, inserted a disk and only the Roxio burn icon appeared. I tried to deselect the autoplay check box, save and reboot. Then reselected autoplay and rebooted. No change. Any suggestions?


My System SpecsSystem Spec
.

30 Aug 2012   #2
BrightBlessings

Win7 Pro-64 Bit
 
 

My System SpecsSystem Spec
30 Aug 2012   #3
TonyL

windows 7 home premium 64 bit
 
 

Thanks BrightBlessings. I read the file and looked at my registers. That does not appear to be the problem.
My System SpecsSystem Spec
.


30 Aug 2012   #4
BrightBlessings

Win7 Pro-64 Bit
 
 

Sorry that was of no help for you. I have got no more to try and help with, keep checking back as I'm sure someone will be able to assist you with this problem.
My System SpecsSystem Spec
30 Aug 2012   #5
Ztruker

Windows 8.1 Pro X64
 
 

Where did you set the action you wanted? Was it here: Control Panel\Hardware and Sound\AutoPlay or here: Control Panel\All Control Panel Items\AutoPlay? If not, take a look there.

Mine looks like this:

Autoplay not working-autoplaysettings.jpg


My System SpecsSystem Spec
30 Aug 2012   #6
TonyL

windows 7 home premium 64 bit
 
 

How do you get a screen shot?
My System SpecsSystem Spec
30 Aug 2012   #7
AddRAM

Windows 7 Professional x64 Service Pack 1
 
 

The easiest way is to hit the Prt Scr key on the keyboard then open paint and click paste. Then name the file and save it to your desktop, or use the snipping tool. Both are found in Start>All programs>Accessories
My System SpecsSystem Spec
30 Aug 2012   #8
TonyL

windows 7 home premium 64 bit
 
 

Attached is my autoplay setup:


Attached Thumbnails
Autoplay not working-autoplay.png  
My System SpecsSystem Spec
31 Aug 2012   #9
BrightBlessings

Win7 Pro-64 Bit
 
 

Just a suggestion.
If you choose the audio cd ask every time option in autoplay, you will have the option to choose iTunes. I know it's not what you desire, but it is just an extra click. I have looked on the net and it seems to be a problem quite a few people have with iTunes and windows.

BTW what letter is assigned to your optical drive?
My System SpecsSystem Spec
06 Sep 2012   #10
TonyL

windows 7 home premium 64 bit
 
 

This is what I have tried:
I tried to run net start shellhwdetection and I received the following message: "system error 1058 has occurred. This service cannot be started, either because it is disabled or because it has no enabled devices associated with it.
Then I tried to check if the NoDriveTypeAutoRun and/or NoDriveAutoRun policy value was set correctly. I went to regetit and looked for HKEY_LOCAL_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer and looked for the NoDriveTypeAutoRun registry entry on the right pane. It was not there.
Does anyone have any other suggestions?
My System SpecsSystem Spec
Reply

 Autoplay not working




Thread Tools





Similar help and support threads
Thread Forum
autoplay not working x64 bit
Recently autoplay is not working.Whenever I insert pen drive,cd,dvd ,dongle no autoplay.It worked earlier.Installed no new software.Tried everything registry,autoplay from control panel,gpedit noe works.Plz help It's very annoying. I have avast free antivirus 2014 and malwarebytes free.
Hardware & Devices
Autoplay not working
Autoplay on my desktop has stopped working. I have to go to Windows Explorere and open the DVD drive to access the proper exe file. It does not work for software or for music or for my rescue disk or the original Win7 OS software. I had the autoplay set up for "ask me every time" and I changed it...
General Discussion
Autoplay not working
The autoplay feature stopped working. Whenever I plug in a removable disk autoplay won't launch. This is strange because it is already enabled in Control Panel. Any idea how can I fix this? :(
General Discussion
Autoplay not working when using CD drive
Hello, I have a problem with the autoplay, USB and card reader are fine however when using either music CD, or DVD or software CD the autoplay doesn't kick in, when I browse the disk and select autoplay manualy it will start, I have set up everything in my autoplay setting in the control panel...
Hardware & Devices
AutoPlay stopped working, help.
OS is 64-bit. AutoPlay worked fine for a long time. Then I must have installed a piece of software that now prohibits it from working. Tried to force it to work with Windows AutoPlay from the Control Panel. No luck. Tried to trace down the source of the problem. No luck. I'm out of ideas. Any one...
Customization
Autoplay is 'mixed up' and not working.
Running Win 7 Home Prem 64 bit and autoplay will not run a software instal CD/DVD. I have reset all autoplay defaults to "Take No Action" except Software and Games which is set to "Instal or run prog". I have restarted Win to ensure these stick. When I try to install a prog from the CD the...
Software

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 18:42.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App