Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Successful Anytime Upgrade Home prem. to Ultimate, problems next day


16 Sep 2012   #1

Windows 7 64-bit
 
 
Successful Anytime Upgrade Home prem. to Ultimate, problems next day

I am in the middle of another windows nightmare right now. I just purchased an anytime upgrade for my laptop and desktop (both OEM 64bit home premium to Ultimate), and rebooted and everything was fine on both. However, I noticed that some elements of Windows were missing. The Local Security Policy was not there, and would just bring up an error. I went on to Microsofts Technet help pages and found a fix for missing local security policy after anytime upgrade. (It was a regsvr command that reregistered all of the windows dlls.)

This seemed to fix the problem on my laptop and as I went through the control panel and administrative tools everything seemed to be there. I then installed the new version 9 of Vmware Workstation and the new virtualbox 4.2 and rebooted (because virtualbox needed it for networking) and it would just boot to a black screen. I tried a system restore, I tried using my macrium reflect system restore disc (worked in the past by rebuilding the boot configuration.) I also tried my windows 7 64bit system repair disc, and none of them changed anything- still booting to black screen after the windows splash screen.

I have an OEM factory restore disc set but there is no repair option on the HP 3 disc set, so I did not use them, normally any problems booting are fixed by my macrium reflect boot disc, or my windows 7 repair disc that I had made from within windows. Strangely, my recovery partition was no longer recognized by Windows and I had no other repair options during boot up besides safe mode, (which also booted to just the black screen only). Thank God I had a system image from August 29th, which I have just resorted to restore, but I am very nervous as it is stuck at 30% after verifying install.

So that is still going on my laptop and I am on the desktop which has the following problems now.... No windows 7 Backup And restore. When I try to access Backup and Restore I get the error: The page failed to load inside a blank box. This worked before the anytime upgrade. It seems on both computers that the anytime upgrade was successful but screwed up some key parts of windows, and now I am mad that I did not perform a full backup and system image immediately before and after the anytime upgrade. I can not find any other posts about people performing a successful anytime upgrade and then rebooting to a black screen after about a day. This is making me want to warn anybody with an OEM computer that anytime upgrade may mess with the system - I can not think of any other reason for these problems.

Does anybody have a similar experience or some information on how I can fix this backup and restore error, and also fix this local security policy error. (I am afraid that the regsvr command is what left my laptop unbootable.)


My System SpecsSystem Spec
.

16 Sep 2012   #2

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

Well if bootable, I would give this a go.
SFC /SCANNOW Command - System File Checker

Also verify in the system window that it did in fact upgrade properly and is now calling itself the proper version.
My System SpecsSystem Spec
16 Sep 2012   #3

Windows 7 64-bit
 
 

Yes I just did this and checked the logs and the only error is the same one Ive always had with the corrupt tcpmon.ini file, (which I just leave alone because it is common and doesnt affect my networking). However Backup and Restore is still not there. I think something happened with the HP laptop and the upgrade knocked the bootup link to the OS, boot was repaired but still could not get to the Windows 7 login screen after just being stuck on the black screen. Could have been something with either the regsvr /u /? %1 command that I performed that reregistered everything in a command window, and stopped with a blank one, ( i everntually closed the command window) , or the install of vmware and the new virtualbox destroyed my boot to the OS, but what a nightmare and thank god for having an august 29th image. Freaking complete nightmare I tried everything man, I am praying that I have no other problems with the Dell Desktop and I am afraid to reboot it, My laptop worked fine until the last reboot. Backup often guys and watch the anytime upgrades on OEMS!

this is the command that I did before the black screen, I dont know if it affected it though.
regsvr32 /u \"%L\""
My System SpecsSystem Spec
.


16 Sep 2012   #4

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

Something else to note, if you are using a antivirus or security software of any sort remove it before upgrading or even attempting a repair install. They very commonly interfere with these processes and cause odd bugs and glitches down the road.
My System SpecsSystem Spec
Reply

 Successful Anytime Upgrade Home prem. to Ultimate, problems next day




Thread Tools



Similar help and support threads for2: Successful Anytime Upgrade Home prem. to Ultimate, problems next day
Thread Forum
Upgrade to Professional or Ultimate (for free), or stay at Home Prem.? General Discussion
Solved Windows 7 Anytime Upgrade with non-upgrade Ultimate license? Installation & Setup
Problems with 64-bit W7 after anytime upgrade from Home Premium to Pro Installation & Setup
Windows Anytime Upgrade was not successful Installation & Setup
Upgrade vs WOW for Win 7 Home Prem to Prof Installation & Setup
Upgrade Win 7 home prem to professional using upgrade disk Installation & Setup
installing home prem, on Ultimate RC? Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:33 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33