Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Folders stuck on "read-only" mode?

19 Sep 2009   #1

Windows 7 Professional 64-bit
 
 
Folders stuck on "read-only" mode?

This is the closest I could find as far as a relevant forum section for this problem.

The sub-folders within my "My Pictures" folder won't let me save directly to them. For example, I would just save an image from the internet directly to a specific folder for organizational reasons, but it says "access denied". BUT when I try to save it to "My Pictures" it works just fine! And then I have to move it later to the folder I wanted it in originally.

I tried going to the main Pictures folder and un-checking the "Read Only" box (which was checked for some reason), but that didn't work (included all sub folders). I also tried to doing that directly to a folder I wanted to save to, no luck.

I also seem to just not be able to do much of any basic things with the images inside of "My Pictures", including just a simple rotation! This seems like a real issue.

My System SpecsSystem Spec
.

19 Sep 2009   #2

Windows 7 build 7100 x86
 
 

that is weird. When you unchecked the folders, was it a tick in the box or a blue square? a tick means it is read only, a blue square just means its in a 'no-attributes' state (counter-intuitive i know).
My System SpecsSystem Spec
19 Sep 2009   #3

64-bit Windows 8.1 Pro
 
 

Take ownership of the folder/file....
My System SpecsSystem Spec
.


19 Sep 2009   #4
Microsoft MVP

W 7 64-bit Ultimate
 
 

Quote   Quote: Originally Posted by Tews View Post
Take ownership of the folder/file....

Here's a nice tutorial for a shortcut, at the link below.



Take Ownership Shortcut
My System SpecsSystem Spec
19 Sep 2009   #5

Windows 7 Professional 64-bit
 
 

Taking ownership worked, but I'm surprised I had to resort to that.

And antt, it was a blue box, not a tick/check.
My System SpecsSystem Spec
19 Sep 2009   #6
Microsoft MVP

W 7 64-bit Ultimate
 
 

Glad to see you have it sorted.
My System SpecsSystem Spec
26 May 2011   #7

windows 7 home basic 32 bit
 
 

Hi

I have made ownership of the my documents folder and when I i check the box (blue square in the box) it makes everything unread but when i open it up again all the folders in the my documents are still read only but the my documents as unread. I have tried the attrib -r in the cmd.exe

I am running windows 7 home basic on a 32bit system
My System SpecsSystem Spec
30 Jun 2011   #8

Windows 7 Ultimate x86
 
 

I've had this problem ever since I reinstalled Windows. It didn't do it before. It's annoying, just about every folder on both my drives defaults to read-only and I can't save or extract any files in say the TEMPORARY FOLDER!!!! AAARRRRRRGHHHH!!!!! I hate you, Microsoft! Fix this problem NOW! I can't install my new wireless card because it can't write two driver files to the C:\Users\(me)\Temp folder. I uncheck read-only and run it...it's back to read only before it finishes applying. It's read-only no matter what I do. I've run cmd as administrator and applied the attrib -r C:\Users and it drops to the next line, but the folder is still Read-Only! I've downloaded that registry file to take ownership and I've then unchecked read only and it still comes back. Am I going to have to reinstall Windows to fix this problem?!
My System SpecsSystem Spec
17 Sep 2011   #9

windows 7, ultimate
 
 

My problem was that Windows Live Photo Gallery would not let me make changes in the files in the folder... I tried several things noted on the forum but what ultimately worked was something that struck me when I planned to merge all partitions into one so that I may have to save the default pictures folder too in the main C drive... I created new folder in my D and pasted one photo from somewhere into it and checked whether Windows Live Photo Gallery would let me make changes in the folder... It worked and so I copied all child folders and files back into same named folders from my C-drive. So this is a new folder that was created in the D partition only and not something that was inherited by copying or other processes...
My System SpecsSystem Spec
17 Sep 2011   #10

XP SP3 32bit, Vista HP 64bit, Seven Pro 64bit
 
 

All Windows folders are always marked read-only. This does not mean that they are read-only. The Windows folder read-only flag can never be changed by the user, all Windows folders will always be flagged as read-only.

Windows uses the folder read-only flag for internal purposes. Improper Windows permissions may stop access to a folder but a user with proper permissions can always write into a folder regardless of the setting of the folder read-only flag.

The folder read-only flag setting serves only one purpose, it is there to allow a user to mark all the files inside the folder as read-only or not read-only all at one time.

It is possible for a programmer to change the folder read-only flag to "not read-only" but absolutely nothing is gained by doing this.

From a technical point of view it's true, a folder "object" is read-only to the user. A folder is a Windows object, much like an ordinary file, that is a collection of data containing information about the folder. The folder object is managed by the Windows file system and only Windows has permission to change any of that folder object data.
My System SpecsSystem Spec
Reply

 Folders stuck on "read-only" mode?





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:01 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33