Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 - Programs Won't Open Sometimes almost sure it's not a virus

28 Sep 2012   #1
arrowhead566

Windows 7 Home Premium x64
 
 
Windows 7 - Programs Won't Open Sometimes almost sure it's not a virus

Hello!

A couple months ago, this problem began, but it went away on it's own. Recently, this problem has arisen again with greater intensity. My programs won't open. Usually it takes a while for this happen. Some scenarios are listed below.

1. I will have Chrome open, AIM open, while playing a game. I decide to open another program, but it will not open. Task Manager will not open. Opening file folders takes 1-2 minutes.

2. A program triggers the problem. After opening AVG Anti-Virus and pressing update, programs refuse to execute. After restarting my computer, the problem goes away and I am able to update.

3. The issue happens on start up. My computer starts up, my only visible start up program, AIM, starts up. However, I can not open files, can not connect wirelessly or wired to my internet connection.

Things I have done to attempt to fix the problem.
- Defragmented my Hard Drive
- Ran chkdsk
- Multiple virus scans
- Registry Scans

Also, this problem can occur at any time while using my computer. For example, I could be gaming for hours at a time, but I won't realize the issue has occurred until I attempt to open another program. I can also browse on an existing tab on Chrome at a time for hours until this issue occurs. However, if I were to open a separate tab on Chrome, the tab is blank, and I am not able to browse with it.

Thank you for any help you can provide.


My System SpecsSystem Spec
.
28 Sep 2012   #2
dejavecue

Windows 7 Ultimate x64
 
 

Tried disabling your antivirus protection? Sounds like whenever you try to open something new (i.e. start a new executable), something - my guess is the antivirus scanner - is scanning this and maybe "hiccoughs", leading to long load times.
If I remember correctly, Chrome opens a new chrome.exe for every tab, so that it can safely crash one tab without interfering in the other open ones (also runs faster that way).

Edit: Also, might be that you have your programs on a different hard drive than the one your games are on?
And that hard drive shuts down to save power - you would hear it spinning up again when you try to open a new program. Typically should not take so long, but I don't know how old it is...
My System SpecsSystem Spec
28 Sep 2012   #3
arrowhead566

Windows 7 Home Premium x64
 
 

Yes, my games are on a different hard drive. I do not believe that is the issue however. Sometimes I will browse, or watch a movie for a while. Then programs from both my internal and external hard drive fail to execute. I did notice that my problems seemed to intensify with the installation of AVG, but the problem was here long before that. I am not sure if Malwarebytes' Anti-Malware is considered as an antivirus, but I will try disabling the security module. Ah yes, this computer is about 3/4 years old, and the external hard drive is about a month old.
My System SpecsSystem Spec
.

28 Sep 2012   #4
dejavecue

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by arrowhead566 View Post
I did notice that my problems seemed to intensify with the installation of AVG, but the problem was here long before that. I am not sure if Malwarebytes' Anti-Malware is considered as an antivirus, but I will try disabling the security module.
Try that. Might be the issue.

Quote   Quote: Originally Posted by arrowhead566 View Post
Yes, my games are on a different hard drive. I do not believe that is the issue however. Sometimes I will browse, or watch a movie for a while. Then programs from both my internal and external hard drive fail to execute.
Wait, they fail to execute? I thought they merely took very long.


Are you up-to-date on all your drivers? Motherboard, graphics card, etc? Current BIOS installed?
My System SpecsSystem Spec
28 Sep 2012   #5
arrowhead566

Windows 7 Home Premium x64
 
 

Program files take extremely long to execute, whereas .exe files, fail to execute at all.
Yes, I have checked the manufacturer's website, and all my drivers are update, as well as my BIOS. I am in safe mode at the moment, and the problem does not seem to be occurring.
My System SpecsSystem Spec
28 Sep 2012   #6
arrowhead566

Windows 7 Home Premium x64
 
 

Ah yes, some information I would like to add. The sporadic nature of this problem is what is unique. If it were a set time, or followed by a set event, it would be easy to diagnose, but it is not. A couple weeks back, I ran a test where I would constantly open task manager every 5 minutes, and I was able to do it for 2+ hours. By then my fingers were a bit sore, but the problem did not arise. Sometimes, this problem won't present itself for days at a time, and then it will suddenly reappear.
My System SpecsSystem Spec
28 Sep 2012   #7
dejavecue

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by arrowhead566 View Post
Program files take extremely long to execute, whereas .exe files, fail to execute at all.
Yes, I have checked the manufacturer's website, and all my drivers are update, as well as my BIOS. I am in safe mode at the moment, and the problem does not seem to be occurring.
If it continues to not occur (what a sentence ) you have a driver at fault - Windows Safe Mode is simply windows without loading drivers. That is why generally you have to set resolution at the beginning again.

If all else fails I would try to reinstall Windows. Should be no problem for you to back up your data, as you still have total access.

Sorry I cannot be of more help, but if you cannot link the problem to a specific program or event, it is really hard for me/us to diagnose this at a distance.

Do you by any chance have another Antiviral software active (maybe in background)?
My System SpecsSystem Spec
28 Sep 2012   #8
arrowhead566

Windows 7 Home Premium x64
 
 

Yes, I am running another antivirus scan, and if all else fails, I do plan reinstalling windows.
My System SpecsSystem Spec
28 Sep 2012   #9
dejavecue

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by arrowhead566 View Post
Yes, I am running another antivirus scan, and if all else fails, I do plan reinstalling windows.
No that's not what I meant: Do you have two antivirus scanners running at all times simultaneously? Because if so, that would be terrible for performance as well as security.
My System SpecsSystem Spec
28 Sep 2012   #10
arrowhead566

Windows 7 Home Premium x64
 
 

I don't know if this will help, but I just attempted another diagnostic. After the problem occurred, I opened Skype, among other .exe files. At first, they wouldn't open, however about 5-10 minutes later, they all opened and the problem is gone for now. It is almost as if my computer was experiencing a massive lag in program executions. Does this help in any way?

EDIT: Wow, I am an idiot, the result of the programs launching was my anti-virus finishing it's scan. It found a WIN32.Kido Trojan. Using a different anti-virus appeared to solve the problem. I will report back to here, to see if it actually was the problem as a reference for any others who have a similar problem with me.
My System SpecsSystem Spec
Reply

 Windows 7 - Programs Won't Open Sometimes almost sure it's not a virus




Thread Tools




Similar help and support threads
Thread Forum
windows 7 - programs not launching fully after launched, virus?
Hi all Recently got a fresh installation of windows and HD from HP after my HD went bad about 2 weeks ago. They replaced a few other things. PC was fine but over the last 2 days things have seemed to have gone downhill. I noticed that occasionally I would click on a program icon to launch, the...
System Security
How do I get rid of weird virus? (Programs won't open in Windows 7)
When I ran Malwarebytes it said it needed to restart to get rid of the viruses it detected and since then I haven't been able to open any software. I used to be able to open only IE but not even that anymore. I did everything I could that I've seen in forums; restoring to another time; going on...
System Security
No programs open, virus diagnosis help
I have a friend's laptop so please excuse me for not being 100% informed about it. He said a pop up opened while surfing and he clicked not knowing what it was. He is unsure what it said except that he thought it was a Windows fix box and it said something about an .exe file. There are no longer...
System Security
My Windows programs will not open images, I can open them with PSP
For a while my windows 7 64 bit would open my images in Documents. Now when I try they appear as a garbled strange format. If I go to PSP ProX2 they open fine. This is a problem for me since I often need to add images to document Newsletters I send out. :confused: Thanks, Char
Software
Virus? - unable to to do system restore or open many programs
hi, i think i have a virus on my computer, it happened a couple of days ago, i've messed around with it a little but with no joy, i had error msg's so tried to do a system restore but got this msg c:\windows\system32\rstrui.exe the extended tributes are inconsistent, i had errors with norton so...
System Security
Windows 7 built in anti-virus & spyware programs
Windows 7 built in anti-virus & spyware programs. Are they worth keeping? On my XP, Avira worked just fine, along with some spyware programs. Your thoughts.
System Security


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:07.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App