Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Problem with Arial Bold Font

04 Oct 2012   #1

Windows 7 Ultimate x64
 
 
Problem with Arial Bold Font

I am being driven to distraction by this. Every time I boot Windows (64-bit ultimate), there is a problem with Arial Bold. It displays in all programs as the bold italic version. When i went into Control Panel > Fonts, it showed it wasn't installed, but when i downloaded and tried to install it, I was told it was already installed and did i want to overwrite it. I said yes, and it works again. However, on the next boot, i have the same problem.

I found a tweak online that made the fonts folder display as it did in XP, just a simple list of files and found there was about 3 or 4 versions of each style of Arial in the folder. I've managed to delete the duplicates so i just have 1 of each now, but the Arial Bold problem remains. After booting, i can go into the font folder, double click the Arial Bold icon and it shows the preview of it looking fine. I can then click the Install button and it tells me again that it is already installed and do i want to overwrite it. When i say yes, all works fine again until next boot.

I've tried deleting the font so i can put a fresh version in, but nothing works. It says i need permission from TrustedInstaller to do this. When i try to change permissions (I am using an administrator account) it tells me 'access is denied'. I have even tried booting into safe mode but the same result.

Does anyone have any idea how i can solve this before i stick the computer through a window?!


My System SpecsSystem Spec
.

04 Oct 2012   #2

Windows 7 Ultimate SP1 (64 bit), Windows XP SP3, Linux Mint 17 MATE (64 bit)
 
 
9 Fonts not including Unicode

The Fonts folder shows a single (stacked) icon for Arial on my PC.
It contains 9 fonts!
Problem with Arial Bold Font-fonts-arial.png


My System SpecsSystem Spec
04 Oct 2012   #3

Windows 7 Ultimate x64
 
 

As I said, because I was having so many problems, i've made a change that just shows all the files in the font folder, rather than the groups. I've attached a screenshot to show what is happening. The screenshot shows on the left how the internet browser is replacing Arial Bold with Arial Bold Italic as Windows doesn't think the Bold version is installed, and on the right is my Windows>Fonts folder showing that it contains 3 separate Arial Bold files (Arial Bold_1.ttf, arialbd.ttf and arialbd_0.ttf). You can also see that when i select the Arial Bold font, the preview shows in bold italic, but when i open that font, the preview shows correctly. What the hell is going on.


Attached Thumbnails
Problem with Arial Bold Font-screen2.jpg  
My System SpecsSystem Spec
.


04 Oct 2012   #4

Windows 7 Ultimate SP1 (64 bit), Windows XP SP3, Linux Mint 17 MATE (64 bit)
 
 
Fonts Tutorial?

Does it only happen with Arial?
What happens if you change to Segoe or Tahoma?

Have you tried the various options in this tutorial?
Fonts - Change


Regarding the "Trusted Installer" problem, do you have access to a Live Linux CD?
I use a Live Ubuntu CD when Windows refuses to let me do something.

Remember to create a Backup HDD image first.
My System SpecsSystem Spec
09 Oct 2012   #5

Windows 7 Ultimate x64
 
 

I'm not sure what you mean. Change what to Segoe UI or Tahoma? It's only currently Arial Bold i'm having this problem with as the message said. Everything else works as normal, just Arial Bold keeps uninstalling itself, or at least not being picked up correctly by Windows.
My System SpecsSystem Spec
09 Oct 2012   #6

Windows 7 Ultimate SP1 (64 bit), Windows XP SP3, Linux Mint 17 MATE (64 bit)
 
 
Font Change tutorial?

Quote   Quote: Originally Posted by scarrott View Post
I'm not sure what you mean. Change what to Segoe UI or Tahoma? It's only currently Arial Bold i'm having this problem with as the message said. Everything else works as normal, just Arial Bold keeps uninstalling itself, or at least not being picked up correctly by Windows.
I don't see where you said that ONLY Arial is faulty.

The Windows 7 default font is Segoe UI.
  • How are you using Arial, if you haven't changed any settings?
In your picture, Windows Explorer looks normal, but Chrome is broken.
  • Are you saying that EVERY 3rd party program is broken, but Windows is still normal?
  • If it is only happening with Chrome, have you checked that it is set to the correct font?
Tutorial
  • Have you tried the Font Change tutorial?
My System SpecsSystem Spec
09 Oct 2012   #7

Windows 7 Ultimate x64
 
 

Thanks for your reply. The first line of my initial message said 'Every time I boot Windows (64-bit ultimate), there is a problem with Arial Bold' and the title of the thread is 'Problem with Arial Bold Font'. There don't seem to be any problems with any other fonts. No program recognises that Arial Bold is installed at all, even though it is in the font folder (as shown on the screenshot). Chrome was just one example, but it was replaced with Arial Bold Italic in every program, and in programs such as Word, CorelDraw, Outlook, etc., Arial Bold was not available for selection. The only place that the font displayed correctly was when I double clicked on the font file in the Fonts folder to see the Preview. Even the preview pane shows it incorrectly.
My System SpecsSystem Spec
09 Oct 2012   #8

Windows 7 Ultimate SP1 (64 bit), Windows XP SP3, Linux Mint 17 MATE (64 bit)
 
 
sfc /scannow

Quote   Quote: Originally Posted by scarrott View Post
Thanks for your reply. The first line of my initial message said 'Every time I boot Windows (64-bit ultimate), there is a problem with Arial Bold' and the title of the thread is 'Problem with Arial Bold Font'. There don't seem to be any problems with any other fonts. No program recognises that Arial Bold is installed at all, even though it is in the font folder (as shown on the screenshot). Chrome was just one example, but it was replaced with Arial Bold Italic in every program, and in programs such as Word, CorelDraw, Outlook, etc., Arial Bold was not available for selection. The only place that the font displayed correctly was when I double clicked on the font file in the Fonts folder to see the Preview. Even the preview pane shows it incorrectly.
OK.
It wasn't obvious that you had tried other fonts and that they ALL worked correctly.

If every program does it, it may indicate that the Registry (or Windows itself) has become corrupted.

Have you tried sfc?
You need to open the "Command Prompt" and execute:
sfc /scannow
Tutorial:
SFC /SCANNOW Command - System File Checker


IMO, if that doesn't work, it seems like you have limited options:
  • Don't use Arial (select a different font)
  • Use System Restore (if there is a System Restore point that pre-dates the problem)
  • Re-image your HDD (if you have backup images)
  • Reinstall Windows
  • Wait for another member to offer some extra options
My System SpecsSystem Spec
10 Oct 2012   #9

Windows 7 Pro x64 (1), Win7 Pro X64 / WinXP Pro x86 on (2)
 
 

Quote   Quote: Originally Posted by scarrott View Post
As I said, because I was having so many problems, i've made a change that just shows all the files in the font folder, rather than the groups. I've attached a screenshot to show what is happening. The screenshot shows on the left how the internet browser is replacing Arial Bold with Arial Bold Italic as Windows doesn't think the Bold version is installed, and on the right is my Windows>Fonts folder showing that it contains 3 separate Arial Bold files (Arial Bold_1.ttf, arialbd.ttf and arialbd_0.ttf). You can also see that when i select the Arial Bold font, the preview shows in bold italic, but when i open that font, the preview shows correctly. What the hell is going on.
When you installed your Windows system, did you add additional fonts packages... perhaps from some other vendor product? Some other word processor maybe?

I ask, because your physical list of font names in \Windows\Fonts\arial* does not appear to be the "standard" Arial family of 10 TTF font names, at least not in my own Windows 7 Pro x64 (and I've added additional fonts, but nothing affecting the standard "arial" family).

I guess I'm suggesting you remove ("uninstall") your existing Arial family of TTF fonts, and install the set of 10 TTF fonts for Arial in my attachment below. Certainly don't forget to take a system restore point or better yet "system image" backup first, just in case of serious problems.


(1) Arial family:



(2) Arial details:



(3) Arial file names in "fonts" folders:



(4) Attached Arial "family" of 10 fonts (TTF):



Attached Files
File Type: zip Arial_font_family.zip (1.89 MB, 100 views)
My System SpecsSystem Spec
Reply

 Problem with Arial Bold Font




Thread Tools



Similar help and support threads for2: Problem with Arial Bold Font
Thread Forum
Bold font problem in programs (Not the average problem) General Discussion
Solved Windows 7 bold font by default problem - solved Customization
Bold font only in some programs Customization
Font is bold inside most app windows!? HEELP :/ Customization
Arial font is bold or italicized General Discussion
Bold font in programs General Discussion
System uses bold font Customization

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:51 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33