Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: weird autoplay problem

02 Nov 2012   #1
dymmy

windows 7 pro
 
 
weird autoplay problem

hi can someone help. I have been trying to solve this one for a while. Whenever i put my driver disk that came with my motherboard or indeed any other disk with software on it the autorun feature works but not the 'install software' box 'run.exe' option. In autoplay the option is to ask each time and there is nowhere i can reset or configure it to ask me if i want to install or run the auto setup file. If i open the disk and click on the setup.exe file myself it runs but wont let me see the window as it did it is there as an open folder on the bottom right of taskbar but only shows me the thumbnail of the folder and refuses to actually open it. I therefore cannot use the interface to choose which software or hardware to install. All other softwaree disks wont autorun only they will if i manually click on the setup.exe but something has interferd with the way it used to work fine.


My System SpecsSystem Spec
.
02 Nov 2012   #2
dymmy

windows 7 pro
 
 

Quote   Quote: Originally Posted by dymmy View Post
hi can someone help. I have been trying to solve this one for a while. Whenever i put my driver disk that came with my motherboard or indeed any other disk with software on it the autorun feature works but not the 'install software' box 'run.exe' option. In autoplay the option is to ask each time and there is nowhere i can reset or configure it to ask me if i want to install or run the auto setup file. If i open the disk and click on the setup.exe file myself it runs but wont let me see the window as it did it is there as an open folder on the bottom right of taskbar but only shows me the thumbnail of the folder and refuses to actually open it. I therefore cannot use the interface to choose which software or hardware to install. All other softwaree disks wont autorun only they will if i manually click on the setup.exe but something has interferd with the way it used to work fine.
shellhwdetection is automatic and the DVD drive i use is external USB one
My System SpecsSystem Spec
02 Nov 2012   #3
indianacarnie

 

Give your machine a through cleaning and then run a sfc /scannow. Do you have a VMware installed?
My System SpecsSystem Spec
.

02 Nov 2012   #4
dymmy

windows 7 pro
 
 

no vmware. sfc completes with no errors
i get this :

when i used to get this :


Attached Images
weird autoplay problem-autoplay.jpg weird autoplay problem-tagoreillycom20091001oreillyimages326561.png.jpg 
My System SpecsSystem Spec
02 Nov 2012   #5
indianacarnie

 

Hmmmmmmm......... I'd still recommend a sfc /scannow, but then..... lol..... I recommend that alot. Its saved my bacon many times over then years. Have you tried a restore to before the time you forced it to install/recognise the rom drive?
My System SpecsSystem Spec
02 Nov 2012   #6
dymmy

windows 7 pro
 
 

there is no restore thats relevant seems to only go back one day. Its a new pc and have been installing allsorts over the past week.
My System SpecsSystem Spec
02 Nov 2012   #7
indianacarnie

 

I don't know if this is relevant or not but have you read this?

AutoRun changes in Windows 7 - Security Research & Defense - Site Home - TechNet Blogs

Try , if you haven't yet , running your A/V and malware programs
My System SpecsSystem Spec
02 Nov 2012   #8
dymmy

windows 7 pro
 
 

Quote   Quote: Originally Posted by indianacarnie View Post
I don't know if this is relevant or not but have you read this?

AutoRun changes in Windows 7 - Security Research & Defense - Site Home - TechNet Blogs

Try , if you haven't yet , running your A/V and malware programs
no malware at all I have Kaspersky running always. I did read this and as when i first used this disk via my usb/dvd reader it worked and gave me the run option which booted the desired UI that i need to run and choose the relevant drivers/software I am assuming it should work now. Maybe an update of windows 7 has changed this. Does the definition of a usb drive mean a 'stick' or indeed as i am using a dvd read/writer I am assuming they mean a usb stick. Basically any software disk I have bundled from manufacturers will not autorun and few will allow me to manually run setup the one from ASUS will not even do that now !

ie this will not happen on my machine:
http://blogs.technet.com/blogfiles/s...B1/image_8.png
My System SpecsSystem Spec
02 Nov 2012   #9
indianacarnie

 

I hesitate to to say this as you obviously have some experience here ..... but have you changed and/or looked at the settings for autoplay software and games? (Control panel > Hardware and Sound > Autoplay)
Theres an option to "Install or Run program from your media". Running out of suggestions here...... sorry

I must say the lack of restore points worries me as Windows will usually make a new restore point for each new program installation. And you say you've been installing a lot of software this past week.
My System SpecsSystem Spec
02 Nov 2012   #10
dymmy

windows 7 pro
 
 

I have and even when i change the setting to ask every time to 'install or run from media' it makes no difference at all and always brings up the generic :

thx for your help I did a bit of deleting files to clean up and rediscover my lost 50gb that was being taken up by restore files and paging files etc. Thats when i lost my restore options. Too much knowledge is a hinderance


Attached Images
weird autoplay problem-autoplay.jpg 
My System SpecsSystem Spec
Reply

 weird autoplay problem




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Portable devices not listed in Autoplay option . Won't pop autoplay.
Hi I have protable device that won't autoplay when plugged , but it is shown in my computer and it's fully functional , it is not visible in the Autoplay option in the control panel , I tried reinstalling the device , but same thing , I followed Shawn's topic , how to set autoplay for...
Hardware & Devices
autorun/autoplay problem
Hi. I have a problem with CD/DVD ROM autorun. when I insert a disc in CD/DVD ROM,The autorun or autoplay doesn't work. how can i repair this problem? thanks
General Discussion
autoplay problem
Hi all :geek: when i go to control panel>autoplay>pictures , i dont have any option "view with photo viewer" /view using windows . photo viewer option is just not there. i'ts funny because in vista there is an option "view using windows" so my 1st question is - does somebody has a pictures...
General Discussion
Yet another autoplay problem
Hi all, A problem with autoplay popped up yesterday. When I plug in a digital still camera, autoplay appears to be completely broken. None of the apps assigned to the device in the autoplay settings will start when the device is plugged in. I've tried disabling/re-enabling autoplay, checking...
Hardware & Devices
AutoPlay problem...
I have three external hard drives and one external disk drive. Every time my computer starts up when I turn it on, two of the external hard drives autostart as does the external disk drive (if there's a disk in it). This has only started happening today and has never happened in the past. I...
General Discussion
AutoPlay Problem
Hi all, I have installed MP Navigator, a scanner program for my printer Canon MP 180, yesterday. Then, I noticed that when I plug my USB disk, this program starts. I think it did sometihng my autorun settings. Then I unistalled the program but now my autoplay does not work. I mean when I plug...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:00.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App